summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-08-21 15:09:38 +0000
committerTilman Klar <phoenix@gentoo.org>2002-08-21 15:09:38 +0000
commit317bdff71d701bd56bac122fad65e27512a63ef2 (patch)
tree439a69e814c076b1a0d7bba948027688bb741450 /sys-apps/modutils/modutils-2.4.19.ebuild
parentMasked modutils-2.4.19 (diff)
downloadgentoo-2-317bdff71d701bd56bac122fad65e27512a63ef2.tar.gz
gentoo-2-317bdff71d701bd56bac122fad65e27512a63ef2.tar.bz2
gentoo-2-317bdff71d701bd56bac122fad65e27512a63ef2.zip
Bumped to new version in order to fix bug 6730.
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.19.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.19.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.19.ebuild b/sys-apps/modutils/modutils-2.4.19.ebuild
new file mode 100644
index 000000000000..32df48ce0673
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.19.ebuild,v 1.1 2002/08/21 15:09:38 phoenix Exp $
+
+SLOT="0"
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/${P}.tar.bz2"
+HOMEPAGE=""
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die "make install failed"
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+