summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-11 10:38:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-11 10:38:53 +0000
commit0fffe8a3bba24179da81a45ffc7b7c34ca0b49cf (patch)
treef1cc70a050d78dcf6b4d57fee0121cba8ca8b73d /sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
parentremoving unused diffs (diff)
downloadgentoo-2-0fffe8a3bba24179da81a45ffc7b7c34ca0b49cf.tar.gz
gentoo-2-0fffe8a3bba24179da81a45ffc7b7c34ca0b49cf.tar.bz2
gentoo-2-0fffe8a3bba24179da81a45ffc7b7c34ca0b49cf.zip
microcode_ctl moved to microcode-ctl
Diffstat (limited to 'sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild')
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
new file mode 100644
index 000000000000..8071f7ed3b30
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild,v 1.1 2003/02/11 10:38:24 seemant Exp $
+
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2
+ http://cvs.gentoo.org/~seemant/${P}-gentoo.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -hppa -mips -alpha"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ make all || die "compile problem"
+}
+
+src_install() {
+ into /usr/
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+ insinto /etc/
+ doins ${WORKDIR}/${PV}/microcode.dat
+ exeinto /etc/init.d/
+ doexe ${WORKDIR}/${PV}/microcode_ctl
+}
+
+pkg_postinst() {
+ einfo "Your kernel must include both devfs and microcode update support."
+ echo
+ einfo "To update the microcode now, run"
+ einfo ""
+ einfo "\tmicrocode_ctl -u"
+ einfo ""
+ einfo "The update will not survive a reboot. To have it do that run"
+ einfo ""
+ einfo "\trc-update add microcode_ctl default"
+}