summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-09-30 01:10:41 +0000
committerDonny Davies <woodchip@gentoo.org>2002-09-30 01:10:41 +0000
commitf40f1513e6f7c53faeba38e918107390b20bd0a2 (patch)
treeec1f98ba1c9208fe956d9402dc16f92adc4f23d5 /sys-apps/memtest86
parentfixes from #7903 (diff)
downloadgentoo-2-f40f1513e6f7c53faeba38e918107390b20bd0a2.tar.gz
gentoo-2-f40f1513e6f7c53faeba38e918107390b20bd0a2.tar.bz2
gentoo-2-f40f1513e6f7c53faeba38e918107390b20bd0a2.zip
use mount-boot eclass; #7903
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog13
-rw-r--r--sys-apps/memtest86/memtest86-3.0.ebuild32
2 files changed, 11 insertions, 34 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index 14a0b4841248..9b33dbc55d1d 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,17 +1,16 @@
# ChangeLog for sys-apps/memtest86
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.6 2002/09/25 15:04:24 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.7 2002/09/30 01:05:42 woodchip Exp $
*memtest86-3.0 (03 Jun 2002)
- 25 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org> :
- memtest86-3.0.ebuild :
+ 29 Sep 2002; Donny Davies <woodchip@gentoo.org> :
+ Now uses mount-boot eclass, #7903.
- Applied hanno's ebuild from
- http://bugs.gentoo.org/show_bug.cgi?id=4088 to fix my bad.
+ 25 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org> :
+ Applied hanno's ebuild from http://bugs.gentoo.org/show_bug.cgi?id=4088 to fix my bad.
24 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org> :
-
Replace patch with mandrake patch. Still doesn't seem to work
properly though. Contacting upstream on this...
@@ -26,10 +25,8 @@
Added KEYWORDS.
03 Jun 2002; Karl Trygve Kalleberg <karltk@gentoo.org> memtest86-3.0.ebuild files/digest-memtest86-3.0 :
-
Memtest86 is thorough, stand alone memory test for x86 architecture
computers. BIOS based memory tests are only a quick check and often miss
many of the failures that are detected by Memtest86.
Ebuild submitted by Alastair Nicol <ifni@blueyonder.co.uk>.
-
diff --git a/sys-apps/memtest86/memtest86-3.0.ebuild b/sys-apps/memtest86/memtest86-3.0.ebuild
index acb82357099c..1f6adc1e8da4 100644
--- a/sys-apps/memtest86/memtest86-3.0.ebuild
+++ b/sys-apps/memtest86/memtest86-3.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.0.ebuild,v 1.7 2002/09/25 15:04:24 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.0.ebuild,v 1.8 2002/09/30 01:05:42 woodchip Exp $
+
+inherit mount-boot
S=${WORKDIR}/${P}
DESCRIPTION="A stand alone memory test for x86 computers"
@@ -11,31 +13,11 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="virtual/glibc"
-RDEPEND=""
-
-pkg_setup() {
- [ "$ROOT" != "/" ] && return 0
- #If the user doesn't have a /boot or /mnt/boot filesystem, skip.
- [ -z "`grep /boot /etc/fstab | grep -v "^[ \t]*#"`" ] || return 0
- local myboot
- myboot=`cat /etc/fstab | grep -v ^# | grep /boot | sed -e 's/^[^[:space:]]*[[:space:]]*\([^[:space:]]*\).*$/\1/'`
- [ `cat /proc/mounts | cut -f2 -d" " | grep $myboot` ] && return 0
- mount $myboot
- if [ $? -ne 0 ]
- then
- eerror "MEMTEST86 installation requires that $myboot is mounted or mountable."
- eerror "If you do not have a seperate /boot partition please remove any"
- eerror "/boot entries from /etc/fstab and make sure /boot exists."
- eerror ""
- eerror "Unable to mount $myboot automatically; exiting."
- die "Please mount your $myboot filesystema and remerge this ebuild."
- fi
-}
+RDEPEND="${DEPEND}"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p1<${FILESDIR}/memtest86-3.0-gcc3-gentoo.patch || die
+ unpack ${A} ; cd ${S}
+ patch -p1 <${FILESDIR}/memtest86-3.0-gcc3-gentoo.patch || die
}
src_compile() {
@@ -45,12 +27,10 @@ src_compile() {
src_install() {
dodir /boot/memtest86
cp memtest.bin ${D}/boot/memtest86
-
dodoc README README.build-process
}
pkg_postinst() {
-
einfo '*** memtest.bin has been installed in /boot/memtest86, please remember to'
einfo '*** update your boot loader. For example grub :'
einfo "*** edit /boot/grub/menu.lst and add the following lines "