summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Silva <r3pek@gentoo.org>2005-12-26 14:31:44 +0000
committerCarlos Silva <r3pek@gentoo.org>2005-12-26 14:31:44 +0000
commit9903dadedb536722609f1a8c93185de24169686c (patch)
treeefffee561cd13f611ef22ed7c184973ed4be0743 /sys-apps/lkcp/lkcp-0.5.4.ebuild
parentoggvorbis Cleanup (diff)
downloadgentoo-2-9903dadedb536722609f1a8c93185de24169686c.tar.gz
gentoo-2-9903dadedb536722609f1a8c93185de24169686c.tar.bz2
gentoo-2-9903dadedb536722609f1a8c93185de24169686c.zip
Version bump. Removed old version
(Portage version: 2.0.53)
Diffstat (limited to 'sys-apps/lkcp/lkcp-0.5.4.ebuild')
-rw-r--r--sys-apps/lkcp/lkcp-0.5.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/lkcp/lkcp-0.5.4.ebuild b/sys-apps/lkcp/lkcp-0.5.4.ebuild
new file mode 100644
index 000000000000..309b8b7aed4c
--- /dev/null
+++ b/sys-apps/lkcp/lkcp-0.5.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lkcp/lkcp-0.5.4.ebuild,v 1.1 2005/12/26 14:31:44 r3pek Exp $
+
+DESCRIPTION="Live Kernel Configuration Panel is an ncurses interface to the run-time Linux kernel configuration data (/proc)"
+HOMEPAGE="http://freshmeat.net/projects/lkcp"
+SRC_URI="https://webspace.utexas.edu/~hyoussef/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE="doc"
+
+DEPEND="sys-libs/ncurses
+ =dev-libs/glib-1*"
+
+src_compile() {
+ cd ${S}/src
+ sed -i -e '/^LKCPDIR/s:\/usr\/local\/bin:\$(DESTDIR)\/usr\/bin:' \
+ -e '/^\t@$(ECHO) $(ECHOFLAGS) "\\n"$/d' \
+ -e '/^\t@$(ECHO) $(ECHOFLAGS) \[+\] Resetting your terminal\.\.\.$/d' \
+ -e '/^\t@$(RESET)$/d' Makefile || die "sed failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}/src
+ dodir /usr/bin
+ make install DESTDIR="${D}" || die "einstall failed"
+ cd ${S}
+ mv LICENCE LICENSE
+ dodoc AUTHORS CREDITS Changelog README TODO LICENSE
+ if use doc; then
+ docinto Documentation
+ dodoc Documentation/{FSSearch.feature,LKCP.dia,LKCP_diagram-OUTDATED.png,LKCP.Shortcomings,proc.txt,sampledox.conf,ScriptDump.feature}
+ fi
+}