summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-11-06 21:20:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-11-06 21:20:57 +0000
commitde851564ad1862327df40c169d0b0d6ad24694d4 (patch)
tree5b8daa48b81fe43ea44b1b02ab3f8e5d86cc926f /sys-apps/lilo
parentGet the build to actually use gcc as gcc; remove the hardened crap. (diff)
downloadgentoo-2-de851564ad1862327df40c169d0b0d6ad24694d4.tar.gz
gentoo-2-de851564ad1862327df40c169d0b0d6ad24694d4.tar.bz2
gentoo-2-de851564ad1862327df40c169d0b0d6ad24694d4.zip
Get the build to actually use gcc as gcc; remove the hardened crap.
Diffstat (limited to 'sys-apps/lilo')
-rw-r--r--sys-apps/lilo/ChangeLog7
-rw-r--r--sys-apps/lilo/Manifest5
-rw-r--r--sys-apps/lilo/files/digest-lilo-22.5.8-r11
-rw-r--r--sys-apps/lilo/lilo-22.5.8-r1.ebuild165
4 files changed, 174 insertions, 4 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index 87261ebe0e68..df4085640f00 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.35 2003/10/13 18:38:00 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.36 2003/11/06 21:20:47 azarah Exp $
+
+*lilo-22.5.8-r1 (06 Nov 2003)
+
+ 06 Nov 2003; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.8-r1.ebuild:
+ Get the build to actually use gcc as $CC; remove the hardened crap.
*lilo-22.5.8 (13 Oct 2003)
diff --git a/sys-apps/lilo/Manifest b/sys-apps/lilo/Manifest
index e8d98682f5d4..882b82e4ed90 100644
--- a/sys-apps/lilo/Manifest
+++ b/sys-apps/lilo/Manifest
@@ -1,10 +1,9 @@
-MD5 ee20b8a396e19e59a19ccc7c92783281 lilo-22.5.8-r1.ebuild 3813
+MD5 cd4fe3a441ea7ebb65db9ed6c14a9d7c lilo-22.5.8-r1.ebuild 3924
MD5 47b444bfb2e1822691b4e62caf2ad676 lilo-22.5.8.ebuild 4040
MD5 b7a131091da3273481f41861e53fa3e7 lilo-22.5.7.2.ebuild 3982
MD5 9d48349e4847a7aa2a6824848c57e8f2 lilo-22.3.3-r1.ebuild 1998
-MD5 8f3d7f755b1858ca7f1aabb0ed4f310f .lilo-22.5.8-r1.ebuild.swp 16384
MD5 de524e597e1f7dca066a53678896ef2f lilo-22.5.6-r2.ebuild 3437
-MD5 2e64abb6e6eff6289ff5bd7c0ba9f0d3 ChangeLog 5756
+MD5 676999103e59cff3a7cb0e2e480049ff ChangeLog 5933
MD5 7dd6ff54cf104acb2bf33b4c22b85460 lilo-22.3.4.ebuild 2003
MD5 69ded17592f9b6efa8bc67ba9e268c12 lilo-22.1-r3.ebuild 1583
MD5 00330f65a2830960c48511693c96eb7a lilo-22.5.1.ebuild 4575
diff --git a/sys-apps/lilo/files/digest-lilo-22.5.8-r1 b/sys-apps/lilo/files/digest-lilo-22.5.8-r1
new file mode 100644
index 000000000000..c77f9da7dc05
--- /dev/null
+++ b/sys-apps/lilo/files/digest-lilo-22.5.8-r1
@@ -0,0 +1 @@
+MD5 3f7a440d198af6715aa3e5b7310e08ef lilo-22.5.8.tar.gz 412078
diff --git a/sys-apps/lilo/lilo-22.5.8-r1.ebuild b/sys-apps/lilo/lilo-22.5.8-r1.ebuild
new file mode 100644
index 000000000000..b894509cc02c
--- /dev/null
+++ b/sys-apps/lilo/lilo-22.5.8-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.8-r1.ebuild,v 1.1 2003/11/06 21:20:47 azarah Exp $
+
+inherit mount-boot eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard Linux boot loader"
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${P}.tar.gz"
+# mirror://gentoo/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://lilo.go.dyndns.org/pub/linux/lilo/"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86"
+
+DEPEND="dev-lang/nasm
+ >=sys-devel/bin86-0.15.5"
+
+PROVIDE="virtual/bootloader"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ # Do not try and build the dos crap.
+ sed -i -e 's|^all:.*$|all: lilo|' ${S}/Makefile
+
+ # This bootlogo patch is borrowed from SuSE Linux.
+ # You should see Raphaël Quinet's (quinet@gamers.org) website,
+ # http://www.gamers.org/~quinet/lilo/index.html
+ #
+ # Update for 22.5 by Quequero (bug #19397):
+ #
+ # I've adapted and edited this patch from and older version
+ # For problems email me.
+ # Quequero <quequerp@bitchx.it>
+ #
+# cd ${S}; epatch ${FILESDIR}/${P}-animated-menu.patch
+
+ # Fixup things for glibc-2.3.3 (and later CVS versions of 2.3.2)
+ cd ${S}; epatch ${FILESDIR}/${PN}-22.5.6-glibc233.patch
+}
+
+src_compile() {
+
+ emake CC="${CC:=gcc}" lilo || die
+}
+
+src_install() {
+ keepdir /boot
+ make CC="${CC:=gcc}" \
+ ROOT=${D} install || die
+ into /usr
+ dosbin keytab-lilo.pl
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+}
+
+pkg_preinst() {
+ mount-boot_mount_boot_partition
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ [ -f "${ROOT}/boot/boot-menu.b" ] && \
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ if lilocheck
+ then
+ einfo "Running LILO to complete the install ..."
+ # do not redirect to /dev/null because it may display some input
+ # prompt
+ /sbin/lilo
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/lilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ sleep 5
+ fi
+ fi
+ echo
+ fi
+
+ echo
+ einfo "Please note that all the loader files (/boot/*.b) is now linked"
+ einfo "into LILO, and thus no longer installed."
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ sleep 3
+ echo
+}
+