summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-04-18 11:54:40 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-04-18 11:54:40 +0000
commit2a323fdb3c406d6a6840c8b9c0982bd6ea5d6289 (patch)
tree2aa5abc62376ff713ae3fea40b6ed6fdc8432a4a /sys-apps/ivman
parent- reverted 2.0.54-r1 for now. Have to move patches into a tarball (diff)
downloadgentoo-2-2a323fdb3c406d6a6840c8b9c0982bd6ea5d6289.tar.gz
gentoo-2-2a323fdb3c406d6a6840c8b9c0982bd6ea5d6289.tar.bz2
gentoo-2-2a323fdb3c406d6a6840c8b9c0982bd6ea5d6289.zip
Version bump fixes #129309 and #129330
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'sys-apps/ivman')
-rw-r--r--sys-apps/ivman/ChangeLog8
-rw-r--r--sys-apps/ivman/files/digest-ivman-0.6.113
-rw-r--r--sys-apps/ivman/ivman-0.6.11.ebuild67
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-apps/ivman/ChangeLog b/sys-apps/ivman/ChangeLog
index e7473471baff..3ae3b85743c0 100644
--- a/sys-apps/ivman/ChangeLog
+++ b/sys-apps/ivman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/ivman
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.31 2006/04/08 18:09:40 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.32 2006/04/18 11:54:39 genstef Exp $
+
+*ivman-0.6.11 (18 Apr 2006)
+
+ 18 Apr 2006; Stefan Schweizer <genstef@gentoo.org> -ivman-0.5_pre2.ebuild,
+ -ivman-0.6.10.ebuild, +ivman-0.6.11.ebuild:
+ Version bump fixes #129309 and #129330
08 Apr 2006; Simon Stelling <blubb@gentoo.org> ivman-0.6.8.ebuild:
stable on amd64
diff --git a/sys-apps/ivman/files/digest-ivman-0.6.11 b/sys-apps/ivman/files/digest-ivman-0.6.11
new file mode 100644
index 000000000000..c7fc83e830f8
--- /dev/null
+++ b/sys-apps/ivman/files/digest-ivman-0.6.11
@@ -0,0 +1,3 @@
+MD5 440db00c2d59c4d408812c9868ac4b32 ivman-0.6.11.tar.bz2 312191
+RMD160 cc7f3604e1984cbe2d75014f8a6f6ac163a6ca8a ivman-0.6.11.tar.bz2 312191
+SHA256 00a6f2be36a2a62cb6bf1b1c6d3f562aee168424e80f0bf378400930ebc1ae43 ivman-0.6.11.tar.bz2 312191
diff --git a/sys-apps/ivman/ivman-0.6.11.ebuild b/sys-apps/ivman/ivman-0.6.11.ebuild
new file mode 100644
index 000000000000..35282d7b60a8
--- /dev/null
+++ b/sys-apps/ivman/ivman-0.6.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ivman-0.6.11.ebuild,v 1.1 2006/04/18 11:54:39 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon to mount/unmount devices, based on info from HAL"
+HOMEPAGE="http://ivman.sf.net"
+SRC_URI="mirror://sourceforge/ivman/${P}.tar.bz2"
+LICENSE="GPL-2 QPL"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/libxml2
+ sys-devel/gettext
+ >=sys-apps/hal-0.4.0
+ >=sys-apps/pmount-0.8"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/ivman-0.3.init ivman
+}
+
+pkg_postinst() {
+ # Ivman can now run as a non-root user :-) Create a dedicated user account,
+ # so users can add rules to /etc/sudoers for programs Ivman wants to
+ # execute...
+ # The group here is intended to be the one needed to use pmount, but Ivman
+ # will still work as long as the group in IvmConfigBase.xml is correct.
+ enewuser ivman -1 -1 /dev/null plugdev || die "Problem adding ivman user"
+
+ if has_version "<sys-apps/hal-0.5.0"; then
+ einfo "Ivman was built against HAL 0.4.x. If you later upgrade to HAL 0.5,"
+ einfo "you must re-merge Ivman."
+ echo
+ else
+ einfo "Ivman was built against HAL 0.5.x. If you later downgrade to HAL 0.4,"
+ einfo "you must re-merge Ivman."
+ echo
+ fi
+
+ einfo "Note that, as of version 0.6.0, the IvmConfigMappings.xml configuration"
+ einfo "file is no longer required to correctly mount fstab entries which"
+ einfo "use symbolic links. You may safely remove this file if desired."
+ einfo "However, HAL typically does not correctly deal with fstab"
+ einfo "entries of this nature, therefore it is strongly recommanded that"
+ einfo "you have real device names (i.e. not symlinks) in /etc/fstab."
+ echo
+
+ einfo "By default, Ivman will mount any removable disks as they are"
+ einfo "attached. If you want Ivman to do more, such as hibernating"
+ einfo "your laptop when the lid is closed or when the battery is low,"
+ einfo "look at the configuration files in /etc/ivman/ ."
+}