summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-15 06:08:35 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-15 06:08:35 +0000
commitbd180b522c6cf82923675102c2112206079a3568 (patch)
treeb10e57ec7446369adb736be428a705b390348122 /sys-apps/irqbalance/irqbalance-0.55-r2.ebuild
parentfix bug #216944 and other assorted issues (diff)
downloadgentoo-2-bd180b522c6cf82923675102c2112206079a3568.tar.gz
gentoo-2-bd180b522c6cf82923675102c2112206079a3568.tar.bz2
gentoo-2-bd180b522c6cf82923675102c2112206079a3568.zip
fix bug #212226, patch from Rene Neumann <gentoo@necoro.eu>
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sys-apps/irqbalance/irqbalance-0.55-r2.ebuild')
-rw-r--r--sys-apps/irqbalance/irqbalance-0.55-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild b/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild
new file mode 100644
index 000000000000..3662c3806400
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55-r2.ebuild,v 1.1 2008/04/15 06:08:35 cardoe Exp $
+
+inherit eutils
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="http://www.irqbalance.org/"
+SRC_URI="http://www.irqbalance.org/releases/${P}.tar.gz"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="=dev-libs/glib-2*
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ into /
+ dosbin irqbalance || die "dosbin failed"
+ doman "${FILESDIR}"/irqbalance.1
+ newinitd "${FILESDIR}"/irqbalance.init-0.55-r2 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd irqbalance
+}