summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-08 19:35:59 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-08 19:35:59 +0000
commitb2299ca5a6b66a016c96e9c99cc3c480a624e2e3 (patch)
tree1924faa4942d37c878108262d3eec1ab1d917361 /sys-apps/initng
parentarm/s390/sh stable (diff)
downloadgentoo-2-b2299ca5a6b66a016c96e9c99cc3c480a624e2e3.tar.gz
gentoo-2-b2299ca5a6b66a016c96e9c99cc3c480a624e2e3.tar.bz2
gentoo-2-b2299ca5a6b66a016c96e9c99cc3c480a624e2e3.zip
Version bump #250214 by lindevel.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/initng')
-rw-r--r--sys-apps/initng/ChangeLog11
-rw-r--r--sys-apps/initng/files/initng-0.6.10.2-logfile-open.patch17
-rw-r--r--sys-apps/initng/initng-0.6.10.2.ebuild82
-rw-r--r--sys-apps/initng/initng-9999.ebuild31
4 files changed, 130 insertions, 11 deletions
diff --git a/sys-apps/initng/ChangeLog b/sys-apps/initng/ChangeLog
index 3a91f793ef70..7138e9c8766e 100644
--- a/sys-apps/initng/ChangeLog
+++ b/sys-apps/initng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/initng
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/ChangeLog,v 1.43 2007/08/25 17:59:38 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/ChangeLog,v 1.44 2009/02/08 19:35:58 vapier Exp $
+
+*initng-0.6.10.2 (08 Feb 2009)
+
+ 08 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/initng-0.6.10.2-logfile-open.patch, +initng-0.6.10.2.ebuild,
+ initng-9999.ebuild:
+ Version bump #250214 by lindevel.
25 Aug 2007; Mike Frysinger <vapier@gentoo.org> initng-0.6.10.1.ebuild,
initng-9999.ebuild:
diff --git a/sys-apps/initng/files/initng-0.6.10.2-logfile-open.patch b/sys-apps/initng/files/initng-0.6.10.2-logfile-open.patch
new file mode 100644
index 000000000000..866f5777e84e
--- /dev/null
+++ b/sys-apps/initng/files/initng-0.6.10.2-logfile-open.patch
@@ -0,0 +1,17 @@
+r5239 | dragoran | 2007-08-07 07:54:17 -0400 (Tue, 07 Aug 2007) | 1 line
+
+fix build with glibc >= 2.6.90
+
+Index: src/plugins/logfile/initng_logfile.c
+===================================================================
+--- src/plugins/logfile/initng_logfile.c (revision 5238)
++++ src/plugins/logfile/initng_logfile.c (revision 5239)
+@@ -71,7 +71,7 @@ static int program_output(s_event * event)
+ filename_fixed = fix_variables(filename, data->service);
+
+ /* open the file */
+- fd = open(filename, O_WRONLY | O_CREAT | O_APPEND);
++ fd = open(filename, O_WRONLY | O_CREAT | O_APPEND, 0644);
+ if (fd < 1)
+ {
+ F_("Error opening %s, err : %s\n", filename, strerror(errno));
diff --git a/sys-apps/initng/initng-0.6.10.2.ebuild b/sys-apps/initng/initng-0.6.10.2.ebuild
new file mode 100644
index 000000000000..3a148ff07380
--- /dev/null
+++ b/sys-apps/initng/initng-0.6.10.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.6.10.2.ebuild,v 1.1 2009/02/08 19:35:58 vapier Exp $
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://svn.initng.org/initng/trunk"
+ ESVN_PROJECT="initng"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="http://download.initng.org/initng/v${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+inherit eutils multilib
+
+DESCRIPTION="A next generation init replacement"
+HOMEPAGE="http://initng.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.1"
+PDEPEND="sys-apps/initng-ifiles"
+
+plugin_warning() {
+ if [[ -z ${INITNG_PLUGINS} ]] ; then
+ einfo "If you want to customize the list of initng plugins, please"
+ einfo "set the INITNG_PLUGINS variable in your make.conf."
+ einfo "See http://www.initng.org/wiki/Documents_Plugins for a list of"
+ einfo "valid plugins for you to choose from."
+ fi
+}
+
+pkg_setup() {
+ plugin_warning
+}
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ sed -i -e 's:-Werror::' CMakeLists.txt #136992
+ epatch "${FILESDIR}"/${P}-logfile-open.patch
+}
+
+src_compile() {
+ local x default_opts valid_opts cmake_opts=""
+ valid_opts=$(sed -n '/^OPTION/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
+ default_opts=$(sed -n '/^OPTION(.*ON)$/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
+ INITNG_PLUGINS=$(echo ${INITNG_PLUGINS} | tr '[:lower:]' '[:upper:]')
+ INITNG_PLUGINS=${INITNG_PLUGINS:-${default_opts}}
+ for x in ${valid_opts} ; do
+ if hasq ${x} ${INITNG_PLUGINS} || hasq ${x#BUILD_} ${INITNG_PLUGINS} ; then
+ cmake_opts="${cmake_opts} -D${x}=ON"
+ else
+ cmake_opts="${cmake_opts} -D${x}=OFF"
+ fi
+ done
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DLIB_INSTALL_DIR=/$(get_libdir) \
+ ${cmake_opts} || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.a' -exec rm "{}" \;
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ plugin_warning
+ einfo "Remember to add init=/sbin/initng in your grub or lilo config"
+ einfo " in order to use initng. Happy testing!"
+}
diff --git a/sys-apps/initng/initng-9999.ebuild b/sys-apps/initng/initng-9999.ebuild
index 172bb8ebd107..2bc87a082bfe 100644
--- a/sys-apps/initng/initng-9999.ebuild
+++ b/sys-apps/initng/initng-9999.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.12 2007/08/25 17:59:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.13 2009/02/08 19:35:58 vapier Exp $
-ESVN_REPO_URI="http://svn.initng.org/initng/trunk"
-ESVN_PROJECT="initng"
-inherit subversion multilib
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://svn.initng.org/initng/trunk"
+ ESVN_PROJECT="initng"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="http://download.initng.org/initng/v${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+inherit eutils multilib
DESCRIPTION="A next generation init replacement"
HOMEPAGE="http://initng.org/"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
RDEPEND=""
@@ -20,8 +25,6 @@ DEPEND="${RDEPEND}
>=dev-util/cmake-2.1"
PDEPEND="sys-apps/initng-ifiles"
-S=${WORKDIR}/${PN}
-
plugin_warning() {
if [[ -z ${INITNG_PLUGINS} ]] ; then
einfo "If you want to customize the list of initng plugins, please"
@@ -35,6 +38,16 @@ pkg_setup() {
plugin_warning
}
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ sed -i -e 's:-Werror::' CMakeLists.txt #136992
+}
+
src_compile() {
local x default_opts valid_opts cmake_opts=""
valid_opts=$(sed -n '/^OPTION/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)