summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 15:53:45 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 15:53:45 +0000
commit32353b2c7831417031440ae1283d264e5a4f1894 (patch)
treefa3c8f750cf89e94421c695d86068e34856448cf /sys-apps/hwloc/hwloc-1.2-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-32353b2c7831417031440ae1283d264e5a4f1894.tar.gz
gentoo-2-32353b2c7831417031440ae1283d264e5a4f1894.tar.bz2
gentoo-2-32353b2c7831417031440ae1283d264e5a4f1894.zip
[sys-apps/hwloc] Update deps
Commited with force option because jer dont permit modiffication of profiles/arch/hppa/package.use.mask (Portage version: 2.2.0_alpha51/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-apps/hwloc/hwloc-1.2-r1.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-1.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/hwloc/hwloc-1.2-r1.ebuild b/sys-apps/hwloc/hwloc-1.2-r1.ebuild
new file mode 100644
index 000000000000..6febb9f1c49c
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2-r1.ebuild,v 1.1 2011/08/31 15:53:45 alexxy Exp $
+
+EAPI="4"
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cairo +numa svg static-libs xml X"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ numa? ( sys-process/numactl )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable cairo) \
+ $(use_enable static-libs static) \
+ $(use_enable xml) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README VERSION
+ use static-libs || rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+}