summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-24 05:07:51 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-24 05:07:51 +0000
commit790a51252f75cc607da2c75a4eb52a2ad7fdbe07 (patch)
tree779e5a3e92ab9284d834899efdde2a295b38ed94 /sys-apps/hwinfo
parentUse PYTHON_USE_WITH to check for sqlite availability and drop alternate (diff)
downloadgentoo-2-790a51252f75cc607da2c75a4eb52a2ad7fdbe07.tar.gz
gentoo-2-790a51252f75cc607da2c75a4eb52a2ad7fdbe07.tar.bz2
gentoo-2-790a51252f75cc607da2c75a4eb52a2ad7fdbe07.zip
Version bump (fixes bug #394357).
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwinfo')
-rw-r--r--sys-apps/hwinfo/ChangeLog9
-rw-r--r--sys-apps/hwinfo/hwinfo-19.1.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/sys-apps/hwinfo/ChangeLog b/sys-apps/hwinfo/ChangeLog
index baded7b95c08..86b360a8809f 100644
--- a/sys-apps/hwinfo/ChangeLog
+++ b/sys-apps/hwinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwinfo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.25 2011/12/13 23:12:40 ago Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.26 2012/02/24 05:07:51 radhermit Exp $
+
+*hwinfo-19.1 (24 Feb 2012)
+
+ 24 Feb 2012; Tim Harder <radhermit@gentoo.org> +hwinfo-19.1.ebuild:
+ Version bump (fixes bug #394357).
13 Dec 2011; Agostino Sarubbo <ago@gentoo.org> hwinfo-18.5.ebuild:
Stable for AMD64, wrt bug #392833
diff --git a/sys-apps/hwinfo/hwinfo-19.1.ebuild b/sys-apps/hwinfo/hwinfo-19.1.ebuild
new file mode 100644
index 000000000000..50aed8b87ace
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-19.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/hwinfo-19.1.ebuild,v 1.1 2012/02/24 05:07:51 radhermit Exp $
+
+EAPI=4
+inherit multilib rpm toolchain-funcs
+
+DESCRIPTION="hwinfo is the hardware detection tool used in SuSE Linux."
+HOMEPAGE="http://www.opensuse.org/"
+SRC_URI="http://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-1.2.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND="amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Avoid -I directories for dbus because HAL is obsolete.
+ sed -i -e '/CFLAGS/d' src/hd/Makefile || die
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) -shared:& $(LDFLAGS):' src/Makefile || die
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+
+ dodoc changelog README
+ doman doc/hwinfo.8
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/example*.c
+}