summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-05-23 19:38:43 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-05-23 19:38:43 +0000
commit5538ff2692e3d729b97cce1e70b1d0e04e98f25e (patch)
treedc85600570570b23afc5bbd869483ef53166ea46 /sys-apps/gawk
parentAdd kcmshell and systemsettings to dependencies, bug 550012 (diff)
downloadgentoo-2-5538ff2692e3d729b97cce1e70b1d0e04e98f25e.tar.gz
gentoo-2-5538ff2692e3d729b97cce1e70b1d0e04e98f25e.tar.bz2
gentoo-2-5538ff2692e3d729b97cce1e70b1d0e04e98f25e.zip
Version bump. Removed old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog9
-rw-r--r--sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch26
-rw-r--r--sys-apps/gawk/files/gawk-4.1.1-sigpipe.patch34
-rw-r--r--sys-apps/gawk/gawk-4.1.3.ebuild (renamed from sys-apps/gawk/gawk-4.1.1-r1.ebuild)6
4 files changed, 9 insertions, 66 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 8375cab81795..3528a01a4a93 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.181 2015/05/04 11:52:07 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.182 2015/05/23 19:38:43 polynomial-c Exp $
+
+*gawk-4.1.3 (23 May 2015)
+
+ 23 May 2015; Lars Wendler <polynomial-c@gentoo.org> -gawk-4.1.1-r1.ebuild,
+ +gawk-4.1.3.ebuild, -files/gawk-4.1.1-sandbox_issue.patch,
+ -files/gawk-4.1.1-sigpipe.patch:
+ Version bump. Removed old.
*gawk-4.1.2 (04 May 2015)
diff --git a/sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch b/sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch
deleted file mode 100644
index c64103550ce1..000000000000
--- a/sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix sandbox issue.
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-
---- gawk-4.1.1/extension/Makefile.am 2014-02-20 19:42:25.000000000 +0100
-+++ gawk-4.1.1/extension/Makefile.am 2014-02-20 19:42:25.000000000 +0100
-@@ -100,7 +100,7 @@
-
- install-data-hook:
- for i in $(pkgextension_LTLIBRARIES) ; do \
-- $(RM) $(pkgextensiondir)/$$i ; \
-+ $(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \
- done
-
- # Keep the uninstall check working:
---- gawk-4.1.1/extension/Makefile.in 2014-04-08 18:13:03.000000000 +0200
-+++ gawk-4.1.1/extension/Makefile.in 2014-04-08 18:13:03.000000000 +0200
-@@ -1231,7 +1231,7 @@
-
- install-data-hook:
- for i in $(pkgextension_LTLIBRARIES) ; do \
-- $(RM) $(pkgextensiondir)/$$i ; \
-+ $(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \
- done
-
- # Keep the uninstall check working:
diff --git a/sys-apps/gawk/files/gawk-4.1.1-sigpipe.patch b/sys-apps/gawk/files/gawk-4.1.1-sigpipe.patch
deleted file mode 100644
index a64e116f60ce..000000000000
--- a/sys-apps/gawk/files/gawk-4.1.1-sigpipe.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 19564e696aca506a14ceb4a08aa2b7c7988a2473 Mon Sep 17 00:00:00 2001
-From: Arnold D. Robbins <arnold@skeeve.com>
-Date: Fri, 25 Apr 2014 10:21:43 +0000
-Subject: In forked children, set SIGPIPE to SIG_DFL.
-
----
-* io.c (two_way_open): In forked child, reset SIGPIPE to SIG_DFL.
-Fixes problems with "broken pipe" errors from child processes,
-restoring 4.1.0 and earlier behavior. Thanks to Daryl F
-<wyatt@prairieturtle.ca> for the report.
-(gawk_popen): Ditto.
-
-diff --git a/io.c b/io.c
-index a6e786f..2bb8f28 100644
---- a/io.c
-+++ b/io.c
-@@ -2078,6 +2078,7 @@ use_pipes:
- || close(ctop[0]) == -1 || close(ctop[1]) == -1)
- fatal(_("close of pipe failed (%s)"), strerror(errno));
- /* stderr does NOT get dup'ed onto child's stdout */
-+ signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", str, NULL);
- _exit(errno == ENOENT ? 127 : 126);
- }
-@@ -2271,6 +2272,7 @@ gawk_popen(const char *cmd, struct redirect *rp)
- fatal(_("moving pipe to stdout in child failed (dup: %s)"), strerror(errno));
- if (close(p[0]) == -1 || close(p[1]) == -1)
- fatal(_("close of pipe failed (%s)"), strerror(errno));
-+ signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", cmd, NULL);
- _exit(errno == ENOENT ? 127 : 126);
- }
---
-cgit v0.9.0.2
diff --git a/sys-apps/gawk/gawk-4.1.1-r1.ebuild b/sys-apps/gawk/gawk-4.1.3.ebuild
index 2d3f24a5cc01..b560f6762bc5 100644
--- a/sys-apps/gawk/gawk-4.1.1-r1.ebuild
+++ b/sys-apps/gawk/gawk-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-4.1.1-r1.ebuild,v 1.2 2015/03/31 20:22:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-4.1.3.ebuild,v 1.1 2015/05/23 19:38:43 polynomial-c Exp $
EAPI="4"
@@ -21,10 +21,6 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_prepare() {
- EPATCH_OPTS="-Z" \
- epatch "${FILESDIR}"/${P}-sandbox_issue.patch
- epatch "${FILESDIR}"/${P}-sigpipe.patch #507340
-
# use symlinks rather than hardlinks, and disable version links
sed -i \
-e '/^LN =/s:=.*:= $(LN_S):' \