summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-09 17:28:54 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-09 17:28:54 +0000
commitb6b7af1a697afe591bcb6192b92428ba61d6e597 (patch)
treeb0dcd4ac3b2f91fddb9303785a84ab0537206379 /sys-apps/findutils
parentbump; added pypy support, fix to setup.cfg -> fixes testsuite, fixes Bug #468236 (diff)
downloadgentoo-2-b6b7af1a697afe591bcb6192b92428ba61d6e597.tar.gz
gentoo-2-b6b7af1a697afe591bcb6192b92428ba61d6e597.tar.bz2
gentoo-2-b6b7af1a697afe591bcb6192b92428ba61d6e597.zip
Update oldfind removal to include program prefix #469084 by Christian Bricart.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog5
-rw-r--r--sys-apps/findutils/findutils-4.5.11.ebuild13
2 files changed, 10 insertions, 8 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 9dbb7e7776ee..f5650d56dca0 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.213 2013/05/07 05:22:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.214 2013/05/09 17:28:54 vapier Exp $
+
+ 09 May 2013; Mike Frysinger <vapier@gentoo.org> findutils-4.5.11.ebuild:
+ Update oldfind removal to include program prefix #469084 by Christian Bricart.
07 May 2013; Fabian Groffen <grobian@gentoo.org> findutils-4.5.11.ebuild:
Fix for Prefix, bug #468786
diff --git a/sys-apps/findutils/findutils-4.5.11.ebuild b/sys-apps/findutils/findutils-4.5.11.ebuild
index e7c8c0a1f033..6b4aeb2c765e 100644
--- a/sys-apps/findutils/findutils-4.5.11.ebuild
+++ b/sys-apps/findutils/findutils-4.5.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.11.ebuild,v 1.2 2013/05/07 05:22:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.11.ebuild,v 1.3 2013/05/09 17:28:54 vapier Exp $
EAPI="3"
@@ -30,16 +30,14 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
- local myconf
- use userland_GNU || myconf=" --program-prefix=g"
-
+ local program_prefix=$(usex userland_GNU '' g)
econf \
--with-packager="Gentoo" \
--with-packager-version="${PVR}" \
--with-packager-bug-reports="http://bugs.gentoo.org/" \
+ --program-prefix=${program_prefix} \
$(use_enable nls) \
- --libexecdir='$(libdir)'/find \
- ${myconf}
+ --libexecdir='$(libdir)'/find
}
src_install() {
@@ -47,5 +45,6 @@ src_install() {
dodoc NEWS README TODO ChangeLog
# We don't need this, so punt it.
- rm "${ED}"/usr/bin/oldfind "${ED}"/usr/share/man/man1/oldfind.1 || die
+ rm "${ED}"/usr/bin/${program_prefix}oldfind \
+ "${ED}"/usr/share/man/man1/${program_prefix}oldfind.1 || die
}