summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-04 02:30:53 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-04 02:30:53 +0000
commit951ca58ff52d7d5493845c3a02a17d324baf7b6a (patch)
treedccafc2fe280edd42159bddc77f03a994b9bfde2 /sys-apps/file
parentVersion bump (diff)
downloadgentoo-2-951ca58ff52d7d5493845c3a02a17d324baf7b6a.tar.gz
gentoo-2-951ca58ff52d7d5493845c3a02a17d324baf7b6a.tar.bz2
gentoo-2-951ca58ff52d7d5493845c3a02a17d324baf7b6a.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog9
-rw-r--r--sys-apps/file/file-5.12.ebuild94
2 files changed, 101 insertions, 2 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 282e0211ab3c..0979c4631ebc 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.228 2012/11/06 06:58:25 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.229 2013/01/04 02:30:53 vapier Exp $
+
+*file-5.12 (04 Jan 2013)
+
+ 04 Jan 2013; Mike Frysinger <vapier@gentoo.org> +file-5.12.ebuild:
+ Version bump.
06 Nov 2012; Ulrich Müller <ulm@gentoo.org> file-5.05.ebuild,
file-5.06.ebuild, file-5.07.ebuild, file-5.07-r1.ebuild, file-5.07-r2.ebuild,
diff --git a/sys-apps/file/file-5.12.ebuild b/sys-apps/file/file-5.12.ebuild
new file mode 100644
index 000000000000..0d1a6f92a971
--- /dev/null
+++ b/sys-apps/file/file-5.12.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.12.ebuild,v 1.1 2013/01/04 02:30:53 vapier Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils distutils libtool toolchain-funcs
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="python static-libs zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="magic.py"
+
+src_prepare() {
+ elibtoolize
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+wd() { echo "${WORKDIR}"/build-${CHOST}; }
+do_configure() {
+ ECONF_SOURCE=${S}
+
+ mkdir "$(wd)"
+ pushd "$(wd)" >/dev/null
+
+ econf "$@"
+
+ popd >/dev/null
+}
+src_configure() {
+ # when cross-compiling, we need to build up our own file
+ # because people often don't keep matching host/target
+ # file versions #362941
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ tc-export_build_env BUILD_C{C,XX}
+ ac_cv_header_zlib_h=no \
+ ac_cv_lib_z_gzopen=no \
+ CHOST=${CBUILD} \
+ CFLAGS=${BUILD_CFLAGS} \
+ CXXFLAGS=${BUILD_CXXFLAGS} \
+ CPPFLAGS=${BUILD_CPPFLAGS} \
+ LDFLAGS="${BUILD_LDFLAGS} -static" \
+ CC=${BUILD_CC} \
+ CXX=${BUILD_CXX} \
+ do_configure --disable-shared
+ fi
+
+ export ac_cv_header_zlib_h=$(usex zlib) ac_cv_lib_z_gzopen=$(usex zlib)
+ do_configure $(use_enable static-libs static)
+}
+
+do_make() {
+ emake -C "$(wd)" "$@" || die
+}
+src_compile() {
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ CHOST=${CBUILD} do_make -C src file
+ PATH=$(CHOST=${CBUILD} wd)/src:${PATH}
+ fi
+ do_make
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ do_make DESTDIR="${D}" install || die
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+ use static-libs || rm -f "${D}"/usr/lib*/libmagic.la
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}