summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-14 15:24:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-14 15:24:01 +0000
commit4decef1ad4d8ccf4add98988e65257b4aab261f6 (patch)
treeca259eb08da7412bafbeba5a6ae51e59a80c5e4d /sys-apps/file
parentdon't assign S=${WORKDIR}/${P}, trim trailing whitespace (Manifest recommit) (diff)
downloadgentoo-2-4decef1ad4d8ccf4add98988e65257b4aab261f6.tar.gz
gentoo-2-4decef1ad4d8ccf4add98988e65257b4aab261f6.tar.bz2
gentoo-2-4decef1ad4d8ccf4add98988e65257b4aab261f6.zip
link with proper libmagic #54401
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog6
-rw-r--r--sys-apps/file/file-4.09.ebuild13
2 files changed, 13 insertions, 6 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 217c1bc3d59b..7c27a89654cd 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/file
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.51 2004/07/12 16:08:52 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.52 2004/07/14 15:24:01 vapier Exp $
+
+ 14 Jul 2004; Mike Frysinger <vapier@gentoo.org> file-4.09.ebuild:
+ Make sure when building the python component we link against the current
+ libmagic.so and not the system one found in /usr/lib #54401 by tyarling.
12 Jul 2004; <solar@gentoo.org> file-4.08.ebuild, file-4.09.ebuild:
remove the unneeded lib/*.a cruft from a stage1 build
diff --git a/sys-apps/file/file-4.09.ebuild b/sys-apps/file/file-4.09.ebuild
index b8754e3e6a64..a45d938d02c7 100644
--- a/sys-apps/file/file-4.09.ebuild
+++ b/sys-apps/file/file-4.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.09.ebuild,v 1.9 2004/07/12 16:08:52 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.09.ebuild,v 1.10 2004/07/14 15:24:01 vapier Exp $
inherit flag-o-matic gnuconfig eutils
use python && inherit distutils
@@ -26,13 +26,16 @@ src_unpack() {
# This patch is for MIPS only. It slightly changes the 'file' output
# on MIPS machines to a specific format so that other programs can
# recognize things.
- use mips && epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
+ if use mips ; then
+ epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
+ gnuconfig_update
+ fi
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
}
src_compile() {
- # If running mips64, we need updated configure data
- use mips && gnuconfig_update
-
# file command segfaults on hppa - reported by gustavo@zacarias.com.ar
[ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"