summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-20 22:03:25 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-20 22:03:25 +0000
commitb77ccfc47b62d9dd9a7acce67ecd6c5a9139a254 (patch)
treee0f3a15f83c22e5c5b16daab4f463eb180fb34f5 /sys-apps/fcron/files
parentInitial binary ebuild for OpenOffice (diff)
downloadgentoo-2-b77ccfc47b62d9dd9a7acce67ecd6c5a9139a254.tar.gz
gentoo-2-b77ccfc47b62d9dd9a7acce67ecd6c5a9139a254.tar.bz2
gentoo-2-b77ccfc47b62d9dd9a7acce67ecd6c5a9139a254.zip
New cronlayout. all the new releases are currently masked - please test. see also message on gentoo-dev
Diffstat (limited to 'sys-apps/fcron/files')
-rw-r--r--sys-apps/fcron/files/crontab23
-rw-r--r--sys-apps/fcron/files/digest-fcron-2.0.0-r11
-rw-r--r--sys-apps/fcron/files/fcron-2.0.0-gentoo.diff22
-rw-r--r--sys-apps/fcron/files/fcron.conf24
-rw-r--r--sys-apps/fcron/files/fcron.rc630
5 files changed, 100 insertions, 0 deletions
diff --git a/sys-apps/fcron/files/crontab b/sys-apps/fcron/files/crontab
new file mode 100644
index 000000000000..bbeed56239ff
--- /dev/null
+++ b/sys-apps/fcron/files/crontab
@@ -0,0 +1,23 @@
+
+# /etc/crontab
+# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
+# $ Header: $
+
+# fcron || dcron:
+# This is NOT the system crontab! fcron and dcron do not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+
+*/15 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+
+
+
diff --git a/sys-apps/fcron/files/digest-fcron-2.0.0-r1 b/sys-apps/fcron/files/digest-fcron-2.0.0-r1
new file mode 100644
index 000000000000..45d732101fce
--- /dev/null
+++ b/sys-apps/fcron/files/digest-fcron-2.0.0-r1
@@ -0,0 +1 @@
+MD5 b20c6bc5d9435a790e5500ecb7990df8 fcron-2.0.0.src.tar.gz 144069
diff --git a/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff b/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff
new file mode 100644
index 000000000000..aa6c0362f6e1
--- /dev/null
+++ b/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff
@@ -0,0 +1,22 @@
+--- configure.in.orig Sun Jul 8 07:32:17 2001
++++ configure.in Sat Aug 25 14:36:05 2001
+@@ -201,13 +201,13 @@
+ fi
+ ;;
+ *)
+- if test -d "$withval"; then
++# if test -d "$withval"; then
+ etcdir="$withval"
+- AC_MSG_RESULT($withval)
+- else
+- AC_MSG_ERROR([
+-Directory $withval does not exist])
+- fi
++# AC_MSG_RESULT($withval)
++# else
++# AC_MSG_ERROR([
++#Directory $withval does not exist])
++# fi
+ ;;
+ esac ],
+ if test -d "/etc"; then
diff --git a/sys-apps/fcron/files/fcron.conf b/sys-apps/fcron/files/fcron.conf
new file mode 100644
index 000000000000..eb7e47af9d07
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.conf
@@ -0,0 +1,24 @@
+# fcron.conf - Configuration file for fcron(8) and fcrontab(1).
+# See fcron.conf(5) for syntax and explanations.
+#
+# WARNING : this file must be owned by root:cron and 640.
+#
+# $ Header: $
+#
+
+# The spool directory where fcron stores its files
+fcrontabs = /var/spool/cron/crontabs
+
+# The location of the pidfile
+pidfile = /var/run/fcron.pid
+
+# allow/deny files to determine which users are allowed to use fcrontab
+fcronallow = /etc/fcron/fcron.allow
+fcrondeny = /etc/fcron/fcron.deny
+
+# Location of the programs used by fcron
+shell = /bin/sh
+sendmail = /usr/sbin/sendmail
+
+# Location of the default editor for "fcrontab -e"
+editor = /usr/bin/nano
diff --git a/sys-apps/fcron/files/fcron.rc6 b/sys-apps/fcron/files/fcron.rc6
new file mode 100644
index 000000000000..26dc4d68e431
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/files/fcron.rc6,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+depend() {
+ need clock hostname logger
+ provide cron
+}
+
+checkconfig() {
+ if [ ! -e /etc/fcron/fcron.conf ] ; then
+ eerror "You will need an /etc/fcron/fcron.conf first"
+ eerror "There is a sample in /etc/fcron"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting fcron"
+ start-stop-daemon --start --quiet --exec /usr/sbin/fcron
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping fcron"
+ start-stop-daemon --stop --quiet --pidfile /var/run/fcron.pid
+ eend $?
+}