summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Seidel <tuxus@gentoo.org>2003-01-23 15:47:19 +0000
committerJan Seidel <tuxus@gentoo.org>2003-01-23 15:47:19 +0000
commit9f5511d918dc21686cdcc051e3228a824bce8307 (patch)
treeda1b9483fb81883205dd3e30e2891f01296d66de /sys-apps/dvhtool/dvhtool-1.0.1.ebuild
parentAdded sparc to keywords. (diff)
downloadgentoo-2-9f5511d918dc21686cdcc051e3228a824bce8307.tar.gz
gentoo-2-9f5511d918dc21686cdcc051e3228a824bce8307.tar.bz2
gentoo-2-9f5511d918dc21686cdcc051e3228a824bce8307.zip
Add initial mips dvhtool ebuild
Diffstat (limited to 'sys-apps/dvhtool/dvhtool-1.0.1.ebuild')
-rw-r--r--sys-apps/dvhtool/dvhtool-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/dvhtool/dvhtool-1.0.1.ebuild b/sys-apps/dvhtool/dvhtool-1.0.1.ebuild
new file mode 100644
index 000000000000..805841da1efe
--- /dev/null
+++ b/sys-apps/dvhtool/dvhtool-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dvhtool/dvhtool-1.0.1.ebuild,v 1.1 2003/01/23 15:47:19 tuxus Exp $
+
+DESCRIPTION="Dvhtool is the tool responsilbe for writing the kernel(s) into the volume header"
+HOMEPAGE="http://packages.debian.org/unstable/utils/dvhtool.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/d/dvhtool/dvhtool_1.0.1.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="mips"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}.orig
+ patch -p1 < ${FILESDIR}/dvhtool-1.0.1-2.diff || die
+}
+src_compile() {
+ cd ${S}.orig
+ econf
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ cd ${S}.orig
+ einstall
+
+}