summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-24 23:13:01 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-24 23:13:01 +0000
commit074247862b46657c683834e8bdf5ba5771fb9929 (patch)
treeb866c1dcc159fc5f9e753e4713c94da8479e61b2 /sys-apps/dmapi
parentadded ssl dep (diff)
downloadgentoo-2-074247862b46657c683834e8bdf5ba5771fb9929.tar.gz
gentoo-2-074247862b46657c683834e8bdf5ba5771fb9929.tar.bz2
gentoo-2-074247862b46657c683834e8bdf5ba5771fb9929.zip
compile fixums, hopefully
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/dmapi-20020124-r1.ebuild29
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-20020124-r11
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-20020124-r1.ebuild b/sys-apps/dmapi/dmapi-20020124-r1.ebuild
new file mode 100644
index 000000000000..d7b75000b5ee
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-20020124-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-20020124-r1.ebuild,v 1.1 2002/01/24 23:12:55 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS data management API library"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make >=sys-apps/xfsprogs-${PV}"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ #let Steve Lord know that "install-dev" isn't mentioned in doc/INSTALL
+ make DESTDIR=${D} install install-dev || die
+ dosym /usr/lib/libdm.a /lib/libdm.a
+ dosym /usr/lib/libdm.la /lib/libdm.la
+ dosym /lib/libdm.so /usr/lib/libdm.so
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-20020124-r1 b/sys-apps/dmapi/files/digest-dmapi-20020124-r1
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-20020124-r1
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672