summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-11 21:06:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-11 21:06:57 +0000
commit24ff58bea7a05f9eb1250b0178ad2daeba771e1d (patch)
tree93c88fdf93f482a4e12d093d10483f7bae05620b /sys-apps/baselayout
parentppc64 stable wrt #385789 (diff)
downloadgentoo-2-24ff58bea7a05f9eb1250b0178ad2daeba771e1d.tar.gz
gentoo-2-24ff58bea7a05f9eb1250b0178ad2daeba771e1d.tar.bz2
gentoo-2-24ff58bea7a05f9eb1250b0178ad2daeba771e1d.zip
Make sure we apply the lib32 de-hack to only the arches where said hack was put into place #386821 by Jim Faulkner.
(Portage version: 2.2.0_alpha65/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/ChangeLog6
-rw-r--r--sys-apps/baselayout/baselayout-2.1.ebuild18
2 files changed, 16 insertions, 8 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index a7fc64374eb5..57bd8d62b0de 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/baselayout
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.514 2011/10/09 16:34:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.515 2011/10/11 21:06:57 vapier Exp $
# See the rc-scripts ChangeLog in subversion for release info:
# http://sources.gentoo.org/viewcvs.py/*checkout*/baselayout/trunk/ChangeLog
+ 11 Oct 2011; Mike Frysinger <vapier@gentoo.org> baselayout-2.1.ebuild:
+ Make sure we apply the lib32 de-hack to only the arches where said hack was
+ put into place #386821 by Jim Faulkner.
+
09 Oct 2011; Mike Frysinger <vapier@gentoo.org> baselayout-2.1.ebuild:
Add sanity check for $DEFAULT_ABI #385993 by Christian Samsel.
diff --git a/sys-apps/baselayout/baselayout-2.1.ebuild b/sys-apps/baselayout/baselayout-2.1.ebuild
index f84919f392a0..bf1c865a7785 100644
--- a/sys-apps/baselayout/baselayout-2.1.ebuild
+++ b/sys-apps/baselayout/baselayout-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.1.ebuild,v 1.3 2011/10/09 16:34:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.1.ebuild,v 1.4 2011/10/11 21:06:57 vapier Exp $
inherit eutils multilib
@@ -102,13 +102,17 @@ multilib_layout() {
# make sure the old "lib" ABI location does not exist; we
# only symlinked the lib dir on systems where we moved it
# to "lib32" ...
- if [ -d "${prefix}lib32" ] ; then
- rm -f "${prefix}lib32"/.keep
- if ! rmdir "${prefix}lib32" 2>/dev/null ; then
- ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
- die "non-empty dir found where there should be none: ${prefix}lib32"
+ case ${CHOST} in
+ i?86*|x86_64*|powerpc*|sparc*|s390*)
+ if [ -d "${prefix}lib32" ] ; then
+ rm -f "${prefix}lib32"/.keep
+ if ! rmdir "${prefix}lib32" 2>/dev/null ; then
+ ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
+ die "non-empty dir found where there should be none: ${prefix}lib32"
+ fi
fi
- fi
+ ;;
+ esac
else
# nothing exists, so just set it up sanely
ewarn "Initializing ${prefix}lib as a dir"