summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-23 03:03:45 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-23 03:03:45 +0000
commit914e8ba0a58b79a1e9915e62a144780383cf5a20 (patch)
treee1e0271b1f1ac64b23d9f87978415d4a9b7dad83 /sys-apps/acl
parentnewer libtool versions have an --install flag for copying/updating helper files (diff)
downloadgentoo-2-914e8ba0a58b79a1e9915e62a144780383cf5a20.tar.gz
gentoo-2-914e8ba0a58b79a1e9915e62a144780383cf5a20.tar.bz2
gentoo-2-914e8ba0a58b79a1e9915e62a144780383cf5a20.zip
old
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/acl-2.2.39-r1.ebuild62
-rw-r--r--sys-apps/acl/acl-2.2.44.ebuild62
-rw-r--r--sys-apps/acl/files/acl-2.2.29-nfs-glue.patch23
-rw-r--r--sys-apps/acl/files/acl-2.2.41-nfs-glue.patch23
-rw-r--r--sys-apps/acl/files/acl-2.2.42-nfs-glue.patch20
-rw-r--r--sys-apps/acl/files/acl-2.2.44-LDFLAGS.patch14
6 files changed, 0 insertions, 204 deletions
diff --git a/sys-apps/acl/acl-2.2.39-r1.ebuild b/sys-apps/acl/acl-2.2.39-r1.ebuild
deleted file mode 100644
index c352db5d651c..000000000000
--- a/sys-apps/acl/acl-2.2.39-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.39-r1.ebuild,v 1.12 2007/01/31 20:47:08 dertobi123 Exp $
-
-WANT_AUTOCONF="latest"
-inherit eutils autotools toolchain-funcs
-
-MY_P="${PN}_${PV}-1"
-DESCRIPTION="Access control list utilities, libraries and headers"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
- ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz
- nfs? ( http://www.citi.umich.edu/projects/nfsv4/linux/acl-patches/2.2.29-3/acl-2.2.29-CITI_NFS4_ALL-3.dif )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nfs nls"
-
-DEPEND=">=sys-apps/attr-2.4
- nfs? ( net-libs/libnfsidmap )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- if use nfs ; then
- cp "${DISTDIR}"/acl-2.2.29-CITI_NFS4_ALL-3.dif . || die
- epatch \
- "${FILESDIR}"/acl-2.2.29-nfs-glue.patch \
- acl-2.2.29-CITI_NFS4_ALL-3.dif
- fi
- epatch "${FILESDIR}"/${PN}-2.2.32-only-symlink-when-needed.patch
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die "failed to update builddefs"
- eautoconf
-}
-
-src_compile() {
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --libexecdir=/usr/$(get_libdir) \
- --bindir=/bin \
- || die
- emake || die
-}
-
-src_install() {
- emake DIST_ROOT="${D}" install install-dev install-lib || die
- prepalldocs
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/libacl.so* "${D}"/$(get_libdir)/ || die
- gen_usr_ldscript libacl.so
-}
diff --git a/sys-apps/acl/acl-2.2.44.ebuild b/sys-apps/acl/acl-2.2.44.ebuild
deleted file mode 100644
index 5df6c593920f..000000000000
--- a/sys-apps/acl/acl-2.2.44.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.44.ebuild,v 1.11 2007/12/11 10:18:08 vapier Exp $
-
-inherit eutils autotools toolchain-funcs
-
-MY_P="${PN}_${PV}-1"
-DESCRIPTION="Access control list utilities, libraries and headers"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
- ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz
- nfs? ( http://www.citi.umich.edu/projects/nfsv4/linux/acl-patches/2.2.41-3/acl-2.2.41-CITI_NFS4_ALL-3.dif )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nfs nls"
-
-DEPEND=">=sys-apps/attr-2.4
- nfs? ( net-libs/libnfsidmap )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- if use nfs ; then
- cp "${DISTDIR}"/acl-2.2.41-CITI_NFS4_ALL-3.dif . || die
- epatch \
- "${FILESDIR}"/acl-2.2.41-nfs-glue.patch \
- acl-2.2.41-CITI_NFS4_ALL-3.dif
- fi
- epatch "${FILESDIR}"/${PN}-2.2.32-only-symlink-when-needed.patch
- epatch "${FILESDIR}"/${PN}-2.2.44-LDFLAGS.patch
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die "failed to update builddefs"
- eautoconf
-}
-
-src_compile() {
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --libexecdir=/usr/$(get_libdir) \
- --bindir=/bin \
- || die
- emake || die
-}
-
-src_install() {
- emake DIST_ROOT="${D}" install install-dev install-lib || die
- prepalldocs
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/libacl.so* "${D}"/$(get_libdir)/ || die
- gen_usr_ldscript libacl.so
-}
diff --git a/sys-apps/acl/files/acl-2.2.29-nfs-glue.patch b/sys-apps/acl/files/acl-2.2.29-nfs-glue.patch
deleted file mode 100644
index 9150eb3a79fe..000000000000
--- a/sys-apps/acl/files/acl-2.2.29-nfs-glue.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- ../acl-2.2.29-CITI_NFS4_ALL-3.dif.orig 2006-09-23 11:34:45.000000000 -0400
-+++ ../acl-2.2.29-CITI_NFS4_ALL-3.dif 2006-09-23 11:34:54.000000000 -0400
-@@ -68,20 +68,6 @@
-
- default: $(CONFIGURE)
- ifeq ($(HAVE_BUILDDEFS), no)
--diff --git a/debian/changelog b/debian/changelog
--index 66e16b7..c431d66 100644
----- a/debian/changelog
--+++ b/debian/changelog
--@@ -1,3 +1,9 @@
--+acl (2.2.37.nfsv4-1) unstable; urgency=low
--+
--+ * Add support for NFSv4 ACLs
--+
--+ -- J. Bruce Fields <bfields@fieldses.org> Tue, 9 May 2006 11:52:32 -0400
--+
-- acl (2.2.37-1) unstable; urgency=low
--
-- * New upstream release
- diff --git a/debian/control b/debian/control
- index 5ff00bc..1d0f356 100644
- --- a/debian/control
diff --git a/sys-apps/acl/files/acl-2.2.41-nfs-glue.patch b/sys-apps/acl/files/acl-2.2.41-nfs-glue.patch
deleted file mode 100644
index d19e16b27ac7..000000000000
--- a/sys-apps/acl/files/acl-2.2.41-nfs-glue.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- acl-2.2.41-CITI_NFS4_ALL-3.dif
-+++ acl-2.2.41-CITI_NFS4_ALL-3.dif
-@@ -5,20 +5,6 @@
- ACLs.
- - miscellaneous cleanup
-
--diff --git a/debian/changelog b/debian/changelog
--index 60ded06..089507e 100644
----- a/debian/changelog
--+++ b/debian/changelog
--@@ -1,3 +1,9 @@
--+acl (2.2.41.nfsv4-1) unstable; urgency=low
--+
--+ * Add support for NFSv4 ACLs
--+
--+ -- J. Bruce Fields <bfields@fieldses.org> Fri, 02 Sep 2006 00:22:07 -0400
--+
-- acl (2.2.41-1) unstable; urgency=low
--
-- * New upstream release
- diff --git a/exports b/exports
- index 59c1311..2296b7d 100644
- --- a/exports
diff --git a/sys-apps/acl/files/acl-2.2.42-nfs-glue.patch b/sys-apps/acl/files/acl-2.2.42-nfs-glue.patch
deleted file mode 100644
index 81712ebff7b4..000000000000
--- a/sys-apps/acl/files/acl-2.2.42-nfs-glue.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- acl-2.2.42-CITI_NFS4_ALL-1.dif.orig 2007-09-20 01:54:06.000000000 -0400
-+++ acl-2.2.42-CITI_NFS4_ALL-1.dif 2007-09-20 01:54:15.000000000 -0400
-@@ -1,17 +1,3 @@
--diff --git a/debian/changelog b/debian/changelog
--index 10f4787..54b8af9 100644
----- a/debian/changelog
--+++ b/debian/changelog
--@@ -1,3 +1,9 @@
--+acl (2.2.42.nfsv4-1) unstable; urgency=low
--+
--+ * Add support for NFSv4 ACLs
--+
--+ -- J. Bruce Fields <bfields@fieldses.org> Fri, 02 Sep 2006 00:22:07 -0400
--+
-- acl (2.2.42-1) unstable; urgency=low
--
-- * New upstream release
- diff --git a/exports b/exports
- index 59c1311..2296b7d 100644
- --- a/exports
diff --git a/sys-apps/acl/files/acl-2.2.44-LDFLAGS.patch b/sys-apps/acl/files/acl-2.2.44-LDFLAGS.patch
deleted file mode 100644
index f5f1ebb74f12..000000000000
--- a/sys-apps/acl/files/acl-2.2.44-LDFLAGS.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-make sure the library link respects LDFLAGS
-
-http://oss.sgi.com/bugzilla/show_bug.cgi?id=642
-
---- include/buildmacros
-+++ include/buildmacros
-@@ -10,6 +10,7 @@
- # during the "dist" phase (packaging).
-
- LDFLAGS += $(LOADERFLAGS) $(LLDFLAGS)
-+LTLDFLAGS += $(LOADERFLAGS)
- LDLIBS = $(LLDLIBS) $(PLDLIBS) $(MALLOCLIB)
-
- MAKEOPTS = --no-print-directory