summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-23 10:21:53 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-23 10:21:53 +0000
commitcf50b9cd5eab560fdf073575c61a450cf2f55043 (patch)
tree50c3e4954c5ead503952afb3093d22d64ba47a65 /sci-visualization
parentAdding blocker for #453044 (diff)
downloadgentoo-2-cf50b9cd5eab560fdf073575c61a450cf2f55043.tar.gz
gentoo-2-cf50b9cd5eab560fdf073575c61a450cf2f55043.tar.bz2
gentoo-2-cf50b9cd5eab560fdf073575c61a450cf2f55043.zip
sci-visualization/gwyddion: Backport patches which upstream declares important, #453158
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/ChangeLog11
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch22
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch37
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.30-r1.ebuild88
-rw-r--r--sci-visualization/gwyddion/metadata.xml10
5 files changed, 161 insertions, 7 deletions
diff --git a/sci-visualization/gwyddion/ChangeLog b/sci-visualization/gwyddion/ChangeLog
index 1bd0b44d0ce0..373d97a09f3a 100644
--- a/sci-visualization/gwyddion/ChangeLog
+++ b/sci-visualization/gwyddion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/gwyddion
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.44 2012/12/06 10:11:45 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.45 2013/01/23 10:21:53 jlec Exp $
+
+*gwyddion-2.30-r1 (23 Jan 2013)
+
+ 23 Jan 2013; Justin Lecher <jlec@gentoo.org> +gwyddion-2.30-r1.ebuild,
+ +files/gwyddion-2.30-BGRA.patch,
+ +files/gwyddion-2.30-color-button-debris-crash.patch, metadata.xml:
+ Backport patches which upstream declares important, #453158
06 Dec 2012; Justin Lecher <jlec@gentoo.org> -gwyddion-2.25.ebuild:
Drop old
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch b/sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch
new file mode 100644
index 000000000000..c3b59122b99c
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.30-BGRA.patch
@@ -0,0 +1,22 @@
+Index: libgwydgets/gwy3dview.c
+===================================================================
+--- libgwydgets/gwy3dview.c (revision 13961)
++++ libgwydgets/gwy3dview.c (working copy)
+@@ -48,7 +48,6 @@
+ #include <GL/glext.h>
+ #endif
+ #endif
+-#endif
+
+ #ifndef GL_BGRA
+ #ifdef GL_BGRA_EXT
+@@ -57,6 +56,7 @@
+ #error FIXME: GL_BGRA is not available, should work around it.
+ #endif
+ #endif
++#endif
+
+ #include <libgwyddion/gwymacros.h>
+ #include <libgwyddion/gwymath.h>
+
+
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch b/sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch
new file mode 100644
index 000000000000..e6ceedf919e3
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.30-color-button-debris-crash.patch
@@ -0,0 +1,37 @@
+Index: modules/file/pixmap.c
+===================================================================
+--- modules/file/pixmap.c (revision 13902)
++++ modules/file/pixmap.c (revision 13903)
+@@ -2933,8 +2933,6 @@
+ gwy_rgba_to_gdk_color(&controls->args->inset_color, &gdkcolor);
+
+ dialog = gtk_color_selection_dialog_new(_("Change Inset Color"));
+- if (gtk_major_version == 2 && gtk_minor_version < 10)
+-
+ selector = GTK_COLOR_SELECTION_DIALOG(dialog)->colorsel;
+ gtk_color_selection_set_current_color(GTK_COLOR_SELECTION(selector),
+ &gdkcolor);
+Index: libgwydgets/gwygraphareadialog.c
+===================================================================
+--- libgwydgets/gwygraphareadialog.c (revision 13902)
++++ libgwydgets/gwygraphareadialog.c (revision 13903)
+@@ -383,7 +383,6 @@
+ dialog->color_dialog = selector;
+ dialog->old_color = cmodel->color;
+
+- if (gtk_major_version == 2 && gtk_minor_version < 10)
+ colorsel = GTK_COLOR_SELECTION_DIALOG(selector)->colorsel;
+ g_signal_connect(selector, "response",
+ G_CALLBACK(colorsel_response_cb), dialog);
+Index: libgwydgets/gwydgetutils.c
+===================================================================
+--- libgwydgets/gwydgetutils.c (revision 13902)
++++ libgwydgets/gwydgetutils.c (revision 13903)
+@@ -561,7 +561,6 @@
+ dialog = gtk_color_selection_dialog_new(dialog_title
+ ? dialog_title
+ : _("Change Mask Color"));
+- if (gtk_major_version == 2 && gtk_minor_version < 10)
+ selector = GTK_COLOR_SELECTION_DIALOG(dialog)->colorsel;
+ gtk_color_selection_set_current_color(GTK_COLOR_SELECTION(selector),
+ &gdkcolor);
diff --git a/sci-visualization/gwyddion/gwyddion-2.30-r1.ebuild b/sci-visualization/gwyddion/gwyddion-2.30-r1.ebuild
new file mode 100644
index 000000000000..164d24aa2a37
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.30-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.30-r1.ebuild,v 1.1 2013/01/23 10:21:53 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils fdo-mime gnome2-utils python
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fftw gnome kde nls opengl perl python ruby sourceview xml X"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/pango
+ fftw? ( sci-libs/fftw:3.0 )
+ gnome? ( gnome-base/gconf:2 )
+ kde? ( kde-base/kdelibs:4 )
+ opengl? ( virtual/opengl x11-libs/gtkglext )
+ perl? ( dev-lang/perl )
+ python? ( dev-python/pygtk:2 )
+ ruby? ( dev-ruby/narray )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+MAKEOPTS+=" V=1"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.25-libpng15.patch
+ "${FILESDIR}"/${P}-BGRA.patch
+ "${FILESDIR}"/${P}-color-button-debris-crash.patch
+ )
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable doc gtk-doc)
+ $(use_enable nls)
+ $(use_enable python pygwy)
+ $(use_with perl)
+ $(use_with python)
+ $(use_with ruby)
+ $(use_with fftw fftw3)
+ $(use_with opengl gl) \
+ $(use_with sourceview gtksourceview)
+ $(use_with xml libxml2)
+ $(use_with X x)
+ $(use_with kde kde4-thumbnailer)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use python && dodoc modules/pygwy/README.pygwy
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/gwyddion/metadata.xml b/sci-visualization/gwyddion/metadata.xml
index 6c5e0e08ed66..3f27823a6510 100644
--- a/sci-visualization/gwyddion/metadata.xml
+++ b/sci-visualization/gwyddion/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
Gwyddion is a modular program for SPM data analysis. Primarily it is
supposed to be used for analysis of height fields obtained by means of
scanning probe microscopy techniques (AFM, MFM, STM, NSOM), but
generally it can be used for any other height field analysis or
image analysis.
</longdescription>
- <use>
- <flag name="sourceview">
+ <use>
+ <flag name="sourceview">
Enable support for <pkg>x11-libs/gtksourceview</pkg>
</flag>
- </use>
+ </use>
</pkgmetadata>