summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-01 11:20:26 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-01 11:20:26 +0000
commit20472191e32cadd5a7310637a7ca70ad9fbcd938 (patch)
treed9514b1de0f07b4defbff5fcb288852b0022a5bd /sci-visualization
parentOne more new dependency. (diff)
downloadgentoo-2-20472191e32cadd5a7310637a7ca70ad9fbcd938.tar.gz
gentoo-2-20472191e32cadd5a7310637a7ca70ad9fbcd938.tar.bz2
gentoo-2-20472191e32cadd5a7310637a7ca70ad9fbcd938.zip
Add build fix from bug 485940, thanks Vadim Dyadkin
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/qtiplot/ChangeLog6
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.8.9-private.patch15
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index 980526f2cc89..e23551ee41ed 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.102 2013/10/31 20:06:39 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.103 2013/11/01 11:20:26 dilfridge Exp $
+
+ 01 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ qtiplot-0.9.8.9-r2.ebuild, +files/qtiplot-0.9.8.9-private.patch:
+ Add build fix from bug 485940, thanks Vadim Dyadkin
31 Oct 2013; Andreas K. Huettel <dilfridge@gentoo.org>
qtiplot-0.9.8.9-r2.ebuild:
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.8.9-private.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.8.9-private.patch
new file mode 100644
index 000000000000..7bec3771813c
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.8.9-private.patch
@@ -0,0 +1,15 @@
+diff -ruN qtiplot-0.9.8.9.orig/qtiplot/src/plot2D/ImageWidget.h qtiplot-0.9.8.9/qtiplot/src/plot2D/ImageWidget.h
+--- qtiplot-0.9.8.9.orig/qtiplot/src/plot2D/ImageWidget.h 2010-10-17 09:04:05.000000000 +0200
++++ qtiplot-0.9.8.9/qtiplot/src/plot2D/ImageWidget.h 2013-11-01 12:11:36.559973891 +0100
+@@ -67,10 +67,10 @@
+ void setWindowName(const QString& name){d_window_name = name;};
+
+ static QPixmap windowPixmap(ApplicationWindow *mw, const QString& name, const QSize& size);
++ void paintEvent(QPaintEvent *e);
+
+ private:
+ void draw(QPainter *painter, const QRect& r);
+- void paintEvent(QPaintEvent *e);
+ QPixmap d_pix;
+ //! The file from which the image was loaded.
+ QString d_file_name;
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild
index a19ed9ad3d33..4854ffbc9b16 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild,v 1.4 2013/10/31 20:06:39 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.8.9-r2.ebuild,v 1.5 2013/11/01 11:20:26 dilfridge Exp $
EAPI=5
@@ -71,6 +71,7 @@ PATCHES=(
"${FILESDIR}"/${P}-set_col_values.patch
"${FILESDIR}"/${P}-adopt_to_alglib3.patch
"${FILESDIR}"/${P}-crasher_without_internet.patch
+ "${FILESDIR}"/${P}-private.patch
)
pkg_setup() {