summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-05-15 20:23:37 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-05-15 20:23:37 +0000
commitce9a338b9958f889cac9badfaec04288ccce5b43 (patch)
treeab54e7fe9d3dd03d1fd3bb5699173a25b39d1942 /sci-physics
parentuse EPYTHON in wrapper (bug #549568) (diff)
downloadgentoo-2-ce9a338b9958f889cac9badfaec04288ccce5b43.tar.gz
gentoo-2-ce9a338b9958f889cac9badfaec04288ccce5b43.tar.bz2
gentoo-2-ce9a338b9958f889cac9badfaec04288ccce5b43.zip
temporary fix for bug 548698
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog9
-rw-r--r--sci-physics/root/files/root-6.02.05-dictpch.patch31
-rw-r--r--sci-physics/root/root-6.02.05-r2.ebuild20
3 files changed, 18 insertions, 42 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 33710992007d..cadec82a7443 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.146 2015/05/01 15:30:02 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.147 2015/05/15 20:23:37 bircoph Exp $
+
+ 15 May 2015; Andrew Savchenko <bircoph@gentoo.org> root-6.02.05-r2.ebuild,
+ -files/root-6.02.05-dictpch.patch:
+ Temporarily disable PCH dictionary regeneration due to bug 548698:
+ root has too many hardcode paths for cling-related stuff, this
+ should be fixed first for dictionary to be regenerated on root
+ install.
01 May 2015; Andrew Savchenko <bircoph@gentoo.org> root-5.34.26.ebuild:
5.34.26 have no support for pythia-8.2
diff --git a/sci-physics/root/files/root-6.02.05-dictpch.patch b/sci-physics/root/files/root-6.02.05-dictpch.patch
deleted file mode 100644
index 80a416e1a339..000000000000
--- a/sci-physics/root/files/root-6.02.05-dictpch.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- etc/dictpch/makepch-gentoo.sh.orig 2015-04-08 14:27:07.781026830 +0300
-+++ etc/dictpch/makepch-gentoo.sh 2015-04-12 13:40:48.226060739 +0300
-@@ -13,8 +13,8 @@
- # Copyright (c) 2014 Rene Brun and Fons Rademakers
- # Author: Axel Naumann <axel@cern.ch>, 2014-10-16
-
--rootdir=.
--cfgdir=etc/dictpch
-+rootdir=ROOTDIR_TEMPLATE
-+cfgdir=etc/root/dictpch
- allheaders=$cfgdir/allHeaders.h
- alllinkdefs=$cfgdir/allLinkDefs.h
- cppflags=$cfgdir/allCppflags.txt
-@@ -36,7 +36,7 @@
- rootbuild=-rootbuild
- fi
-
--cxxflags="-D__CLING__ -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS -DROOT_PCH -I$rootdir/include -I$rootdir/etc -I$rootdir/$cfgdir -I$rootdir/etc/cling `cat $rootdir/$cppflags`"
-+cxxflags="-D__CLING__ -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS -DROOT_PCH -I$rootdir/usr/include/root -I$rootdir/etc/root -I$rootdir/$cfgdir -I$rootdir/etc/root/cling `cat $rootdir/$cppflags`"
-
- if ! [ "x$1" = "x" ]; then
- cxxflags="$cxxflags $1"
-@@ -44,7 +44,7 @@
-
- # generate pch
- touch allDict.cxx.h
--$rootdir/bin/rootcling $rootbuild -1 -f allDict.cxx -noDictSelection -c $cxxflags $allheaders $@ $alllinkdefs
-+$rootdir/usr/bin/rootcling -1 -f allDict.cxx -noDictSelection -c $cxxflags $allheaders $@ $alllinkdefs
- res=$?
- if [ $res -eq 0 ] ; then
- mv allDict_rdict.pch $pch
diff --git a/sci-physics/root/root-6.02.05-r2.ebuild b/sci-physics/root/root-6.02.05-r2.ebuild
index 25252441c892..102d06481c93 100644
--- a/sci-physics/root/root-6.02.05-r2.ebuild
+++ b/sci-physics/root/root-6.02.05-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-6.02.05-r2.ebuild,v 1.3 2015/04/15 08:48:36 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-6.02.05-r2.ebuild,v 1.4 2015/05/15 20:23:37 bircoph Exp $
EAPI=5
@@ -212,7 +212,7 @@ src_prepare() {
# This can be done only at install stage, when files are placed
# as appropriate. Premature modification of makepch.sh will
# broke build process, however.
- cp "etc/dictpch/makepch.sh" "etc/dictpch/makepch-gentoo.sh" || die
+ #cp "etc/dictpch/makepch.sh" "etc/dictpch/makepch-gentoo.sh" || die
epatch \
"${FILESDIR}"/${PN}-5.28.00b-glibc212.patch \
@@ -226,8 +226,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-6.00.01-llvm.patch \
"${FILESDIR}"/${PN}-6.00.01-nobyte-compile.patch \
"${FILESDIR}"/${PN}-6.00.01-prop-flags.patch \
- "${FILESDIR}"/${PN}-6.02.05-dictpch.patch \
"${FILESDIR}"/${PN}-6.02.05-xrootd4.patch
+ #"${FILESDIR}"/${PN}-6.02.05-dictpch.patch \
# make sure we use system libs and headers
rm montecarlo/eg/inc/cfortran.h README/cfortran.doc || die
@@ -423,14 +423,14 @@ cleanup_install() {
use examples || rm -r ${DOC_DIR#/}/examples || die
# clean hardcoded sandbox paths
- rm etc/root/dictpch/allCppflags.txt.tmp || die
- sed -i "s|${S}/||" etc/root/cling/llvm/Config/llvm-config.h || die
+ #rm etc/root/dictpch/allCppflags.txt.tmp || die
+ #sed -i "s|${S}/||" etc/root/cling/llvm/Config/llvm-config.h || die
# regenerate pch for Gentoo headers layout
- rm "etc/root/allDict.cxx.pch" || die
- sed -i 's|etc/dictpch|etc/root/dictpch|' etc/root/dictpch/allLinkDefs.h || die
- sed -i 's|etc/cling|etc/root/cling|' etc/root/dictpch/allHeaders.h || die
- sed -i "s|ROOTDIR_TEMPLATE|${ED}|" etc/root/dictpch/makepch-gentoo.sh || die
- etc/root/dictpch/makepch-gentoo.sh etc/root/allDict.cxx.pch || die "PCH generation failed"
+ #rm "etc/root/allDict.cxx.pch" || die
+ #sed -i 's|etc/dictpch|etc/root/dictpch|' etc/root/dictpch/allLinkDefs.h || die
+ #sed -i 's|etc/cling|etc/root/cling|' etc/root/dictpch/allHeaders.h || die
+ #sed -i "s|ROOTDIR_TEMPLATE|${ED}|" etc/root/dictpch/makepch-gentoo.sh || die
+ #etc/root/dictpch/makepch-gentoo.sh etc/root/allDict.cxx.pch || die "PCH generation failed"
}
src_install() {