summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-08-26 16:28:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-08-26 16:28:30 +0000
commitbbf4f2e139fcf170c5123ab0e02ff99c7158074f (patch)
tree0421fadbacea1b1cd7e927e4e605c12d7c2d8ebd /sci-physics
parentChange HOMEPAGE thanks to MAL (bug #334545). (diff)
downloadgentoo-2-bbf4f2e139fcf170c5123ab0e02ff99c7158074f.tar.gz
gentoo-2-bbf4f2e139fcf170c5123ab0e02ff99c7158074f.tar.bz2
gentoo-2-bbf4f2e139fcf170c5123ab0e02ff99c7158074f.zip
Version bump
(Portage version: 2.2_rc68/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog8
-rw-r--r--sci-physics/pythia/pythia-8.1.42.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 05d206a2cf3a..1464c85be8c5 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.30 2010/07/18 17:48:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.31 2010/08/26 16:28:30 bicatali Exp $
+
+*pythia-8.1.42 (26 Aug 2010)
+
+ 26 Aug 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +pythia-8.1.42.ebuild:
+ Version bump
18 Jul 2010; Raúl Porcel <armin76@gentoo.org> pythia-8.1.35.ebuild:
sparc stable wrt #318467
diff --git a/sci-physics/pythia/pythia-8.1.42.ebuild b/sci-physics/pythia/pythia-8.1.42.ebuild
new file mode 100644
index 000000000000..717df67f29cf
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.42.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.42.ebuild,v 1.1 2010/08/26 16:28:30 bicatali Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples +hepmc"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION=/usr
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk
+ cat > config.mk <<-EOF
+ SHAREDLIBS = yes
+ LDFLAGSSHARED = -shared ${LDFLAGS}
+ LDFLAGLIBNAME = -Wl,-soname
+ SHAREDSUFFIX = so
+ EOF
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake \
+ $(ls main0{1..9}*.cc | sed -e 's/.cc//') \
+ || die "emake tests failed"
+ for i in main0{1..9}*.exe; do
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32 || die "emake tests for hepmc failed"
+ ./main31.exe > main31.exe.out || die
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ dolib.a lib/archive/* || die "static lib install failed"
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc || die "xmldoc install failed"
+ echo PYTHIA8DATA=/usr/share/${PN}/xmldoc >> 99pythia8
+ doenvd 99pythia8
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins worksheet.pdf || die "doc install failed"
+ mv htmldoc html
+ doins -r html || die "html doc install failed"
+ fi
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+}