summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-08-06 20:30:29 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-08-06 20:30:29 +0000
commit30002d46cfc9c65315bdad2e3515fdcd00de995b (patch)
treeeb8d2ad41e65ad972cc41716f641b149f60d3722 /sci-physics
parentBackport removal of ARM_FP_ABI option, bug 547246. (diff)
downloadgentoo-2-30002d46cfc9c65315bdad2e3515fdcd00de995b.tar.gz
gentoo-2-30002d46cfc9c65315bdad2e3515fdcd00de995b.tar.bz2
gentoo-2-30002d46cfc9c65315bdad2e3515fdcd00de995b.zip
Update Debian patchset and EAPI for geant-3, fix copyright year for geant-4
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant/ChangeLog7
-rw-r--r--sci-physics/geant/geant-3.21.14-r4.ebuild68
-rw-r--r--sci-physics/geant/geant-4.9.4_p03.ebuild4
3 files changed, 76 insertions, 3 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 7e360c1d265c..b41e560c3888 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/geant
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.84 2015/05/27 15:28:09 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.85 2015/08/06 20:30:29 bircoph Exp $
+
+*geant-3.21.14-r4 (06 Aug 2015)
+
+ 06 Aug 2015; Andrew Savchenko <bircoph@gentoo.org> +geant-3.21.14-r4.ebuild:
+ Update Debian patchset to version 11, upgrade to EAPI=5.
27 May 2015; Andrew Savchenko <bircoph@gentoo.org> geant-4.10.00.ebuild,
geant-4.10.00_p01.ebuild, geant-4.10.01.ebuild:
diff --git a/sci-physics/geant/geant-3.21.14-r4.ebuild b/sci-physics/geant/geant-3.21.14-r4.ebuild
new file mode 100644
index 000000000000..b3e0abe3f5ce
--- /dev/null
+++ b/sci-physics/geant/geant-3.21.14-r4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r4.ebuild,v 1.1 2015/08/06 20:30:29 bircoph Exp $
+
+EAPI=5
+
+inherit eutils fortran-2
+
+DEB_PN=geant321
+DEB_PV=${PV}.dfsg
+DEB_PR=11
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN's detector description and simulation Tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
+
+SLOT="3"
+LICENSE="GPL-2 LGPL-2 BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ x11-libs/motif:0
+ dev-lang/cfortran
+ sci-physics/cernlib
+ sci-physics/paw"
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+src_prepare() {
+ mv ../debian . || die
+ sed -i -e 's:/tmp/dp.*/cern:cern:g' debian/patches/* || die
+ cp debian/add-ons/Makefile . || die
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
+ sed -i \
+ -e 's:/usr/local:${EROOT}usr:g' \
+ Makefile || die "sed'ing the Makefile failed"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h
+}
+
+src_compile() {
+ # create local LaTeX cache directory
+ VARTEXFONTS="${T}"/fonts
+ emake -j1 cernlib-indep cernlib-arch
+}
+
+src_test_() {
+ LD_LIBRARY_PATH="${S}"/shlib emake -j1 cernlib-test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ cd debian
+ dodoc changelog README.* deadpool.txt NEWS copyright
+ newdoc add-ons/README README.add-ons
+}
diff --git a/sci-physics/geant/geant-4.9.4_p03.ebuild b/sci-physics/geant/geant-4.9.4_p03.ebuild
index 486f6cd7004c..24e59cd08f4b 100644
--- a/sci-physics/geant/geant-4.9.4_p03.ebuild
+++ b/sci-physics/geant/geant-4.9.4_p03.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4_p03.ebuild,v 1.5 2013/03/02 23:26:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4_p03.ebuild,v 1.6 2015/08/06 20:30:29 bircoph Exp $
EAPI=4