summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:12:41 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:12:41 +0000
commit938954483cb1a5cde2a73038c32ed25ef1045f54 (patch)
tree1e0e69a0fc5123a99fd927f58e6ce2feb6e5c2a5 /sci-physics/paw
parentadded missing pkgconfig dep wrt bug #205494 (diff)
downloadgentoo-2-938954483cb1a5cde2a73038c32ed25ef1045f54.tar.gz
gentoo-2-938954483cb1a5cde2a73038c32ed25ef1045f54.tar.bz2
gentoo-2-938954483cb1a5cde2a73038c32ed25ef1045f54.zip
New series of patches from Debian, more compatible with gfortran and better tests. Much ebuild cleaning.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics/paw')
-rw-r--r--sci-physics/paw/ChangeLog11
-rw-r--r--sci-physics/paw/metadata.xml16
-rw-r--r--sci-physics/paw/paw-2.14.04-r1.ebuild85
3 files changed, 102 insertions, 10 deletions
diff --git a/sci-physics/paw/ChangeLog b/sci-physics/paw/ChangeLog
index 24a438d7867f..2b8ca00744bb 100644
--- a/sci-physics/paw/ChangeLog
+++ b/sci-physics/paw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/paw
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.1 2007/08/24 21:38:52 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.2 2008/03/11 12:12:41 bicatali Exp $
+
+*paw-2.14.04-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +paw-2.14.04-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
*paw-2.14.04 (24 Aug 2007)
diff --git a/sci-physics/paw/metadata.xml b/sci-physics/paw/metadata.xml
index c3dd8b627dc4..9450758ff229 100644
--- a/sci-physics/paw/metadata.xml
+++ b/sci-physics/paw/metadata.xml
@@ -3,13 +3,13 @@
<pkgmetadata>
<herd>sci-physics</herd>
<longdescription lang="en">
-PAW is an interactive program providing interactive graphical
-presentation and statistical and mathematical analysis tools. It is
-designed to work on objects familiar to physicists such as histograms,
-event files (Ntuples), vectors, etc.
-The program is linked statically against the CERN libraries on 64-bit
-architectures in order to function properly, as its design is not very
-64-bit clean. Even so, AMD64 is the only 64-bit platform where it
-functions well.
+ PAW is an interactive program providing interactive graphical
+ presentation and statistical and mathematical analysis tools. It is
+ designed to work on objects familiar to physicists such as histograms,
+ event files (Ntuples), vectors, etc.
+ The program is linked statically against the CERN libraries on 64-bit
+ architectures in order to function properly, as its design is not very
+ 64-bit clean. Even so, AMD64 is the only 64-bit platform where it
+ functions well.
</longdescription>
</pkgmetadata>
diff --git a/sci-physics/paw/paw-2.14.04-r1.ebuild b/sci-physics/paw/paw-2.14.04-r1.ebuild
new file mode 100644
index 000000000000..0d386c65371d
--- /dev/null
+++ b/sci-physics/paw/paw-2.14.04-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/paw-2.14.04-r1.ebuild,v 1.1 2008/03/11 12:12:41 bicatali Exp $
+
+inherit eutils multilib fortran
+
+DEB_PN=paw
+DEB_PV=${PV}.dfsg.2
+DEB_PR=3
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN's Physics Analysis Workstation data analysis program"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/paw/index.html"
+LICENSE="GPL-2 LGPL-2 BSD"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran
+ sci-physics/cernlib
+ x11-libs/xbae"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+KEYWORDS="~amd64 ~x86"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+
+ cd "${S}"
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+
+ # fix some path stuff and collision for comis.h,
+ # already installed by cernlib and replace hardcoded fortran compiler
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ -e '/comis.h/d' \
+ -e "s/gfortran/${FORTRANC}/g" \
+ Makefile || "sed'ing the Makefile failed"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "make patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h
+}
+
+src_compile() {
+ # create local LaTeX cache directory
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
+
+pkg_postinst() {
+ if use amd64; then
+ elog "Please see the possible warnings in using ${PN} on 64 bits:"
+ elog "${ROOT}/usr/share/doc/${PF}/README.*64*"
+ fi
+}