summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-07 17:19:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-07 17:19:39 +0000
commit9f958bcb1b8b958f02af86eca07a84195ce56c99 (patch)
treeed53786d5fa6c8c3795f8df1c2cebe6bbcd464b4 /sci-physics/heppdt/heppdt-3.04.01.ebuild
parents390 stable wrt #414865 (diff)
downloadgentoo-2-9f958bcb1b8b958f02af86eca07a84195ce56c99.tar.gz
gentoo-2-9f958bcb1b8b958f02af86eca07a84195ce56c99.tar.bz2
gentoo-2-9f958bcb1b8b958f02af86eca07a84195ce56c99.zip
Added static-libs flag, fixed tests when linking to shared libs, keyword amd64-linux, x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/heppdt/heppdt-3.04.01.ebuild')
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/sci-physics/heppdt/heppdt-3.04.01.ebuild b/sci-physics/heppdt/heppdt-3.04.01.ebuild
index dd43b6ff95e7..4c75ef8416d8 100644
--- a/sci-physics/heppdt/heppdt-3.04.01.ebuild
+++ b/sci-physics/heppdt/heppdt-3.04.01.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/heppdt/heppdt-3.04.01.ebuild,v 1.3 2010/05/25 21:20:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/heppdt/heppdt-3.04.01.ebuild,v 1.4 2012/08/07 17:19:39 bicatali Exp $
-EAPI=2
+EAPI=4
inherit autotools
MYP=HepPDT-${PV}
@@ -13,8 +13,8 @@ SRC_URI="${HOMEPAGE}/download/${MYP}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
RDEPEND=""
DEPEND="${RDEPEND}"
@@ -33,10 +33,18 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/src/HepPDT:${S}/src/HepPID" \
+ emake check MY_LD=-L SHEXT=so
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README ChangeLog
- use doc && mv "${D}"usr/doc/* "${D}"usr/share/doc/${PF}/
- use examples && mv "${D}"usr/examples "${D}"usr/share/doc/${PF}/
- rm -rf "${D}"usr/{doc,examples}
+ default
+ use doc && mv "${ED}"usr/doc/* "${ED}"usr/share/doc/${PF}/
+ use examples && mv "${ED}"usr/examples "${ED}"usr/share/doc/${PF}/
+ rm -r "${ED}"usr/{doc,examples}
}