summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-14 06:52:28 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-14 06:52:28 +0000
commitb8edafeed8c95ae76bd5e630f2a5916e83630762 (patch)
treee3bbd0d3c27e3da17a795ec2b238481245bcb2c5 /sci-misc
parentStable on amd64 and x86, wrt bug #473242 (diff)
downloadgentoo-2-b8edafeed8c95ae76bd5e630f2a5916e83630762.tar.gz
gentoo-2-b8edafeed8c95ae76bd5e630f2a5916e83630762.tar.bz2
gentoo-2-b8edafeed8c95ae76bd5e630f2a5916e83630762.zip
sci-misc/apertium: Fix detection of libpcre, #440632
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/apertium/ChangeLog8
-rw-r--r--sci-misc/apertium/apertium-3.2.0.ebuild10
-rw-r--r--sci-misc/apertium/files/apertium-3.2.0-libpcre.patch43
-rw-r--r--sci-misc/apertium/metadata.xml4
4 files changed, 58 insertions, 7 deletions
diff --git a/sci-misc/apertium/ChangeLog b/sci-misc/apertium/ChangeLog
index 98cfdec0b917..3131dd4a1d8f 100644
--- a/sci-misc/apertium/ChangeLog
+++ b/sci-misc/apertium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/apertium
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/ChangeLog,v 1.6 2012/05/04 07:50:52 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/ChangeLog,v 1.7 2013/06/14 06:52:28 jlec Exp $
+
+ 14 Jun 2013; Justin Lecher <jlec@gentoo.org> apertium-3.2.0.ebuild,
+ +files/apertium-3.2.0-libpcre.patch, metadata.xml:
+ Fix detection of libpcre, #440632
04 May 2012; Jeff Horelick <jdhore@gentoo.org> apertium-3.2.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-misc/apertium/apertium-3.2.0.ebuild b/sci-misc/apertium/apertium-3.2.0.ebuild
index 76d96b49acde..ace70d4163d9 100644
--- a/sci-misc/apertium/apertium-3.2.0.ebuild
+++ b/sci-misc/apertium/apertium-3.2.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/apertium-3.2.0.ebuild,v 1.3 2012/05/04 07:50:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/apertium/apertium-3.2.0.ebuild,v 1.4 2013/06/14 06:52:28 jlec Exp $
-EAPI=4
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
inherit autotools-utils
@@ -26,6 +28,8 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PV}-flags.patch
"${FILESDIR}"/${PV}-datadir.patch
+ "${FILESDIR}"/${P}-libpcre.patch
)
MAKEOPTS+=" -j1"
+AUTOTOOLS_IN_SOURCE_BUILD=1
diff --git a/sci-misc/apertium/files/apertium-3.2.0-libpcre.patch b/sci-misc/apertium/files/apertium-3.2.0-libpcre.patch
new file mode 100644
index 000000000000..29a6a5483bb8
--- /dev/null
+++ b/sci-misc/apertium/files/apertium-3.2.0-libpcre.patch
@@ -0,0 +1,43 @@
+ configure.ac | 28 ++++++++++++++++------------
+ 1 file changed, 16 insertions(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0bfca01..2d8ec3b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -183,19 +183,23 @@ AC_CHECK_FUNCS(strcasecmp)
+
+ if test x$(uname) != xDarwin;
+ then
+-AC_CHECK_HEADER(pcreposix.h,
+- AC_CHECK_LIB(pcre, pcre_info,[
+- LIBS="$LIBS -lpcreposix -lpcre"
+- no_comp_check=yes],
+- AC_MSG_ERROR([*** unable to locate pcre library ***])),
+- AC_MSG_ERROR([*** unable to locate pcreposix.h include file ***]))
++PKG_CHECK_MODULES([PCRE],
++ [libpcre libpcreposix libpcrecpp],
++ [LIBS="${LIBS} ${PCRE_LIBS}" no_comp_check=yes], [
++ AC_CHECK_HEADER(pcreposix.h,
++ AC_CHECK_LIB(pcre, pcre_version,[
++ LIBS="$LIBS -lpcreposix -lpcre"
++ no_comp_check=yes],
++ AC_MSG_ERROR([*** unable to locate pcre library ***])),
++ AC_MSG_ERROR([*** unable to locate pcreposix.h include file ***]))
+
+-AC_CHECK_HEADER(pcrecpp.h,
+- AC_CHECK_LIB(pcrecpp,pcre_compile,[
+- LIBS="$LIBS -lpcrecpp"
+- no_comp_check=yes],
+- AC_MSG_ERROR([*** unable to locate pcrecpp library ***])),
+- AC_MSG_ERROR([*** unable to locate pcrecpp.h include file ***]))
++ AC_CHECK_HEADER(pcrecpp.h,
++ AC_CHECK_LIB(pcrecpp,pcre_compile,[
++ LIBS="$LIBS -lpcrecpp"
++ no_comp_check=yes],
++ AC_MSG_ERROR([*** unable to locate pcrecpp library ***])),
++ AC_MSG_ERROR([*** unable to locate pcrecpp.h include file ***]))
++ ])
+ fi
+
+
diff --git a/sci-misc/apertium/metadata.xml b/sci-misc/apertium/metadata.xml
index 77c01f62e274..68024782b0da 100644
--- a/sci-misc/apertium/metadata.xml
+++ b/sci-misc/apertium/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
Apertium is an open-source shallow-transfer machine translation
engine and toolbox.
</longdescription>