summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-08-20 15:15:06 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-08-20 15:15:06 +0000
commit859c3f9ef4c792fdebccc64627764855971a5a17 (patch)
treee021b98fb18496a2bd3dfd3572f3a902b5043df0 /sci-misc
parentnew version, get rid of hexdec patch ( merged upstream ), get rid of hacks fo... (diff)
downloadgentoo-2-859c3f9ef4c792fdebccc64627764855971a5a17.tar.gz
gentoo-2-859c3f9ef4c792fdebccc64627764855971a5a17.tar.bz2
gentoo-2-859c3f9ef4c792fdebccc64627764855971a5a17.zip
Cleaned out some old ebuilds. Fixed the php dependency, closing bug 102835.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog8
-rw-r--r--sci-misc/boinc/boinc-4.19.ebuild87
-rw-r--r--sci-misc/boinc/boinc-4.32.ebuild28
-rw-r--r--sci-misc/boinc/boinc-4.72.20050725.ebuild77
-rw-r--r--sci-misc/boinc/boinc-4.72.20050813.ebuild18
-rw-r--r--sci-misc/boinc/files/digest-boinc-4.191
-rw-r--r--sci-misc/boinc/files/digest-boinc-4.72.200507251
7 files changed, 27 insertions, 193 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 55a5fff9d1d4..e9bc2eb9947f 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.6 2005/08/14 00:18:39 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.7 2005/08/20 15:15:06 cryos Exp $
+
+ 20 Aug 2005; Marcus D. Hanwell <marcus@gentoo.org> -boinc-4.19.ebuild,
+ boinc-4.32.ebuild, -boinc-4.72.20050725.ebuild,
+ boinc-4.72.20050813.ebuild:
+ Cleaned out some old ebuilds. Fixed the php dependency to virtual/php
+ closing bug 102835.
*boinc-4.72.20050813 (14 Aug 2005)
*boinc-4.72.20050725 (14 Aug 2005)
diff --git a/sci-misc/boinc/boinc-4.19.ebuild b/sci-misc/boinc/boinc-4.19.ebuild
deleted file mode 100644
index 75080b148e53..000000000000
--- a/sci-misc/boinc/boinc-4.19.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.19.ebuild,v 1.2 2005/05/28 12:49:44 cryos Exp $
-
-inherit eutils
-
-MY_PN="boinc_public-cvs"
-MY_PV="2005-01-26"
-S=${WORKDIR}/boinc_public
-
-DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
-HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="http://boinc.ssl.berkeley.edu/source/nightly/${MY_PN}-${MY_PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="server X"
-
-DEPEND=">=sys-devel/gcc-3.0.4
- >=sys-devel/autoconf-2.59
- >=sys-devel/automake-1.9.3
- X? ( virtual/x11
- virtual/glut
- virtual/glu
- >=x11-libs/wxGTK-2.4.2-r2 )
- server? ( >=dev-db/mysql-4.0.24
- >=dev-php/php-4.3.10
- >=dev-lang/python-2.2.3 )"
-RDEPEND=" X? ( virtual/x11
- virtual/glut
- virtual/glu
- >=x11-libs/wxGTK-2.4.2-r2 )
- server? ( net-www/apache
- >=dev-db/mysql-4.0.24
- >=dev-php/php-4.3.10
- >=dev-lang/python-2.2.3
- dev-python/mysql-python )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # point to a proper mouse device
- sed -i "s:/dev/mouse:/dev/psaux:g" client/hostinfo_unix.C
-}
-
-src_compile() {
- # boinc does not support unicode so force wxconfig non-unicode
- WXCONFIG=$(ls /usr/bin/wxgtk2-?.?-config)
- if [ -e "${WXCONFIG}" ]; then
- CONF="--with-wx-config=${WXCONFIG}"
- fi
-
- econf --enable-client \
- `use_enable server` \
- `use_with X x` \
- ${CONF} || die "could not configure"
- emake || die "emake failed"
-}
-
-src_install() {
-# einstall || die "install failed"
- make install DESTDIR=${D} || die "make install failed"
-
- newinitd ${FILESDIR}/boinc.init boinc
- newconfd ${FILESDIR}/boinc.conf boinc
-}
-
-pkg_preinst() {
- enewgroup boinc
- enewuser boinc -1 /bin/false /var/lib/boinc boinc
-}
-
-pkg_postinst() {
- echo
- einfo "You need to attach to a project to do anything useful with boinc."
- einfo "You can do this by running /etc/init.d/boinc attach"
- einfo "BOINC The howto for configuration is located at:"
- einfo "http://boinc.berkeley.edu/anonymous_platform.php"
- if use server;then
- einfo "You have chosen to enable server mode. this ebuild has installed"
- einfo "the necessary packages to be a server, you will need to have a"
- einfo "project. Contact BOINC directly for further information."
- fi
- echo
-}
diff --git a/sci-misc/boinc/boinc-4.32.ebuild b/sci-misc/boinc/boinc-4.32.ebuild
index 490e957e1047..b48c0ab0e7f4 100644
--- a/sci-misc/boinc/boinc-4.32.ebuild
+++ b/sci-misc/boinc/boinc-4.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.32.ebuild,v 1.4 2005/08/06 11:53:21 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.32.ebuild,v 1.5 2005/08/20 15:15:06 cryos Exp $
inherit eutils
@@ -17,25 +17,19 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="server X"
+RDEPEND="X? ( virtual/x11
+ virtual/glut
+ virtual/glu
+ >=x11-libs/wxGTK-2.4.2-r2 )
+ server? ( net-www/apache
+ >=dev-db/mysql-4.0.24
+ virtual/php
+ >=dev-lang/python-2.2.3
+ dev-python/mysql-python )"
DEPEND=">=sys-devel/gcc-3.0.4
>=sys-devel/autoconf-2.59
>=sys-devel/automake-1.9.3
- X? ( virtual/x11
- virtual/glut
- virtual/glu
- >=x11-libs/wxGTK-2.4.2-r2 )
- server? ( >=dev-db/mysql-4.0.24
- >=dev-php/php-4.3.10
- >=dev-lang/python-2.2.3 )"
-RDEPEND=" X? ( virtual/x11
- virtual/glut
- virtual/glu
- >=x11-libs/wxGTK-2.4.2-r2 )
- server? ( net-www/apache
- >=dev-db/mysql-4.0.24
- >=dev-php/php-4.3.10
- >=dev-lang/python-2.2.3
- dev-python/mysql-python )"
+ ${RDEPEND}"
src_unpack() {
unpack ${A}
diff --git a/sci-misc/boinc/boinc-4.72.20050725.ebuild b/sci-misc/boinc/boinc-4.72.20050725.ebuild
deleted file mode 100644
index 8c448d3cf090..000000000000
--- a/sci-misc/boinc/boinc-4.72.20050725.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050725.ebuild,v 1.1 2005/08/14 00:18:39 ribosome Exp $
-
-inherit eutils
-
-MY_PN="boinc_public-cvs"
-MY_PV="2005-07-25"
-S=${WORKDIR}/boinc_public
-
-DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
-HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="http://boinc.ssl.berkeley.edu/source/nightly/${MY_PN}-${MY_PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="server X"
-
-RDEPEND=" X? ( virtual/x11
- virtual/glut
- virtual/glu
- >=x11-libs/wxGTK-2.6.0 )
- server? ( net-www/apache
- >=dev-db/mysql-4.0.24
- >=dev-php/php-4.3.10
- >=dev-lang/python-2.2.3
- dev-python/mysql-python )"
-DEPEND=">=sys-devel/gcc-3.0.4
- >=sys-devel/autoconf-2.59
- >=sys-devel/automake-1.9.3
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # point to a proper mouse device
- sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
-}
-
-src_compile() {
- econf \
- --enable-client \
- --disable-static-client \
- --with-wx-config=$(which wx-config-2.6) \
- $(use_enable server) \
- $(use_with X x) || die
- emake || die
-}
-
-src_install() {
- make install DESTDIR=${D} || die
-
- newinitd ${FILESDIR}/boinc.init boinc
- newconfd ${FILESDIR}/boinc.conf boinc
-}
-
-pkg_preinst() {
- enewgroup boinc
- enewuser boinc -1 /bin/false /var/lib/boinc boinc
-}
-
-pkg_postinst() {
- echo
- einfo "You need to attach to a project to do anything useful with boinc."
- einfo "You can do this by running /etc/init.d/boinc attach"
- einfo "BOINC The howto for configuration is located at:"
- einfo "http://boinc.berkeley.edu/anonymous_platform.php"
- if use server;then
- echo
- einfo "You have chosen to enable server mode. this ebuild has installed"
- einfo "the necessary packages to be a server. You will need to have a"
- einfo "project. Contact BOINC directly for further information."
- fi
- echo
-}
diff --git a/sci-misc/boinc/boinc-4.72.20050813.ebuild b/sci-misc/boinc/boinc-4.72.20050813.ebuild
index dbe98ffd9243..98ea39230cee 100644
--- a/sci-misc/boinc/boinc-4.72.20050813.ebuild
+++ b/sci-misc/boinc/boinc-4.72.20050813.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813.ebuild,v 1.1 2005/08/14 00:18:39 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813.ebuild,v 1.2 2005/08/20 15:15:06 cryos Exp $
inherit eutils
@@ -17,15 +17,15 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="server X"
-RDEPEND=" X? ( virtual/x11
- virtual/glut
- virtual/glu
- >=x11-libs/wxGTK-2.6.0 )
+RDEPEND="X? ( virtual/x11
+ virtual/glut
+ virtual/glu
+ >=x11-libs/wxGTK-2.6.0 )
server? ( net-www/apache
- >=dev-db/mysql-4.0.24
- >=dev-php/php-4.3.10
- >=dev-lang/python-2.2.3
- dev-python/mysql-python )"
+ >=dev-db/mysql-4.0.24
+ virtual/php
+ >=dev-lang/python-2.2.3
+ dev-python/mysql-python )"
DEPEND=">=sys-devel/gcc-3.0.4
>=sys-devel/autoconf-2.59
>=sys-devel/automake-1.9.3
diff --git a/sci-misc/boinc/files/digest-boinc-4.19 b/sci-misc/boinc/files/digest-boinc-4.19
deleted file mode 100644
index efb1e665ff82..000000000000
--- a/sci-misc/boinc/files/digest-boinc-4.19
+++ /dev/null
@@ -1 +0,0 @@
-MD5 59c8ca1810bd83f58d57ea54c8c27615 boinc_public-cvs-2005-01-26.tar.gz 3845012
diff --git a/sci-misc/boinc/files/digest-boinc-4.72.20050725 b/sci-misc/boinc/files/digest-boinc-4.72.20050725
deleted file mode 100644
index bd91e8474cdb..000000000000
--- a/sci-misc/boinc/files/digest-boinc-4.72.20050725
+++ /dev/null
@@ -1 +0,0 @@
-MD5 03dc61863f996f52b16c50c5889b3d0e boinc_public-cvs-2005-07-25.tar.gz 6054522