summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-09 10:29:25 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-09 10:29:25 +0000
commit9a75de8944ed7425665653e94048c3894b23f4c1 (patch)
treeff4e603a95a3bd833ac96fc19569415977a9a88b /sci-mathematics
parentStable for ppc/ppc64, wrt bug #531310 (diff)
downloadgentoo-2-9a75de8944ed7425665653e94048c3894b23f4c1.tar.gz
gentoo-2-9a75de8944ed7425665653e94048c3894b23f4c1.tar.bz2
gentoo-2-9a75de8944ed7425665653e94048c3894b23f4c1.zip
Version Bump, fixes problems with format security, #542666
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/nauty/ChangeLog10
-rw-r--r--sci-mathematics/nauty/metadata.xml12
-rw-r--r--sci-mathematics/nauty/nauty-2.5.9.ebuild42
3 files changed, 56 insertions, 8 deletions
diff --git a/sci-mathematics/nauty/ChangeLog b/sci-mathematics/nauty/ChangeLog
index 166df2033dea..84478a6be253 100644
--- a/sci-mathematics/nauty/ChangeLog
+++ b/sci-mathematics/nauty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/nauty
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nauty/ChangeLog,v 1.5 2014/08/10 20:23:44 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nauty/ChangeLog,v 1.6 2015/03/09 10:29:25 jlec Exp $
+
+*nauty-2.5.9 (09 Mar 2015)
+
+ 09 Mar 2015; Justin Lecher <jlec@gentoo.org> +nauty-2.5.9.ebuild,
+ metadata.xml:
+ Version Bump, fixes problems with format security, #542666
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> nauty-2.4.2.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/sci-mathematics/nauty/metadata.xml b/sci-mathematics/nauty/metadata.xml
index 0c5be24442aa..186d7a91db3c 100644
--- a/sci-mathematics/nauty/metadata.xml
+++ b/sci-mathematics/nauty/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>tomka@gentoo.org</email>
- <name>Thomas Kahle</name>
-</maintainer>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
nauty is a program for computing automorphism groups of graphs and digraphs. It can also produce a
canonical labelling.
diff --git a/sci-mathematics/nauty/nauty-2.5.9.ebuild b/sci-mathematics/nauty/nauty-2.5.9.ebuild
new file mode 100644
index 000000000000..fd11ad7114d3
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.5.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nauty/nauty-2.5.9.ebuild,v 1.1 2015/03/09 10:29:25 jlec Exp $
+
+EAPI=5
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 2 'r')
+MY_PV=$(delete_version_separator 1 ${MY_PV})
+
+DESCRIPTION="Computing automorphism groups of graphs and digraphs"
+HOMEPAGE="http://pallini.di.uniroma1.it/"
+SRC_URI="http://cs.anu.edu.au/~bdm/${PN}/${PN}${MY_PV}.tar.gz"
+
+LICENSE="nauty"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare () {
+ sed \
+ -e "s/^LDFLAGS=.*/LDFLAGS=${LDFLAGS}/" \
+ -e 's:${CC} -o:${CC} ${LDFLAGS} -o:g' \
+ -e 's:${LDFLAGS}$::g' \
+ -i makefile.in || die
+}
+
+src_test () {
+ emake checks
+ ./runalltests
+}
+
+src_install () {
+ dobin addedgeg amtog biplabg catg complg copyg countg \
+ deledgeg directg dreadnaut dretog genbg geng genrang \
+ gentourng labelg listg multig newedgeg NRswitchg pickg \
+ planarg shortg showg
+ dodoc README formats.txt nug*.pdf
+}