summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-08 15:59:39 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-08 15:59:39 +0000
commit7ea7a45725cafc76008eef68abd73580e7f4b006 (patch)
treea17af52c1243dceb37d2e682ad7daf6174cda346 /sci-mathematics
parentinitial version, intended as an update to dev-php/PEAR-PhpDocumentor; note th... (diff)
downloadgentoo-2-7ea7a45725cafc76008eef68abd73580e7f4b006.tar.gz
gentoo-2-7ea7a45725cafc76008eef68abd73580e7f4b006.tar.bz2
gentoo-2-7ea7a45725cafc76008eef68abd73580e7f4b006.zip
sci-mathematics/prover9: Fix breakage due to dropping make target, #497530; Respect CC
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/prover9/ChangeLog5
-rw-r--r--sci-mathematics/prover9/prover9-2009.11a.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/sci-mathematics/prover9/ChangeLog b/sci-mathematics/prover9/ChangeLog
index 542d7657b99f..3f2ebd1d80dd 100644
--- a/sci-mathematics/prover9/ChangeLog
+++ b/sci-mathematics/prover9/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/prover9
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/prover9/ChangeLog,v 1.5 2014/01/06 14:02:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/prover9/ChangeLog,v 1.6 2014/01/08 15:59:39 jlec Exp $
+
+ 08 Jan 2014; Justin Lecher <jlec@gentoo.org> prover9-2009.11a.ebuild:
+ Fix breakage due to dropping make target, #497530; Respect CC
06 Jan 2014; Justin Lecher <jlec@gentoo.org> prover9-2009.11a.ebuild,
metadata.xml:
diff --git a/sci-mathematics/prover9/prover9-2009.11a.ebuild b/sci-mathematics/prover9/prover9-2009.11a.ebuild
index 9ae3d778b705..8189523d67b8 100644
--- a/sci-mathematics/prover9/prover9-2009.11a.ebuild
+++ b/sci-mathematics/prover9/prover9-2009.11a.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/prover9/prover9-2009.11a.ebuild,v 1.3 2014/01/06 14:02:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/prover9/prover9-2009.11a.ebuild,v 1.4 2014/01/08 15:59:39 jlec Exp $
EAPI=5
-inherit eutils versionator
+inherit eutils toolchain-funcs versionator
MY_PN="LADR"
typeset -u MY_PV
@@ -15,7 +15,7 @@ DESCRIPTION="Automated theorem prover for first-order and equational logic"
HOMEPAGE="http://www.cs.unm.edu/~mccune/mace4/"
SRC_URI="
http://www.cs.unm.edu/~mccune/mace4/download/${MY_P}.tar.gz
- http://dev.gentoo.org/~gienah/2big4tree/sci-mathematics/prover9/${MY_PN}-2009-11A-makefile.patch.bz2"
+ http://dev.gentoo.org/~jlec/distfiles/${MY_PN}-2009-11A-makefile.patch.xz"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -23,8 +23,8 @@ LICENSE="GPL-2"
IUSE="examples"
PATCHES=(
- "${DISTDIR}/${MY_PN}-2009-11A-makefile.patch.bz2"
- "${FILESDIR}/${MY_PN}-2009-11A-manpages.patch"
+ "${WORKDIR}"/${MY_PN}-2009-11A-makefile.patch
+ "${FILESDIR}"/${MY_PN}-2009-11A-manpages.patch
)
S="${WORKDIR}/${MY_P}/"
@@ -32,6 +32,13 @@ S="${WORKDIR}/${MY_P}/"
src_prepare() {
MAKEOPTS+=" -j1"
epatch ${PATCHES[@]}
+ sed \
+ -e "/^CC =/s:gcc:$(tc-getCC):g" \
+ -i */Makefile || die
+}
+
+src_compile() {
+ emake all
}
src_install () {