summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-03 13:01:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-03 13:01:52 +0000
commit7c30576ffb3c8db49a4632ec61bb958441378e4a (patch)
tree61de84ffb955ded0a0327534b8cff9192e65a24f /sci-mathematics
parentBlock lighttpd until spawn-fcgi collision is fixed. See bug #224781. (diff)
downloadgentoo-2-7c30576ffb3c8db49a4632ec61bb958441378e4a.tar.gz
gentoo-2-7c30576ffb3c8db49a4632ec61bb958441378e4a.tar.bz2
gentoo-2-7c30576ffb3c8db49a4632ec61bb958441378e4a.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-14.3.1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index d5d65ce67fd9..f57792981f55 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.38 2009/01/02 20:28:34 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.39 2009/02/03 13:01:52 bicatali Exp $
+
+*mathomatic-14.3.1 (03 Feb 2009)
+
+ 03 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-14.3.1.ebuild:
+ Version bump
*mathomatic-14.2.7 (02 Jan 2009)
diff --git a/sci-mathematics/mathomatic/mathomatic-14.3.1.ebuild b/sci-mathematics/mathomatic/mathomatic-14.3.1.ebuild
new file mode 100644
index 000000000000..5330882036c6
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-14.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-14.3.1.ebuild,v 1.1 2009/02/03 13:01:52 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+
+src_compile() {
+ sed -i \
+ -e '/^CFLAGS/ s/-O.//' \
+ makefile primes/makefile || die "sed failed"
+ emake READLINE=1 || die "emake failed"
+ emake -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic primes/matho-{primes,pascal,sumsq} || die
+ dodoc changes.txt README.txt AUTHORS || die
+ doman mathomatic.1 primes/*.1 || die
+ doicon icons/mathomatic.png || die
+ domenu icons/mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}