summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-04-10 20:03:20 +0000
committerIan Stakenvicius <axs@gentoo.org>2015-04-10 20:03:20 +0000
commit4a98e4a443ab8cbed70b00f2bc1ad2248dcaee89 (patch)
treebd0ad2f831b83429e4fa92d593505e2ca927e8a9 /sci-mathematics
parentVersion bumps (diff)
downloadgentoo-2-4a98e4a443ab8cbed70b00f2bc1ad2248dcaee89.tar.gz
gentoo-2-4a98e4a443ab8cbed70b00f2bc1ad2248dcaee89.tar.bz2
gentoo-2-4a98e4a443ab8cbed70b00f2bc1ad2248dcaee89.zip
Took over package maintainership and restored 4.3 version to the tree with nod from xarthisius. 4.3-r1 ebuild resolves file parsing bug introduced in 4.2-r9 (bug 546066) and converts to distutils-r1 (bug 544920).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/snns/ChangeLog12
-rw-r--r--sci-mathematics/snns/files/4.3-bison-version.patch11
-rw-r--r--sci-mathematics/snns/files/4.3-unstrip.patch11
-rw-r--r--sci-mathematics/snns/metadata.xml4
-rw-r--r--sci-mathematics/snns/snns-4.3-r1.ebuild121
5 files changed, 157 insertions, 2 deletions
diff --git a/sci-mathematics/snns/ChangeLog b/sci-mathematics/snns/ChangeLog
index a3c6d8692032..34bd1914ef58 100644
--- a/sci-mathematics/snns/ChangeLog
+++ b/sci-mathematics/snns/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/snns
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.25 2013/07/21 09:45:08 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.26 2015/04/10 20:03:20 axs Exp $
+
+*snns-4.3-r1 (10 Apr 2015)
+
+ 10 Apr 2015; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +snns-4.3-r1.ebuild,
+ +files/4.3-bison-version.patch, +files/4.3-unstrip.patch, metadata.xml:
+ Took over package maintainership and restored 4.3 version to the tree with
+ nod from xarthisius. 4.3-r1 ebuild resolves file parsing bug introduced in
+ 4.2-r9 (bug 546066) and converts to distutils-r1 (bug 544920).
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #473480
diff --git a/sci-mathematics/snns/files/4.3-bison-version.patch b/sci-mathematics/snns/files/4.3-bison-version.patch
new file mode 100644
index 000000000000..73da70187254
--- /dev/null
+++ b/sci-mathematics/snns/files/4.3-bison-version.patch
@@ -0,0 +1,11 @@
+--- configure.old 2015-04-08 16:27:05.000000000 -0400
++++ configure 2015-04-08 16:26:41.000000000 -0400
+@@ -5071,7 +5071,7 @@
+ else
+ { echo "$as_me:$LINENO: checking for version of bison" >&5
+ echo $ECHO_N "checking for version of bison... $ECHO_C" >&6; }
+- bison_version=`$BISON --version`
++ bison_version=`$BISON --version |head -n 1`
+ { echo "$as_me:$LINENO: result: $bison_version" >&5
+ echo "${ECHO_T}$bison_version" >&6; }
+ warn_bison=yes
diff --git a/sci-mathematics/snns/files/4.3-unstrip.patch b/sci-mathematics/snns/files/4.3-unstrip.patch
new file mode 100644
index 000000000000..4f36040e2218
--- /dev/null
+++ b/sci-mathematics/snns/files/4.3-unstrip.patch
@@ -0,0 +1,11 @@
+--- a/configuration/install-sh 2008-04-21 03:55:33.000000000 -0400
++++ b/configuration/install-sh 2015-04-08 16:59:32.000000000 -0400
+@@ -79,7 +79,7 @@
+ shift
+ continue;;
+
+- -s) stripcmd="$stripprog"
++ -s) stripcmd=""
+ shift
+ continue;;
+
diff --git a/sci-mathematics/snns/metadata.xml b/sci-mathematics/snns/metadata.xml
index 5a2f1c7b832e..601be9594b9b 100644
--- a/sci-mathematics/snns/metadata.xml
+++ b/sci-mathematics/snns/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-mathematics</herd>
+<maintainer>
+ <email>axs@gentoo.org</email>
+ <name>Ian Stakenvicius</name>
+</maintainer>
</pkgmetadata>
diff --git a/sci-mathematics/snns/snns-4.3-r1.ebuild b/sci-mathematics/snns/snns-4.3-r1.ebuild
new file mode 100644
index 000000000000..a73da91c7eee
--- /dev/null
+++ b/sci-mathematics/snns/snns-4.3-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.3-r1.ebuild,v 1.1 2015/04/10 20:03:20 axs Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1 eutils
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://sourceforge.net/projects/snns/"
+SRC_URI="http://www.ra.cs.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ doc? ( http://www.ra.cs.uni-tuebingen.de/downloads/SNNS/SNNSv4.2.Manual.pdf )"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="X doc python"
+
+RDEPEND="X? ( x11-libs/libXaw3d )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.2.2
+ X? ( x11-proto/xproto )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/4.3-unstrip.patch
+ epatch "${FILESDIR}"/4.3-bison-version.patch
+ epatch "${FILESDIR}"/4.2-ldflags.patch
+
+ # change all references of Xaw to Xaw3d
+ cd "${S}"/xgui/sources
+ for file in *.c; do
+ sed -e "s:X11/Xaw/:X11/Xaw3d/:g" -i "${file}"
+ done
+
+ # clean up files that apparently are not removed by any clean rules
+ rm -Rf "${S}"/{tools,xgui}/bin \
+ "${S}"/{Makefile.def,config.h} \
+ "${S}"/configuration/config.{guess,log}
+
+ epatch_user
+
+ if use python; then
+ pushd "${S}"/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ econf --enable-global \
+ $(use_with X x)
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ local compileopts=( compile-kernel compile-tools )
+ use X && compileopts+=( compile-xgui )
+
+ # tarball is sometimes left dirty
+ emake clean
+
+ # parallel make sometimes fails (phosphan)
+ # so emake each phase separately (axs)
+ for tgt in "${compileopts[@]}"; do
+ emake ${tgt}
+ done
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ # bug 248322
+ mv "${ED}"/usr/bin/{,snns-}netperf || die
+
+ if use X; then
+ newbin xgui/sources/xgui snns
+
+ echo XGUILOADPATH=/usr/share/doc/${PF} > "${T}"/99snns
+ doenvd "${T}"/99snns
+
+ docompress -x /usr/share/doc/${PF}/{default.cfg,help.hdoc}
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_install
+ insinto /usr/share/doc/${PF}/python-examples
+ doins examples/*
+ newdoc README README.python
+ popd > /dev/null || die
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${MY_P}.Manual.pdf
+ fi
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ doman man/man*/*
+}