summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 14:06:23 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 14:06:23 +0000
commit49b629cb52777c2b983c884d60fc6b6aaf24be90 (patch)
treedeb944adba457b26942b99e1a71ec06e4ba4279f /sci-mathematics
parentMarked ~hppa (bug #497068). (diff)
downloadgentoo-2-49b629cb52777c2b983c884d60fc6b6aaf24be90.tar.gz
gentoo-2-49b629cb52777c2b983c884d60fc6b6aaf24be90.tar.bz2
gentoo-2-49b629cb52777c2b983c884d60fc6b6aaf24be90.zip
sci-mathematics/octave: Drop old; punt base.eclass
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/octave-3.4.3-r1.ebuild105
2 files changed, 5 insertions, 107 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 62e78d9dda3f..98d2ae4bb647 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.146 2013/12/07 18:50:41 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.147 2014/01/06 14:06:23 jlec Exp $
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> -octave-3.4.3-r1.ebuild:
+ Drop old; punt base.eclass
*octave-3.6.4-r1 (07 Dec 2013)
diff --git a/sci-mathematics/octave/octave-3.4.3-r1.ebuild b/sci-mathematics/octave/octave-3.4.3-r1.ebuild
deleted file mode 100644
index d32348004f9a..000000000000
--- a/sci-mathematics/octave/octave-3.4.3-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.3-r1.ebuild,v 1.15 2013/02/21 13:30:58 jlec Exp $
-
-EAPI=4
-inherit eutils base autotools toolchain-funcs
-
-DESCRIPTION="High-level interactive language for numerical computations"
-LICENSE="GPL-3"
-HOMEPAGE="http://www.octave.org/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-IUSE="curl doc fftw +glpk +imagemagick opengl openmp +qhull +qrupdate
- readline +sparse static-libs X zlib"
-KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="dev-libs/libpcre
- app-text/ghostscript-gpl
- sys-libs/ncurses
- virtual/lapack
- curl? ( net-misc/curl )
- fftw? ( sci-libs/fftw:3.0 )
- glpk? ( sci-mathematics/glpk )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
- opengl? (
- media-libs/freetype:2
- media-libs/fontconfig
- >=x11-libs/fltk-1.3:1[opengl] )
- qhull? ( media-libs/qhull )
- qrupdate? ( sci-libs/qrupdate )
- readline? ( sys-libs/readline )
- sparse? (
- sci-libs/camd
- sci-libs/ccolamd
- sci-libs/cholmod
- sci-libs/colamd
- sci-libs/cxsparse
- sci-libs/umfpack )
- X? ( x11-libs/libX11 )
- zlib? ( sys-libs/zlib )"
-
-DEPEND="${RDEPEND}
- doc? (
- virtual/latex-base
- dev-texlive/texlive-genericrecommended
- sys-apps/texinfo )
- dev-util/gperf
- virtual/pkgconfig"
-
-pkg_setup() {
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp && \
- die "You have openmp enabled but your current gcc does not support it"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-{pkgbuilddir,help,texi}.patch
- eautoreconf
-}
-
-src_configure() {
- # hdf5 disabled because not really useful (bug #299876)
- local myconf="--without-magick"
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myconf="--with-magick=GraphicsMagick"
- else
- myconf="--with-magick=ImageMagick"
- fi
- fi
-
- econf \
- --localstatedir="${EPREFIX}/var/state/octave" \
- --enable-shared \
- --without-hdf5 \
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
- --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
- $(use_enable doc docs) \
- $(use_enable readline) \
- $(use_with curl) \
- $(use_with fftw fftw3) \
- $(use_with fftw fftw3f) \
- $(use_with glpk) \
- $(use_with opengl) \
- $(use_with qhull) \
- $(use_with qrupdate) \
- $(use_with sparse umfpack) \
- $(use_with sparse colamd) \
- $(use_with sparse ccolamd) \
- $(use_with sparse cholmod) \
- $(use_with sparse cxsparse) \
- $(use_with X x) \
- $(use_with zlib z) \
- ${myconf}
-}
-
-src_install() {
- default
- use doc && dodoc $(find doc -name \*.pdf)
- [[ -e test/fntests.log ]] && dodoc test/fntests.log
- echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${P}" > 99octave
- doenvd 99octave
-}