summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-14 16:13:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-14 16:13:48 +0000
commit2888944f0bd9619b1cbeeb0b3259388c4dfcaba8 (patch)
tree5405f35dcb628d3c7cf0ff2ee040686e6042b8f5 /sci-mathematics
parentStable for HPPA (bug #371261). (diff)
downloadgentoo-2-2888944f0bd9619b1cbeeb0b3259388c4dfcaba8.tar.gz
gentoo-2-2888944f0bd9619b1cbeeb0b3259388c4dfcaba8.tar.bz2
gentoo-2-2888944f0bd9619b1cbeeb0b3259388c4dfcaba8.zip
Tests for primes re-enabled. Added bold color flag
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog6
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index b8bb8b0ebdef..75c9b6f61f5b 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.58 2011/06/13 22:20:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.59 2011/06/14 16:13:48 bicatali Exp $
+
+ 14 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ mathomatic-15.6.2.ebuild:
+ Tests for primes re-enabled. Added bold color flag
*mathomatic-15.6.2 (13 Jun 2011)
diff --git a/sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild b/sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild
index ed93361692b9..b0deccdeee26 100644
--- a/sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild
+++ b/sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild,v 1.1 2011/06/13 22:20:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.6.2.ebuild,v 1.2 2011/06/14 16:13:48 bicatali Exp $
EAPI=4
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="Automatic algebraic manipulator"
HOMEPAGE="http://www.mathomatic.org/"
@@ -20,10 +20,16 @@ RDEPEND="${DEPEND}
gnuplot? ( sci-visualization/gnuplot )"
src_compile() {
+ append-cflags -DBOLD_COLOR=1
emake READLINE=1 CC=$(tc-getCC)
emake CC=$(tc-getCC) -C primes
}
+src_test() {
+ default
+ emake -C primes check
+}
+
src_install() {
emake prefix="${EPREFIX}usr" DESTDIR="${D}" bininstall
emake prefix="${EPREFIX}usr" DESTDIR="${D}" -C primes install