summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-11 22:33:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-11 22:33:31 +0000
commit0206cd3f631df0cd817f43c8d45fd1b60c95227f (patch)
treee55bd28bea0c45491a4b77cb00df6ea3faf5a714 /sci-mathematics
parentnet-wireless/gr-osmosdr: Add missing dependency on cheetah (diff)
downloadgentoo-2-0206cd3f631df0cd817f43c8d45fd1b60c95227f.tar.gz
gentoo-2-0206cd3f631df0cd817f43c8d45fd1b60c95227f.tar.bz2
gentoo-2-0206cd3f631df0cd817f43c8d45fd1b60c95227f.zip
Re-add hdf5, some octave packages might need it. Do in source configuring for preventing more bugs. Drop hppa (needs hdf5)
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/octave-3.6.2-r1.ebuild113
2 files changed, 120 insertions, 1 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index dc41b7b73e60..2bcb2053138e 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.126 2012/06/06 21:31:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.127 2012/06/11 22:33:31 bicatali Exp $
+
+*octave-3.6.2-r1 (11 Jun 2012)
+
+ 11 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> +octave-3.6.2-r1.ebuild:
+ Re-add hdf5, some octave packages might need it. Do in source configuring for
+ preventing more bugs. Drop hppa (needs hdf5)
*octave-3.6.2 (06 Jun 2012)
diff --git a/sci-mathematics/octave/octave-3.6.2-r1.ebuild b/sci-mathematics/octave/octave-3.6.2-r1.ebuild
new file mode 100644
index 000000000000..f5dc2287f1d7
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.6.2-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.6.2-r1.ebuild,v 1.1 2012/06/11 22:33:31 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils toolchain-funcs fortran-2
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="curl doc fftw +glpk gnuplot hdf5 +imagemagick opengl +qhull +qrupdate
+ readline +sparse static-libs X zlib"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-libs/libpcre
+ app-text/ghostscript-gpl
+ sys-libs/ncurses
+ virtual/lapack
+ curl? ( net-misc/curl )
+ fftw? ( sci-libs/fftw:3.0 )
+ glpk? ( sci-mathematics/glpk )
+ gnuplot? ( sci-visualization/gnuplot )
+ hdf5? ( sci-libs/hdf5 )
+ imagemagick? ( || (
+ media-gfx/graphicsmagick[cxx]
+ media-gfx/imagemagick[cxx] ) )
+ opengl? (
+ media-libs/freetype:2
+ media-libs/fontconfig
+ >=x11-libs/fltk-1.3:1[opengl] )
+ qhull? ( media-libs/qhull )
+ qrupdate? ( sci-libs/qrupdate )
+ readline? ( sys-libs/readline )
+ sparse? (
+ sci-libs/arpack
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/colamd
+ sci-libs/cxsparse
+ sci-libs/umfpack )
+ X? ( x11-libs/libX11 )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-genericrecommended
+ sys-apps/texinfo )
+ dev-util/gperf
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.3-{pkgbuilddir,help,texi}.patch )
+
+src_configure() {
+ # occasional fail on install, force regeneration see bug #401189
+ rm -f doc/interpreter/contributors.texi || die
+
+ # hdf5 disabled because not really useful (bug #299876)
+ local myconf="--without-magick"
+ if use imagemagick; then
+ if has_version media-gfx/graphicsmagick[cxx]; then
+ myconf="--with-magick=GraphicsMagick"
+ else
+ myconf="--with-magick=ImageMagick"
+ fi
+ fi
+
+ # gentoo bug #302621
+ use hdf5 && has_version sci-libs/hdf5[mpi] && \
+ export CXX=mpicxx CC=mpicc FC=mpif77 F77=mpif77
+
+ local myeconfargs+=(
+ --localstatedir="${EPREFIX}/var/state/octave"
+ --with-blas="$(pkg-config --libs blas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ $(use_enable doc docs)
+ $(use_enable readline)
+ $(use_with curl)
+ $(use_with fftw fftw3)
+ $(use_with fftw fftw3f)
+ $(use_with glpk)
+ $(use_with hdf5)
+ $(use_with opengl)
+ $(use_with qhull)
+ $(use_with qrupdate)
+ $(use_with sparse arpack)
+ $(use_with sparse umfpack)
+ $(use_with sparse colamd)
+ $(use_with sparse ccolamd)
+ $(use_with sparse cholmod)
+ $(use_with sparse cxsparse)
+ $(use_with X x)
+ $(use_with zlib z)
+ ${myconf}
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc $(find doc -name \*.pdf)
+ [[ -e test/fntests.log ]] && dodoc test/fntests.log
+ echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${P}" > 99octave
+ doenvd 99octave
+}