summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-04-29 09:01:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-04-29 09:01:39 +0000
commitfd6d79a7a9bb28b659acb0c3fd14826505b51653 (patch)
tree7d78a9ed01b31e0d2b93c24cb4a8fcaeec543f56 /sci-mathematics/wxmaxima
parentVersion bump (diff)
downloadgentoo-2-fd6d79a7a9bb28b659acb0c3fd14826505b51653.tar.gz
gentoo-2-fd6d79a7a9bb28b659acb0c3fd14826505b51653.tar.bz2
gentoo-2-fd6d79a7a9bb28b659acb0c3fd14826505b51653.zip
Version bump
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog8
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.7.5.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index e9725c3d1e63..db840e797868 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.16 2008/04/19 09:46:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.17 2008/04/29 09:01:39 bicatali Exp $
+
+*wxmaxima-0.7.5 (29 Apr 2008)
+
+ 29 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +wxmaxima-0.7.5.ebuild:
+ Version bump
19 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
wxmaxima-0.7.4.ebuild:
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.7.5.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.7.5.ebuild
new file mode 100644
index 000000000000..a7939a29dd30
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.7.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.5.ebuild,v 1.1 2008/04/29 09:01:39 bicatali Exp $
+
+WX_GTK_VER="2.8"
+EAPI="1"
+inherit eutils autotools wxwidgets fdo-mime
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-libs/libxml2-2.5.0
+ x11-libs/wxGTK:2.8"
+RDEPEND="${DEPEND}
+ >=sci-mathematics/maxima-5.15.0"
+
+S="${WORKDIR}/${MYP}"
+
+src_compile () {
+
+ # consistent package names
+ sed -i \
+ -e "s:${datadir}/wxMaxima:${datadir}/${PN}:g" \
+ Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -i \
+ -e 's:share/wxMaxima:share/wxmaxima:g' \
+ src/wxMaxima.cpp || die "sed failed"
+
+ econf \
+ --enable-dnd \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG} \
+ $(use_unicode unicode-glyphs) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dodir /usr/share/doc/${PF}
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}