summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-06-11 14:31:38 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-06-11 14:31:38 +0000
commit6650cbfc70910ac9a193bb9c16c4efbac490acf3 (patch)
tree24a2fc18dd4855f1a2edf0a1836e71d5b3dd98cf /sci-mathematics/spin
parentFix invalid variable name in amd64 profiles. (diff)
downloadgentoo-2-6650cbfc70910ac9a193bb9c16c4efbac490acf3.tar.gz
gentoo-2-6650cbfc70910ac9a193bb9c16c4efbac490acf3.tar.bz2
gentoo-2-6650cbfc70910ac9a193bb9c16c4efbac490acf3.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/spin')
-rw-r--r--sci-mathematics/spin/ChangeLog8
-rw-r--r--sci-mathematics/spin/files/spin-xspin-r1.patch26
-rw-r--r--sci-mathematics/spin/spin-5.2.5.ebuild54
3 files changed, 87 insertions, 1 deletions
diff --git a/sci-mathematics/spin/ChangeLog b/sci-mathematics/spin/ChangeLog
index af91d4d9cdda..6432b8eb02d9 100644
--- a/sci-mathematics/spin/ChangeLog
+++ b/sci-mathematics/spin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/spin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.1 2010/04/11 12:50:07 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.2 2010/06/11 14:31:38 phajdan.jr Exp $
+
+*spin-5.2.5 (11 Jun 2010)
+
+ 11 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/spin-xspin-r1.patch, +spin-5.2.5.ebuild:
+ Version bump.
*spin-5.2.4 (11 Apr 2010)
diff --git a/sci-mathematics/spin/files/spin-xspin-r1.patch b/sci-mathematics/spin/files/spin-xspin-r1.patch
new file mode 100644
index 000000000000..7606fa55a787
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-xspin-r1.patch
@@ -0,0 +1,26 @@
+--- xspin.tcl.orig 2010-04-03 12:26:48.000000000 +0200
++++ xspin.tcl 2010-04-03 12:27:26.000000000 +0200
+@@ -1,22 +1,4 @@
+-#!/bin/sh
+-# the next line restarts using wish \
+-exec wish c:/cygwin/bin/xspin -- $*
+-
+-# cd ;# enable to cd to home directory by default
+-
+-# on PCs:
+-# adjust the first argument to wish above with the name and
+-# location of this tcl/tk file on your system, if different.
+-#
+-# Cygwin:
+-# if you use cygwin, do not refer to the file as /usr/bin/xspin
+-# /usr/bin is a symbolic link to /bin, which really
+-# lives in c:/cygwin, hence the contortions above
+-#
+-# on Unix/Linux/Solaris systems
+-# replace the first line with something like
+-# #!/usr/bin/wish -f
+-# using the pathname for the wish executable on your system
++#!/usr/bin/wish -f
+
+ #======================================================================#
+ # Tcl/Tk Spin Controller, written by Gerard J. Holzmann, 1995-2009. #
diff --git a/sci-mathematics/spin/spin-5.2.5.ebuild b/sci-mathematics/spin/spin-5.2.5.ebuild
new file mode 100644
index 000000000000..7977a990ee44
--- /dev/null
+++ b/sci-mathematics/spin/spin-5.2.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-5.2.5.ebuild,v 1.1 2010/06/11 14:31:38 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PV=$(replace_all_version_separators '')
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="Tool for formal verification of distributed software systems."
+HOMEPAGE="http://spinroot.com/"
+SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz
+ http://spinroot.com/spin/Src/xspin525.tcl"
+
+LICENSE="|| ( spin-commercial spin-educational )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="graphviz tk"
+
+DEPEND="sys-devel/bison"
+RDEPEND="sys-devel/gcc
+ sys-process/time
+ tk? (
+ dev-lang/tk
+ graphviz? ( media-gfx/graphviz )
+ )"
+
+S="${WORKDIR}/Spin/Src${PV}"
+
+src_unpack() {
+ unpack "${MY_P}.tar.gz"
+ cp "${DISTDIR}/xspin525.tcl" "${S}/xspin.tcl" || die "cp failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+ epatch "${FILESDIR}/${PN}-xspin-r1.patch"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin spin || die "dobin failed"
+ doman ../Man/spin.1 || die "doman failed"
+ dodoc ../Doc/* || die "dodoc failed"
+ if use tk; then
+ newbin xspin.tcl xspin || die "newbin failed"
+ make_desktop_entry xspin XSpin
+ fi
+}