summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-01 15:57:08 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-01 15:57:08 +0000
commit2a49d9e66ce9dc3bf235913509e38f94d6612d67 (patch)
tree60e1541769df7896d6d2d979009d071747625b43 /sci-mathematics/spin
parentalpha/ia64 stable wrt #349906 (diff)
downloadgentoo-2-2a49d9e66ce9dc3bf235913509e38f94d6612d67.tar.gz
gentoo-2-2a49d9e66ce9dc3bf235913509e38f94d6612d67.tar.bz2
gentoo-2-2a49d9e66ce9dc3bf235913509e38f94d6612d67.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/spin')
-rw-r--r--sci-mathematics/spin/ChangeLog10
-rw-r--r--sci-mathematics/spin/files/spin-6.0.1-makefile.patch21
-rw-r--r--sci-mathematics/spin/spin-6.0.1.ebuild47
3 files changed, 76 insertions, 2 deletions
diff --git a/sci-mathematics/spin/ChangeLog b/sci-mathematics/spin/ChangeLog
index f925b7dc7509..d7595bb65cf4 100644
--- a/sci-mathematics/spin/ChangeLog
+++ b/sci-mathematics/spin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/spin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.4 2010/10/12 11:16:28 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.5 2011/01/01 15:57:08 phajdan.jr Exp $
+
+*spin-6.0.1 (01 Jan 2011)
+
+ 01 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> +spin-6.0.1.ebuild,
+ +files/spin-6.0.1-makefile.patch:
+ Version bump.
12 Oct 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> -spin-5.2.4.ebuild,
-spin-5.2.5.ebuild, files/spin-makefile.patch:
diff --git a/sci-mathematics/spin/files/spin-6.0.1-makefile.patch b/sci-mathematics/spin/files/spin-6.0.1-makefile.patch
new file mode 100644
index 000000000000..d1840875fc03
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-6.0.1-makefile.patch
@@ -0,0 +1,21 @@
+--- makefile.orig 2011-01-01 16:51:18.000000000 +0100
++++ makefile 2011-01-01 16:52:00.000000000 +0100
+@@ -13,9 +13,6 @@
+
+ # see also ./make_pc for a simpler script, not requiring make
+
+-CC=gcc
+-CFLAGS=-O2 -ansi -DNXT -D_POSIX_SOURCE -Wno-format-security # on some systems add: -I/usr/include
+-
+ # CC=cc -m32 # for 32bit compilation on a 64bit system (not recommended)
+ # for a more picky compilation use gcc-4 and:
+ # CFLAGS=-std=c99 -Wstrict-prototypes -pedantic -fno-strength-reduce -fno-builtin -W -Wshadow -Wpointer-arith -Wcast-qual -Winline -Wall -g -DNXT -DPC
+@@ -43,7 +40,7 @@
+ tl_mem.o tl_rewrt.o tl_cache.o
+
+ spin: $(SPIN_OS) $(TL_OS)
+- $(CC) $(CFLAGS) -o spin $(SPIN_OS) $(TL_OS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o spin $(SPIN_OS) $(TL_OS)
+
+ spin.o: spin.y
+ $(YACC) $(YFLAGS) spin.y
diff --git a/sci-mathematics/spin/spin-6.0.1.ebuild b/sci-mathematics/spin/spin-6.0.1.ebuild
new file mode 100644
index 000000000000..6737f715c7e8
--- /dev/null
+++ b/sci-mathematics/spin/spin-6.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-6.0.1.ebuild,v 1.1 2011/01/01 15:57:08 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PV=$(replace_all_version_separators '')
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="Tool for formal verification of distributed software systems."
+HOMEPAGE="http://spinroot.com/"
+SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz"
+
+LICENSE="|| ( spin-commercial spin-educational )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="graphviz tk"
+
+DEPEND="sys-devel/bison"
+RDEPEND="sys-devel/gcc
+ sys-process/time
+ tk? (
+ dev-lang/tk
+ graphviz? ( media-gfx/graphviz )
+ )"
+
+S="${WORKDIR}/Spin/Src${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-makefile.patch"
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ dobin spin || die
+ doman ../Man/spin.1 || die
+ dodoc ../Doc/* || die
+ if use tk; then
+ newbin "${WORKDIR}/Spin/iSpin/ispin.tcl" ispin || die
+ make_desktop_entry ispin
+ fi
+}