summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-12-26 22:19:06 +0000
committerThomas Kahle <tomka@gentoo.org>2010-12-26 22:19:06 +0000
commit292f4403effe012275de1f6de49bc955850da1f3 (patch)
treefa25c2486eeafdcfb61c31a74d05c1504ca57893 /sci-mathematics/polymake
parentVersion bump, bug 348361. (diff)
downloadgentoo-2-292f4403effe012275de1f6de49bc955850da1f3.tar.gz
gentoo-2-292f4403effe012275de1f6de49bc955850da1f3.tar.bz2
gentoo-2-292f4403effe012275de1f6de49bc955850da1f3.zip
Updated ebuild without jReality (see bug 346073)
(Portage version: 2.1.9.26/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/polymake')
-rw-r--r--sci-mathematics/polymake/ChangeLog8
-rw-r--r--sci-mathematics/polymake/files/2.9.9-drop-jreality.patch33
-rw-r--r--sci-mathematics/polymake/polymake-2.9.9-r1.ebuild70
3 files changed, 110 insertions, 1 deletions
diff --git a/sci-mathematics/polymake/ChangeLog b/sci-mathematics/polymake/ChangeLog
index db71e6c4a5cd..850982c6a0b9 100644
--- a/sci-mathematics/polymake/ChangeLog
+++ b/sci-mathematics/polymake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/polymake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.3 2010/11/17 08:10:17 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.4 2010/12/26 22:19:06 tomka Exp $
+
+*polymake-2.9.9-r1 (26 Dec 2010)
+
+ 26 Dec 2010; Thomas Kahle <tomka@gentoo.org>
+ +files/2.9.9-drop-jreality.patch, +polymake-2.9.9-r1.ebuild:
+ Updated ebuild without jReality (see bug 346073)
17 Nov 2010; Thomas Kahle <tomka@gentoo.org> polymake-2.9.9.ebuild:
Missing || die on configure. Thx maekke.
diff --git a/sci-mathematics/polymake/files/2.9.9-drop-jreality.patch b/sci-mathematics/polymake/files/2.9.9-drop-jreality.patch
new file mode 100644
index 000000000000..2811b4fc93fc
--- /dev/null
+++ b/sci-mathematics/polymake/files/2.9.9-drop-jreality.patch
@@ -0,0 +1,33 @@
+--- Makefile 2010-11-19 14:34:32.000000000 +0100
++++ Makefile.new 2010-11-19 15:10:41.000000000 +0100
+@@ -89,7 +89,7 @@
+ @+$(call _MakeAppsBin,all-lib)
+
+ ifeq (${JavaBuild},n)
+- all-java% clean-java :
++ all-java all-java-native all-java-jars clean-java :
+ @echo Build architecture ${Arch} was configured --without-java or ant utility was not found.
+ @echo Please repeat the configure step if you want to recompile the java modules.
+ false
+@@ -134,11 +134,11 @@
+ @case "$$(uname -s)" in \
+ *linux*|*Linux*) \
+ for d in linux32 linux64; do \
+- ${PERL} ${INSTALL_PL} -m ${DirMask} -U external/jreality/jni/$$d ${InstallArch}/lib/jreality/jni/$$d; \
++ true ; \
+ done; \
+ ;; \
+ Darwin*|darwin*) \
+- ${PERL} ${INSTALL_PL} -m ${DirMask} -U external/jreality/jni/macosx ${InstallArch}/lib/jreality/jni/macosx; \
++ true ; \
+ ;; \
+ esac
+ [ -d ${InstallBin} ] || $(call _CreateDir,${InstallBin})
+@@ -169,7 +169,6 @@
+ @+$(call _MakeAppsBin, install-src)
+ $(if ${.svn},${PERL} perl/polymake --script filter_rules -m ${InstallTop} ${Apps})
+ [ ! -d java_build ] || $(call _InstallSubdir,java_build,-X de)
+- [ ! -d java_build ] || $(call _InstallSubdirRenamed,external/jreality/lib,java_build/jreality/lib)
+ $(call _InstallSubdir,povray)
+ $(call _InstallSubdir,scripts)
+ $(call _InstallSubdir,xml)
diff --git a/sci-mathematics/polymake/polymake-2.9.9-r1.ebuild b/sci-mathematics/polymake/polymake-2.9.9-r1.ebuild
new file mode 100644
index 000000000000..857268078a6b
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.9.9-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.9.9-r1.ebuild,v 1.1 2010/12/26 22:19:06 tomka Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://www.opt.tu-darmstadt.de/polymake/lib/exe/fetch.php/download/${P}.tar.bz2"
+
+HOMEPAGE="http://www.opt.tu-darmstadt.de/polymake"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/gmp
+ dev-libs/libxml2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Upstream provided patch. Remove in version 3.0!
+ epatch "${FILESDIR}/${PV}-gentoo-binutils.patch"
+ epatch "${FILESDIR}/${PV}-drop-jreality.patch"
+ rm -rf java_build/jreality
+
+ # Don't strip
+ sed -i '/system "strip $to"/d' support/install.pl || die
+
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+}
+
+src_configure () {
+
+ export CXXOPT=$(get-flag -O)
+ # Configure does not accept --host, therefore econf cannot be used
+ # Note 'libdir' does not mean where to put .so files!
+ # --libdir=/usr/$(get_libdir) \
+ ./configure --prefix=/usr \
+ --without-java \
+ --without-prereq \
+ ${myconf} || die
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst(){
+ elog "Polymake uses Perl Modules compiled during install."
+ elog "You have to reinstall polymake after an upgrade of Perl."
+ elog " "
+ elog "This version of polymake does not ship docs. Sorry."
+ elog "Help can be found on http://www.opt.tu-darmstadt.de/polymake_doku/ "
+ elog " "
+ elog "Visualization in polymake is via jreality which ships pre-compiled"
+ elog "binary libraries. Until this situation is resolved, support for"
+ elog "jreality has been dropped. Please contribute to Bug #346073 to "
+ elog "make jreality available in Gentoo."
+}