summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-30 08:52:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-30 08:52:07 +0000
commitf8371e9dbe55949e3bc08106198cf9ff948e9b4d (patch)
tree1dfe81852a91ccb7fd2ee5cad4d1b66e77006c05 /sci-mathematics/msieve
parentReadd the ~-linux keywords (diff)
downloadgentoo-2-f8371e9dbe55949e3bc08106198cf9ff948e9b4d.tar.gz
gentoo-2-f8371e9dbe55949e3bc08106198cf9ff948e9b4d.tar.bz2
gentoo-2-f8371e9dbe55949e3bc08106198cf9ff948e9b4d.zip
Fix displayed versioning
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/msieve')
-rw-r--r--sci-mathematics/msieve/ChangeLog9
-rw-r--r--sci-mathematics/msieve/files/fix-version.patch15
-rw-r--r--sci-mathematics/msieve/files/fix-version2.patch14
-rw-r--r--sci-mathematics/msieve/msieve-1.50-r1.ebuild48
-rw-r--r--sci-mathematics/msieve/msieve-1.50-r2.ebuild54
-rw-r--r--sci-mathematics/msieve/msieve-1.50-r4.ebuild (renamed from sci-mathematics/msieve/msieve-1.50-r3.ebuild)4
-rw-r--r--sci-mathematics/msieve/msieve-1.50.ebuild48
7 files changed, 40 insertions, 152 deletions
diff --git a/sci-mathematics/msieve/ChangeLog b/sci-mathematics/msieve/ChangeLog
index e08fe81e6559..488971f05727 100644
--- a/sci-mathematics/msieve/ChangeLog
+++ b/sci-mathematics/msieve/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/msieve
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/ChangeLog,v 1.7 2012/11/28 08:15:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/ChangeLog,v 1.8 2012/11/30 08:52:07 patrick Exp $
+
+*msieve-1.50-r4 (30 Nov 2012)
+
+ 30 Nov 2012; Patrick Lauer <patrick@gentoo.org> +files/fix-version.patch,
+ +files/fix-version2.patch, +msieve-1.50-r4.ebuild, -msieve-1.50-r1.ebuild,
+ -msieve-1.50-r2.ebuild, -msieve-1.50-r3.ebuild, -msieve-1.50.ebuild:
+ Fix displayed versioning
28 Nov 2012; Patrick Lauer <patrick@gentoo.org> msieve-1.50-r3.ebuild:
Removing erroneous dep
diff --git a/sci-mathematics/msieve/files/fix-version.patch b/sci-mathematics/msieve/files/fix-version.patch
new file mode 100644
index 000000000000..748a7ae8c68c
--- /dev/null
+++ b/sci-mathematics/msieve/files/fix-version.patch
@@ -0,0 +1,15 @@
+--- common/driver.c 2011-05-02 09:10:50.000000000 +0800
++++ common/driver.c.new 2012-11-30 16:43:59.067925006 +0800
+@@ -191,10 +191,9 @@
+
+ logprintf(obj, "\n");
+ logprintf(obj, "\n");
+- logprintf(obj, "Msieve v. %d.%02d (SVN %s)\n",
++ logprintf(obj, "Msieve v. %d.%02d\n",
+ MSIEVE_MAJOR_VERSION,
+- MSIEVE_MINOR_VERSION,
+- MSIEVE_SVN_VERSION);
++ MSIEVE_MINOR_VERSION);
+ start_time = time(NULL);
+ if (obj->flags & MSIEVE_FLAG_LOG_TO_STDOUT) {
+ printf("%s", ctime(&start_time));
diff --git a/sci-mathematics/msieve/files/fix-version2.patch b/sci-mathematics/msieve/files/fix-version2.patch
new file mode 100644
index 000000000000..6e956897bdf0
--- /dev/null
+++ b/sci-mathematics/msieve/files/fix-version2.patch
@@ -0,0 +1,14 @@
+--- demo.c 2011-11-25 00:25:28.000000000 +0800
++++ demo.c.new 2012-11-30 16:46:50.417333847 +0800
+@@ -81,9 +81,8 @@
+ /*--------------------------------------------------------------------*/
+ void print_usage(char *progname) {
+
+- printf("\nMsieve v. %d.%02d (SVN %s)\n", MSIEVE_MAJOR_VERSION,
+- MSIEVE_MINOR_VERSION,
+- MSIEVE_SVN_VERSION);
++ printf("\nMsieve v. %d.%02d\n", MSIEVE_MAJOR_VERSION,
++ MSIEVE_MINOR_VERSION);
+
+ printf("\nusage: %s [options] [one_number]\n", progname);
+ printf("\nnumbers starting with '0' are treated as octal,\n"
diff --git a/sci-mathematics/msieve/msieve-1.50-r1.ebuild b/sci-mathematics/msieve/msieve-1.50-r1.ebuild
deleted file mode 100644
index 9e2eb2b634ce..000000000000
--- a/sci-mathematics/msieve/msieve-1.50-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50-r1.ebuild,v 1.1 2012/11/19 06:19:46 patrick Exp $
-
-EAPI=4
-DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
-HOMEPAGE="http://sourceforge.net/projects/msieve/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}src.tar.gz"
-
-inherit eutils
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="zlib +ecm mpi"
-
-DEPEND="ecm? ( sci-mathematics/gmp-ecm )
- mpi? ( virtual/mpi )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- if use ecm; then
- export "ECM=1"
- fi
- if use mpi; then
- export "MPI=1"
- fi
- if use zlib; then
- export "ZLIB=1"
- fi
- if use amd64; then
- emake x86_64 || die "Failed to build"
- fi
- if use x86; then
- emake x86 || die "Failed to build"
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/include/msieve"
- mkdir -p "${D}/usr/lib/"
- mkdir -p "${D}/usr/share/doc/${P}/"
- cp include/* "${D}/usr/include/msieve" || die "Failed to install"
- cp libmsieve.a "${D}/usr/lib/" || die "Failed to install"
- dobin msieve || die "Failed to install"
- cp Readme* "${D}/usr/share/doc/${P}/" || die "Failed to install"
-}
diff --git a/sci-mathematics/msieve/msieve-1.50-r2.ebuild b/sci-mathematics/msieve/msieve-1.50-r2.ebuild
deleted file mode 100644
index 28431f377ce8..000000000000
--- a/sci-mathematics/msieve/msieve-1.50-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50-r2.ebuild,v 1.2 2012/11/27 17:42:19 mr_bones_ Exp $
-
-EAPI=4
-DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
-HOMEPAGE="http://sourceforge.net/projects/msieve/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}src.tar.gz"
-
-inherit eutils
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="zlib +ecm mpi"
-
-DEPEND="ecm? ( sci-mathematics/gmp-ecm )
- mpi? ( virtual/mpi )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i -e 's/-march=k8//' Makefile || die
- sed -i -e 's/CC =/#CC =/' Makefile || die
- sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
-}
-
-src_compile() {
- if use ecm; then
- export "ECM=1"
- fi
- if use mpi; then
- export "MPI=1"
- fi
- if use zlib; then
- export "ZLIB=1"
- fi
- if use amd64; then
- emake x86_64 || die "Failed to build"
- fi
- if use x86; then
- emake x86 || die "Failed to build"
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/include/msieve"
- mkdir -p "${D}/usr/lib/"
- mkdir -p "${D}/usr/share/doc/${P}/"
- cp include/* "${D}/usr/include/msieve" || die "Failed to install"
- cp libmsieve.a "${D}/usr/lib/" || die "Failed to install"
- dobin msieve || die "Failed to install"
- cp Readme* "${D}/usr/share/doc/${P}/" || die "Failed to install"
-}
diff --git a/sci-mathematics/msieve/msieve-1.50-r3.ebuild b/sci-mathematics/msieve/msieve-1.50-r4.ebuild
index c3ee991718db..d472871ba1fd 100644
--- a/sci-mathematics/msieve/msieve-1.50-r3.ebuild
+++ b/sci-mathematics/msieve/msieve-1.50-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50-r3.ebuild,v 1.3 2012/11/28 08:15:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50-r4.ebuild,v 1.1 2012/11/30 08:52:07 patrick Exp $
EAPI=4
DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
@@ -22,6 +22,8 @@ RDEPEND="${DEPEND}"
src_prepare() {
# TODO: Integrate ggnfs properly
epatch "${FILESDIR}/reduce-printf.patch" || die
+ epatch "${FILESDIR}/fix-version.patch" || die
+ epatch "${FILESDIR}/fix-version2.patch" || die
sed -i -e 's/-march=k8//' Makefile || die
sed -i -e 's/CC =/#CC =/' Makefile || die
sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
diff --git a/sci-mathematics/msieve/msieve-1.50.ebuild b/sci-mathematics/msieve/msieve-1.50.ebuild
deleted file mode 100644
index 2053d0ce8fd2..000000000000
--- a/sci-mathematics/msieve/msieve-1.50.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/msieve/msieve-1.50.ebuild,v 1.3 2012/11/16 04:14:45 patrick Exp $
-
-EAPI=4
-DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
-HOMEPAGE="http://sourceforge.net/projects/msieve/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}src.tar.gz"
-
-inherit eutils
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="zlib +ecm mpi"
-
-DEPEND="ecm? ( sci-mathematics/gmp-ecm )
- mpi? ( virtual/mpi )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- if use ecm; then
- export "ECM=1"
- fi
- if use mpi; then
- export "MPI=1"
- fi
- if use zlib; then
- export "ZLIB=1"
- fi
- if use amd64; then
- emake x86_64 || die "Failed to build"
- fi
- if use x86; then
- emake x86 || die "Failed to build"
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/include/"
- mkdir -p "${D}/usr/lib/"
- mkdir -p "${D}/usr/share/doc/${P}/"
- cp include/* "${D}/usr/include/" || die "Failed to install"
- cp libmsieve.a "${D}/usr/lib/" || die "Failed to install"
- dobin msieve || die "Failed to install"
- cp Readme* "${D}/usr/share/doc/${P}/" || die "Failed to install"
-}