summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-20 21:58:13 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-20 21:58:13 +0000
commit17ee45c69d8af48c863bf7b89787f2539ac1484a (patch)
treecf9997079898d333ec62629123db5bd26b6640a6 /sci-mathematics/gretl
parentVersion bump (diff)
downloadgentoo-2-17ee45c69d8af48c863bf7b89787f2539ac1484a.tar.gz
gentoo-2-17ee45c69d8af48c863bf7b89787f2539ac1484a.tar.bz2
gentoo-2-17ee45c69d8af48c863bf7b89787f2539ac1484a.zip
Version bump
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics/gretl')
-rw-r--r--sci-mathematics/gretl/ChangeLog7
-rw-r--r--sci-mathematics/gretl/gretl-1.9.12.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index 56fa1236e16c..be90697eebf1 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.41 2013/01/15 18:22:35 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.42 2013/03/20 21:58:13 bicatali Exp $
+
+*gretl-1.9.12 (20 Mar 2013)
+
+ 20 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> +gretl-1.9.12.ebuild:
+ Version bump
15 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> -gretl-1.9.9.ebuild,
gretl-1.9.11.ebuild:
diff --git a/sci-mathematics/gretl/gretl-1.9.12.ebuild b/sci-mathematics/gretl/gretl-1.9.12.ebuild
new file mode 100644
index 000000000000..2473d2624e63
--- /dev/null
+++ b/sci-mathematics/gretl/gretl-1.9.12.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.12.ebuild,v 1.1 2013/03/20 21:58:13 bicatali Exp $
+
+EAPI=5
+
+USE_EINSTALL=true
+
+inherit eutils elisp-common toolchain-funcs
+
+DESCRIPTION="Regression, econometrics and time-series library"
+HOMEPAGE="http://gretl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="accessibility emacs gnome gtk nls odbc openmp readline sse2 R static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/libxml2:2
+ dev-libs/mpfr
+ sci-libs/fftw:3.0
+ sci-visualization/gnuplot
+ virtual/lapack
+ virtual/latex-base
+ accessibility? ( app-accessibility/flite )
+ emacs? ( virtual/emacs )
+ gtk? (
+ media-libs/gd[png]
+ sci-visualization/gnuplot[gd]
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0 )
+ odbc? ( dev-db/unixODBC )
+ R? ( dev-lang/R )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+SITEFILE=50${PN}-gentoo.el
+
+REQUIRED_USE="emacs? ( gtk )"
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp
+ then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --enable-shared \
+ --with-mpfr \
+ $(use_enable gtk gui) \
+ $(use_enable gtk gtk3) \
+ $(use_enable gtk xdg) \
+ $(use_enable gtk xdg-utils) \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable sse2) \
+ $(use_enable static-libs static) \
+ $(use_with accessibility audio) \
+ $(use_with odbc) \
+ $(use_with readline) \
+ $(use_with R libR) \
+ ${myconf} \
+ LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ cd utils/emacs && emake
+ elisp-compile gretl.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ # to fix
+ emake -j1 DESTDIR="${D}" install
+ if use emacs; then
+ elisp-install ${PN} utils/emacs/gretl.{el,elc} \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+ dodoc README README.audio ChangeLog CompatLog
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "To begin using gretl-mode for all \".inp\" files that you edit,"
+ elog "add the following line to your \"~/.emacs\" file:"
+ elog " (add-to-list 'auto-mode-alist '(\"\\\\.inp\\\\'\" . gretl-mode))"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}