summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-12-06 16:42:52 +0000
committerThomas Kahle <tomka@gentoo.org>2011-12-06 16:42:52 +0000
commitfdd882ccff18ce799c6707fdd8a74c3ede5e78c5 (patch)
tree89b3e5584e23d183b20a178572739acb96021773 /sci-mathematics/gimps
parentrebuild protector-3.2.2-10.tar.gz digest since i had a bum local copy (diff)
downloadgentoo-2-fdd882ccff18ce799c6707fdd8a74c3ede5e78c5.tar.gz
gentoo-2-fdd882ccff18ce799c6707fdd8a74c3ede5e78c5.tar.bz2
gentoo-2-fdd882ccff18ce799c6707fdd8a74c3ede5e78c5.zip
Don't use deprecated options of start-stop-daemon (Bug 393353). Thanks Paolo
Pedroni. (Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/gimps')
-rw-r--r--sci-mathematics/gimps/ChangeLog9
-rw-r--r--sci-mathematics/gimps/files/gimps-26.6-r1-init.d37
-rw-r--r--sci-mathematics/gimps/gimps-26.6-r1.ebuild57
-rw-r--r--sci-mathematics/gimps/gimps-26.6.ebuild6
4 files changed, 105 insertions, 4 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index 3daaff84a723..b78964564a93 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.44 2011/07/15 20:09:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.45 2011/12/06 16:42:52 tomka Exp $
+
+*gimps-26.6-r1 (06 Dec 2011)
+
+ 06 Dec 2011; Thomas Kahle <tomka@gentoo.org> gimps-26.6.ebuild,
+ +gimps-26.6-r1.ebuild, +files/gimps-26.6-r1-init.d:
+ Don't use deprecated options of start-stop-daemon (Bug 393353). Thanks
+ Paolo Pedroni.
15 Jul 2011; Markus Meier <maekke@gentoo.org> gimps-26.6.ebuild:
x86 stable, bug #372669
diff --git a/sci-mathematics/gimps/files/gimps-26.6-r1-init.d b/sci-mathematics/gimps/files/gimps-26.6-r1-init.d
new file mode 100644
index 000000000000..dfee0e8c0c3e
--- /dev/null
+++ b/sci-mathematics/gimps/files/gimps-26.6-r1-init.d
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e "${GIMPS_DIR}" ]; then
+ einfo "Creating ${GIMPS_DIR}"
+ /bin/mkdir "${GIMPS_DIR}"
+ fi
+
+ /bin/chown -R ${USER}:${GROUP} ${GIMPS_DIR}
+
+ if [ ! -e "${GIMPS_DIR}/local.txt" ]; then
+ eerror "GIMPS has not been configured. Please configure it manually before"
+ eerror "starting this initscript."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting GIMPS"
+ start-stop-daemon --quiet --start -b --exec /opt/gimps/mprime \
+ --chdir ${GIMPS_DIR} --user ${USER}:${GROUP} \
+ -- -w${GIMPS_DIR} ${GIMPS_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping GIMPS"
+ start-stop-daemon --quiet --stop --exec /opt/gimps/mprime
+ eend $?
+}
diff --git a/sci-mathematics/gimps/gimps-26.6-r1.ebuild b/sci-mathematics/gimps/gimps-26.6-r1.ebuild
new file mode 100644
index 000000000000..4e90933a694e
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-26.6-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-26.6-r1.ebuild,v 1.1 2011/12/06 16:42:52 tomka Exp $
+
+IUSE=""
+DESCRIPTION="GIMPS - The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="amd64? ( ftp://mersenne.org/gimps/mprime${PV/./}-linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/mprime${PV/./}.tar.gz )"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="binchecks"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+QA_EXECSTACK="opt/gimps/mprime"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ cp mprime "${D}/${I}"
+ chmod a-w "${D}/${I}/mprime"
+ chown root:0 "${D}/${I}"
+ chown root:0 "${D}/${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/${PF}-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}
diff --git a/sci-mathematics/gimps/gimps-26.6.ebuild b/sci-mathematics/gimps/gimps-26.6.ebuild
index 2fea8b9d0ea8..42423ed4213c 100644
--- a/sci-mathematics/gimps/gimps-26.6.ebuild
+++ b/sci-mathematics/gimps/gimps-26.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-26.6.ebuild,v 1.4 2011/07/15 20:09:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-26.6.ebuild,v 1.5 2011/12/06 16:42:52 tomka Exp $
IUSE=""
DESCRIPTION="GIMPS - The Great Internet Mersenne Prime Search"
@@ -32,8 +32,8 @@ src_install() {
dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
- newinitd "${FILESDIR}/gimps-25.6-init.d" gimps
- newconfd "${FILESDIR}/gimps-25.6-conf.d" gimps
+ newinitd "${FILESDIR}/gimps-26.6-r1-init.d" gimps
+ newconfd "${FILESDIR}/gimps-26.6-r1-conf.d" gimps
}
pkg_postinst() {