summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-02-16 10:01:56 +0000
committerThomas Kahle <tomka@gentoo.org>2013-02-16 10:01:56 +0000
commit5a47d62dd106e5fd971de5ce3d2f8ab7ca190631 (patch)
treed8533f70cbd22cb5fbb4bb610a538734d53683eb /sci-mathematics/frobby
parentSplit out src_prepare from src_unpack. (diff)
downloadgentoo-2-5a47d62dd106e5fd971de5ce3d2f8ab7ca190631.tar.gz
gentoo-2-5a47d62dd106e5fd971de5ce3d2f8ab7ca190631.tar.bz2
gentoo-2-5a47d62dd106e5fd971de5ce3d2f8ab7ca190631.zip
drop old, update Makefile patch (bugs 457722, 457720)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'sci-mathematics/frobby')
-rw-r--r--sci-mathematics/frobby/ChangeLog6
-rw-r--r--sci-mathematics/frobby/files/frobby-cflags-no-strip-soname.patch24
-rw-r--r--sci-mathematics/frobby/frobby-0.9.0.ebuild54
3 files changed, 26 insertions, 58 deletions
diff --git a/sci-mathematics/frobby/ChangeLog b/sci-mathematics/frobby/ChangeLog
index aad28cbd2391..6019f35edb45 100644
--- a/sci-mathematics/frobby/ChangeLog
+++ b/sci-mathematics/frobby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/frobby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.16 2013/02/15 19:08:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.17 2013/02/16 10:01:56 tomka Exp $
+
+ 16 Feb 2013; Thomas Kahle <tomka@gentoo.org> -frobby-0.9.0.ebuild,
+ files/frobby-cflags-no-strip-soname.patch:
+ drop old, update Makefile patch (bugs 457722, 457720)
15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> frobby-0.9.0-r1.ebuild:
Stable for x86, wrt bug #457690
diff --git a/sci-mathematics/frobby/files/frobby-cflags-no-strip-soname.patch b/sci-mathematics/frobby/files/frobby-cflags-no-strip-soname.patch
index 48e504f95815..2f5721d62a71 100644
--- a/sci-mathematics/frobby/files/frobby-cflags-no-strip-soname.patch
+++ b/sci-mathematics/frobby/files/frobby-cflags-no-strip-soname.patch
@@ -1,6 +1,15 @@
-diff -U 3 -dHrN frobby_v0.9.0-orig/Makefile frobby_v0.9.0/Makefile
---- frobby_v0.9.0-orig/Makefile 2012-07-30 14:19:58.161584356 +0200
-+++ frobby_v0.9.0/Makefile 2012-07-30 14:21:36.796558990 +0200
+diff -U 3 -dHrN frobby_v0.9.0.orig/Makefile frobby_v0.9.0/Makefile
+--- frobby_v0.9.0.orig/Makefile 2013-01-15 22:40:13.127937655 +0100
++++ frobby_v0.9.0/Makefile 2013-02-16 10:54:42.265322522 +0100
+@@ -70,7 +70,7 @@
+ BIN_INSTALL_DIR = "/usr/local/bin/"
+ endif
+
+-cflags = $(CFLAGS) $(CPPFLAGS) -Wall -ansi -pedantic -I $(GMP_INC_DIR) \
++cflags = $(CPPFLAGS) -Wall -ansi -pedantic -I $(GMP_INC_DIR) \
+ -Wno-uninitialized -Wno-unused-parameter
+ program = frobby
+ library = libfrobby.a
@@ -87,7 +87,6 @@
MATCH=false
ifeq ($(MODE), release)
@@ -9,6 +18,15 @@ diff -U 3 -dHrN frobby_v0.9.0-orig/Makefile frobby_v0.9.0/Makefile
MATCH=true
endif
ifeq ($(MODE), debug)
+@@ -99,7 +98,7 @@
+ endif
+ ifeq ($(MODE), shared)
+ outdir = bin/shared/
+- cflags += -O2 -fPIC
++ cflags += -fPIC
+ library = libfrobby.so
+ MATCH=true
+ endif
@@ -204,16 +203,13 @@
mv -f $@.exe $@; \
fi
diff --git a/sci-mathematics/frobby/frobby-0.9.0.ebuild b/sci-mathematics/frobby/frobby-0.9.0.ebuild
deleted file mode 100644
index 4aa0682a4fec..000000000000
--- a/sci-mathematics/frobby/frobby-0.9.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.6 2012/07/30 12:28:16 tomka Exp $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Software system and project for computations with monomial ideals"
-HOMEPAGE="http://www.broune.com/frobby/"
-SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc static-libs"
-
-RDEPEND="dev-libs/gmp[cxx]"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
-
-S="${WORKDIR}/frobby_v${PV}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-cflags-no-strip-soname.patch" \
- "${FILESDIR}/${PN}-gcc-4.7.patch"
- # CXXFLAGS are called CPPFLAGS
- sed "s/CPPFLAGS/CXXFLAGS/" -i Makefile || die
-}
-
-src_compile() {
- # Makefile uses the value of CXX which may be defined in /etc/env,
- # breaking cross-compile.
- CXX=$(tc-getCXX) emake
- MODE=shared CXX=$(tc-getCXX) emake library
- use static-libs && CXX=$(tc-getCXX) emake library
- use doc && emake docPdf
-}
-
-src_install() {
- dobin bin/frobby
- dolib.so bin/libfrobby.so
- dosym libfrobby.so "${EPREFIX}/usr/$(get_libdir)/libfrobby.so.0"
- use static-libs && dolib.a bin/libfrobby.a
-
- insinto /usr/include
- doins src/frobby.h
-
- insinto /usr/include/"${PN}"
- doins src/stdinc.h
-
- use doc && dodoc bin/manual.pdf
-}