summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-06-22 07:35:14 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-06-22 07:35:14 +0000
commite5958a0d544aa6638dfbb7504535dcee6703eeea (patch)
treef41dc8a5dec10232d9df2e847ff400976eb81f05 /sci-mathematics/fricas
parentVersion bump (thanks euscan). (diff)
downloadgentoo-2-e5958a0d544aa6638dfbb7504535dcee6703eeea.tar.gz
gentoo-2-e5958a0d544aa6638dfbb7504535dcee6703eeea.tar.bz2
gentoo-2-e5958a0d544aa6638dfbb7504535dcee6703eeea.zip
fix a bug in src/graph/view3D/smoothShade3d.c
(Portage version: 2.2.0_alpha110/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/ChangeLog8
-rw-r--r--sci-mathematics/fricas/files/fricas-1.1.7.patch8
-rw-r--r--sci-mathematics/fricas/fricas-1.1.7-r1.ebuild (renamed from sci-mathematics/fricas/fricas-1.1.7.ebuild)9
3 files changed, 22 insertions, 3 deletions
diff --git a/sci-mathematics/fricas/ChangeLog b/sci-mathematics/fricas/ChangeLog
index 8e7fb1c82381..5d38dca7d92d 100644
--- a/sci-mathematics/fricas/ChangeLog
+++ b/sci-mathematics/fricas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/fricas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.14 2012/06/21 08:24:23 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.15 2012/06/22 07:35:14 grozin Exp $
+
+*fricas-1.1.7-r1 (22 Jun 2012)
+
+ 22 Jun 2012; Andrey Grozin <grozin@gentoo.org> -fricas-1.1.7.ebuild,
+ +fricas-1.1.7-r1.ebuild, +files/fricas-1.1.7.patch:
+ fix a bug in src/graph/view3D/smoothShade3d.c
*fricas-1.1.7 (21 Jun 2012)
diff --git a/sci-mathematics/fricas/files/fricas-1.1.7.patch b/sci-mathematics/fricas/files/fricas-1.1.7.patch
new file mode 100644
index 000000000000..c2af6d923e01
--- /dev/null
+++ b/sci-mathematics/fricas/files/fricas-1.1.7.patch
@@ -0,0 +1,8 @@
+diff -r -U1 fricas-1.1.7.orig/src/graph/view3D/smoothShade3d.c fricas-1.1.7/src/graph/view3D/smoothShade3d.c
+--- fricas-1.1.7.orig/src/graph/view3D/smoothShade3d.c 2012-06-19 08:17:01.000000000 +0700
++++ fricas-1.1.7/src/graph/view3D/smoothShade3d.c 2012-06-22 13:38:49.000000000 +0700
+@@ -753,3 +753,3 @@
+ /* axes label for X */
+- if ((int)axesZ[0][0] >= (int)axesZ[0][2]) {
++ if ((int)axesZ[0][0] >= (int)axesZ[0][1]) {
+ if (axesXY[0][2] < axesXY[0][0]) xcoord2 = axesXY[0][2]-5;
diff --git a/sci-mathematics/fricas/fricas-1.1.7.ebuild b/sci-mathematics/fricas/fricas-1.1.7-r1.ebuild
index b39b11b270ee..67372c4fceda 100644
--- a/sci-mathematics/fricas/fricas-1.1.7.ebuild
+++ b/sci-mathematics/fricas/fricas-1.1.7-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.1.7.ebuild,v 1.1 2012/06/21 08:24:23 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.1.7-r1.ebuild,v 1.1 2012/06/22 07:35:14 grozin Exp $
EAPI=4
-inherit multilib elisp-common
+inherit eutils multilib elisp-common
DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
HOMEPAGE="http://${PN}.sourceforge.net/"
@@ -46,6 +46,11 @@ DEPEND="${RDEPEND}"
# necessary for clisp and gcl
RESTRICT="strip"
+src_prepare() {
+ # fix a bug in src/graph/view3D/smoothShade3d.c
+ epatch "${FILESDIR}"/${P}.patch
+}
+
src_configure() {
local LISP n
LISP=sbcl