summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-03-24 13:59:39 +0000
committerMark Wright <gienah@gentoo.org>2012-03-24 13:59:39 +0000
commitfb5ca944669d0e417b1c2bbc8c4acfed01efdd95 (patch)
treea0e1c8fc0ca0d7c61d5238f479508e03e1134681 /sci-mathematics/coq
parentInitial version. Lift computations from the bottom of a transformer stack. A ... (diff)
downloadgentoo-2-fb5ca944669d0e417b1c2bbc8c4acfed01efdd95.tar.gz
gentoo-2-fb5ca944669d0e417b1c2bbc8c4acfed01efdd95.tar.bz2
gentoo-2-fb5ca944669d0e417b1c2bbc8c4acfed01efdd95.zip
Fix coq 8.3_p2 and 8.3_p3 builds with dev-ml/camlp5-6.05. Stdpp.Exc_located is an alias for Ploc.Exc, it has been deprecated for a while, and was removed in dev-ml/camlp5-6.05. Fixed by upstream in svn repo: https://coq.inria.fr/bugs/show_bug.cgi?id=2728
(Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog9
-rw-r--r--sci-mathematics/coq/coq-8.3_p2.ebuild28
-rw-r--r--sci-mathematics/coq/coq-8.3_p3.ebuild26
3 files changed, 59 insertions, 4 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 035656887ea9..2196c6f840ee 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.68 2012/02/23 21:15:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.69 2012/03/24 13:59:39 gienah Exp $
+
+ 24 Mar 2012; Mark Wright <gienah@gentoo.org> coq-8.3_p2.ebuild,
+ coq-8.3_p3.ebuild:
+ Fix coq 8.3_p2 and 8.3_p3 builds with dev-ml/camlp5-6.05. Stdpp.Exc_located
+ is an alias for Ploc.Exc, it has been deprecated for a while, and was removed
+ in dev-ml/camlp5-6.05. Fixed by upstream in svn repo:
+ https://coq.inria.fr/bugs/show_bug.cgi?id=2728
*coq-8.3_p3 (23 Feb 2012)
diff --git a/sci-mathematics/coq/coq-8.3_p2.ebuild b/sci-mathematics/coq/coq-8.3_p2.ebuild
index 24cd4b890f10..37dc9f4b8047 100644
--- a/sci-mathematics/coq/coq-8.3_p2.ebuild
+++ b/sci-mathematics/coq/coq-8.3_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p2.ebuild,v 1.2 2011/10/05 18:54:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p2.ebuild,v 1.3 2012/03/24 13:59:39 gienah Exp $
EAPI="2"
@@ -40,6 +40,30 @@ src_prepare() {
# wild sed which replaces \"$LABLGTKLIB\" by $LABLGTKLIB. Note
# during pl2-bump: Hmm, my patch did not get applied upstream?
sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+ # Stdpp.Exc_located is an alias for Ploc.Exc, it has been
+ # deprecated for a while, and was removed in dev-ml/camlp5-6.05
+ # Fixed by upstream in svn repo:
+ # https://coq.inria.fr/bugs/show_bug.cgi?id=2728
+ sed -e 's@Stdpp.Exc_located@Ploc.Exc@g' \
+ -i "${S}/checker/checker.ml" \
+ -i "${S}/ide/coq.ml" \
+ -i "${S}/lib/util.ml" \
+ -i "${S}/lib/util.mli" \
+ -i "${S}/parsing/ppvernac.ml" \
+ -i "${S}/plugins/subtac/subtac_obligations.ml" \
+ -i "${S}/pretyping/cases.ml" \
+ -i "${S}/pretyping/pretype_errors.ml" \
+ -i "${S}/pretyping/typeclasses_errors.ml" \
+ -i "${S}/proofs/logic.ml" \
+ -i "${S}/proofs/refiner.ml" \
+ -i "${S}/tactics/class_tactics.ml4" \
+ -i "${S}/tactics/extratactics.ml4" \
+ -i "${S}/tactics/rewrite.ml4" \
+ -i "${S}/tactics/tacinterp.ml" \
+ -i "${S}/toplevel/cerrors.ml" \
+ -i "${S}/toplevel/toplevel.ml" \
+ -i "${S}/toplevel/vernac.ml" \
+ || die "Could not rename deprecated Stdpp.Exc_located to Ploc.Exc"
}
src_configure() {
diff --git a/sci-mathematics/coq/coq-8.3_p3.ebuild b/sci-mathematics/coq/coq-8.3_p3.ebuild
index 8836580a4c88..0f6bea9a97c2 100644
--- a/sci-mathematics/coq/coq-8.3_p3.ebuild
+++ b/sci-mathematics/coq/coq-8.3_p3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p3.ebuild,v 1.1 2012/02/23 21:15:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p3.ebuild,v 1.2 2012/03/24 13:59:39 gienah Exp $
EAPI="2"
@@ -40,6 +40,30 @@ src_prepare() {
# wild sed which replaces \"$LABLGTKLIB\" by $LABLGTKLIB. Note
# during pl2-bump: Hmm, my patch did not get applied upstream?
sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+ # Stdpp.Exc_located is an alias for Ploc.Exc, it has been
+ # deprecated for a while, and was removed in dev-ml/camlp5-6.05
+ # Fixed by upstream in svn repo:
+ # https://coq.inria.fr/bugs/show_bug.cgi?id=2728
+ sed -e 's@Stdpp.Exc_located@Ploc.Exc@g' \
+ -i "${S}/checker/checker.ml" \
+ -i "${S}/ide/coq.ml" \
+ -i "${S}/lib/util.ml" \
+ -i "${S}/lib/util.mli" \
+ -i "${S}/parsing/ppvernac.ml" \
+ -i "${S}/plugins/subtac/subtac_obligations.ml" \
+ -i "${S}/pretyping/cases.ml" \
+ -i "${S}/pretyping/pretype_errors.ml" \
+ -i "${S}/pretyping/typeclasses_errors.ml" \
+ -i "${S}/proofs/logic.ml" \
+ -i "${S}/proofs/refiner.ml" \
+ -i "${S}/tactics/class_tactics.ml4" \
+ -i "${S}/tactics/extratactics.ml4" \
+ -i "${S}/tactics/rewrite.ml4" \
+ -i "${S}/tactics/tacinterp.ml" \
+ -i "${S}/toplevel/cerrors.ml" \
+ -i "${S}/toplevel/toplevel.ml" \
+ -i "${S}/toplevel/vernac.ml" \
+ || die "Could not rename deprecated Stdpp.Exc_located to Ploc.Exc"
}
src_configure() {