summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-27 04:31:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-27 04:31:52 +0000
commit3c5aa52edd1393b3834162fc6c74c0b9392d990e (patch)
tree84c104c736faa9ac122a36b6418f7b63e117d772 /sci-mathematics/coq
parentBump (diff)
downloadgentoo-2-3c5aa52edd1393b3834162fc6c74c0b9392d990e.tar.gz
gentoo-2-3c5aa52edd1393b3834162fc6c74c0b9392d990e.tar.bz2
gentoo-2-3c5aa52edd1393b3834162fc6c74c0b9392d990e.zip
Bump
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog8
-rw-r--r--sci-mathematics/coq/coq-8.2_p2.ebuild75
-rw-r--r--sci-mathematics/coq/metadata.xml19
3 files changed, 98 insertions, 4 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 990a1eee75dc..e1fe41f51aa5 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.52 2010/04/09 10:34:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.53 2010/09/27 04:31:52 bicatali Exp $
+
+*coq-8.2_p2 (27 Sep 2010)
+
+ 27 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> +coq-8.2_p2.ebuild,
+ metadata.xml:
+ Bump
09 Apr 2010; Alexis Ballier <aballier@gentoo.org> coq-8.2_p1-r1.ebuild:
Add missing netpbm dep for USE=doc, by Christian D. <ThyrusG@gmx.de>, bug
diff --git a/sci-mathematics/coq/coq-8.2_p2.ebuild b/sci-mathematics/coq/coq-8.2_p2.ebuild
new file mode 100644
index 000000000000..087137cc57fe
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.2_p2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.2_p2.ebuild,v 1.1 2010/09/27 04:31:52 bicatali Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://coq.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+realanalysis gtk debug +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ || ( dev-texlive/texlive-pictures app-text/ptex )
+ || ( dev-texlive/texlive-mathextra app-text/ptex )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --camlp5dir ${ocaml_lib}/camlp5
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use realanalysis || myconf="$myconf --reals no"
+ use realanalysis && myconf="$myconf --reals all"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && domenu "${FILESDIR}/coqide.desktop"
+}
diff --git a/sci-mathematics/coq/metadata.xml b/sci-mathematics/coq/metadata.xml
index 059bdea3f8ec..948b4b1f508b 100644
--- a/sci-mathematics/coq/metadata.xml
+++ b/sci-mathematics/coq/metadata.xml
@@ -1,10 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
<herd>ml</herd>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ Developed in the LogiCal project, the Coq tool is a formal proof
+ management system: a proof done with Coq is mechanically checked
+ by the machine.
+ In particular, Coq allows:
+ * the definition of functions or predicates,
+ * to state mathematical theorems and software specifications,
+ * to develop interactively formal proofs of these theorems,
+ * to check these proofs by a small certification "kernel".
+ Coq is based on a logical framework called "Calculus of Inductive
+ Constructions" extended by a modular development system for
+ theories.
+</longdescription>
<use>
- <flag name='norealanalysis'>Do not build real analysis modules
- (faster compilation)</flag>
+ <flag name='norealanalysis'>Do not build real analysis modules (faster compilation)</flag>
+ <flag name='realanalysis'>Build real analysis modules (slower compilation)</flag>
</use>
</pkgmetadata>