summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-01-04 14:55:12 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-01-04 14:55:12 +0000
commit9b86ab15d3f59e61f75055236b6e4e1f3285e570 (patch)
tree23818fc7a58a6de011078b99cc08216859447e41 /sci-libs
parentFix broken autotools handling. (diff)
downloadgentoo-2-9b86ab15d3f59e61f75055236b6e4e1f3285e570.tar.gz
gentoo-2-9b86ab15d3f59e61f75055236b6e4e1f3285e570.tar.bz2
gentoo-2-9b86ab15d3f59e61f75055236b6e4e1f3285e570.zip
Version bump (fixes bug #159888).
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libqalculate/ChangeLog10
-rw-r--r--sci-libs/libqalculate/files/digest-libqalculate-0.9.53
-rw-r--r--sci-libs/libqalculate/libqalculate-0.9.5.ebuild41
3 files changed, 52 insertions, 2 deletions
diff --git a/sci-libs/libqalculate/ChangeLog b/sci-libs/libqalculate/ChangeLog
index 2e9ef91e243f..8641e7f679ba 100644
--- a/sci-libs/libqalculate/ChangeLog
+++ b/sci-libs/libqalculate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libqalculate
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/ChangeLog,v 1.17 2006/09/11 02:18:36 tsunam Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/ChangeLog,v 1.18 2007/01/04 14:55:12 markusle Exp $
+
+*libqalculate-0.9.5 (04 Jan 2007)
+
+ 04 Jan 2007; Markus Dittrich <markusle@gentoo.org>
+ +libqalculate-0.9.5.ebuild:
+ Version bump (fixes bug #159888).
11 Sep 2006; Joshua Jackson <tsunam@gentoo.org> libqalculate-0.9.4.ebuild:
Stable x86; bug #146202
diff --git a/sci-libs/libqalculate/files/digest-libqalculate-0.9.5 b/sci-libs/libqalculate/files/digest-libqalculate-0.9.5
new file mode 100644
index 000000000000..c3dae7842bf7
--- /dev/null
+++ b/sci-libs/libqalculate/files/digest-libqalculate-0.9.5
@@ -0,0 +1,3 @@
+MD5 e4074d9fe54b7a8846a31f3c2cfb7b78 libqalculate-0.9.5.tar.gz 1118827
+RMD160 7839c56e275979157f6bace072d1fc9f500c8953 libqalculate-0.9.5.tar.gz 1118827
+SHA256 f9f40c0753890779cf9507548cc5212961d3c7c4ff699db517f0422e0b5a2b0d libqalculate-0.9.5.tar.gz 1118827
diff --git a/sci-libs/libqalculate/libqalculate-0.9.5.ebuild b/sci-libs/libqalculate/libqalculate-0.9.5.ebuild
new file mode 100644
index 000000000000..ac3ed9069d35
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.9.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/libqalculate-0.9.5.ebuild,v 1.1 2007/01/04 14:55:12 markusle Exp $
+
+DESCRIPTION="A modern multi-purpose calculator library"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE="readline"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+COMMON_DEPEND=">=sci-libs/cln-1.1
+ dev-libs/libxml2
+ >=dev-libs/glib-2.4
+ sys-libs/zlib
+ readline? ( sys-libs/readline )"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ dev-util/intltool
+ sys-devel/gettext"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sci-visualization/gnuplot-3.7
+ net-misc/wget"
+
+src_compile() {
+ # The CLN test is buggy and will often fail though an appropriate version
+ # of the library is installed.
+ CONFIG="$(use_with readline) --disable-clntest"
+ econf ${CONFIG} || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die "Installation failed."
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ dodoc ${DOCS} || die "Documentation installation failed."
+}