summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-31 12:07:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-31 12:07:10 +0000
commit4ef544b39ec80a5d9bac31ca5efa5636635e68a4 (patch)
treed457c1ff87b9f72a8fff257b4937d8851bba05c4 /sci-libs
parentUpdate upstream patch set (diff)
downloadgentoo-2-4ef544b39ec80a5d9bac31ca5efa5636635e68a4.tar.gz
gentoo-2-4ef544b39ec80a5d9bac31ca5efa5636635e68a4.tar.bz2
gentoo-2-4ef544b39ec80a5d9bac31ca5efa5636635e68a4.zip
Re-add addwrite on /opt/intel, needed for a first install
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ipp/ChangeLog6
-rw-r--r--sci-libs/ipp/ipp-6.0.0.063.ebuild10
-rw-r--r--sci-libs/ipp/ipp-6.0.1.071.ebuild10
3 files changed, 17 insertions, 9 deletions
diff --git a/sci-libs/ipp/ChangeLog b/sci-libs/ipp/ChangeLog
index 5ce23044a9e9..a18041f18018 100644
--- a/sci-libs/ipp/ChangeLog
+++ b/sci-libs/ipp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/ipp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ChangeLog,v 1.6 2009/01/27 16:11:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ChangeLog,v 1.7 2009/01/31 12:07:10 bicatali Exp $
+
+ 31 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org> ipp-6.0.0.063.ebuild,
+ ipp-6.0.1.071.ebuild:
+ Re-add addwrite on /opt/intel, needed for a first install
*ipp-6.0.1.071 (27 Jan 2009)
diff --git a/sci-libs/ipp/ipp-6.0.0.063.ebuild b/sci-libs/ipp/ipp-6.0.0.063.ebuild
index bc9f37495fc6..0524ea1b66a0 100644
--- a/sci-libs/ipp/ipp-6.0.0.063.ebuild
+++ b/sci-libs/ipp/ipp-6.0.0.063.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ipp-6.0.0.063.ebuild,v 1.3 2009/01/28 23:02:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ipp-6.0.0.063.ebuild,v 1.4 2009/01/31 12:07:10 bicatali Exp $
inherit check-reqs
@@ -68,13 +68,14 @@ src_unpack() {
# binary blob extractor uses stupid directory
addpredict /usr/local/share/macrovision
-
+ addwrite /opt/intel
cp ${IPP_LICENSE} "${WORKDIR}"/
+ IPP_LICENSE_LOCAL="${WORKDIR}/$(basename ${IPP_LICENSE})"
cat > ipp.ini <<- EOF
ACTIVATION=license_file
CONTINUE_WITH_OPTIONAL_ERROR=yes
PSET_INSTALL_DIR=${S}
- PSET_LICENSE_FILE=${IPP_LICENSE}
+ PSET_LICENSE_FILE=${IPP_LICENSE_LOCAL}
INSTALL_MODE=NONRPM
ACCEPT_EULA=accept
EOF
@@ -98,6 +99,7 @@ src_unpack() {
find . -type d -print0 | xargs --null chmod 755
rm -rf tmp* uninstall.sh
rm -rf "${WORKDIR}"/l_*
+ rm -f /opt/intel/.*ipp*.log /opt/intel/intel_sdp_products.db
}
src_install() {
@@ -107,7 +109,7 @@ src_install() {
# install license file
if [[ ! -f ${INTEL_LIC_DIR}/$(basename ${IPP_LICENSE}) ]]; then
insinto ${INTEL_LIC_DIR}
- doins ${IPP_LICENSE}
+ doins ${IPP_LICENSE_LOCAL}
fi
# cp quicker than doins
diff --git a/sci-libs/ipp/ipp-6.0.1.071.ebuild b/sci-libs/ipp/ipp-6.0.1.071.ebuild
index d05ca413ee62..43e7065b8b2a 100644
--- a/sci-libs/ipp/ipp-6.0.1.071.ebuild
+++ b/sci-libs/ipp/ipp-6.0.1.071.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ipp-6.0.1.071.ebuild,v 1.2 2009/01/28 23:02:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ipp-6.0.1.071.ebuild,v 1.3 2009/01/31 12:07:10 bicatali Exp $
inherit check-reqs
@@ -68,13 +68,14 @@ src_unpack() {
# binary blob extractor uses stupid directory
addpredict /usr/local/share/macrovision
-
+ addwrite /opt/intel
cp ${IPP_LICENSE} "${WORKDIR}"/
+ IPP_LICENSE_LOCAL="${WORKDIR}/$(basename ${IPP_LICENSE})"
cat > ipp.ini <<- EOF
ACTIVATION=license_file
CONTINUE_WITH_OPTIONAL_ERROR=yes
PSET_INSTALL_DIR=${S}
- PSET_LICENSE_FILE=${IPP_LICENSE}
+ PSET_LICENSE_FILE=${IPP_LICENSE_LOCAL}
INSTALL_MODE=NONRPM
ACCEPT_EULA=accept
EOF
@@ -98,6 +99,7 @@ src_unpack() {
find . -type d -print0 | xargs --null chmod 755
rm -rf tmp* uninstall.sh
rm -rf "${WORKDIR}"/l_*
+ rm -f /opt/intel/.*ipp*.log /opt/intel/intel_sdp_products.db
}
src_install() {
@@ -107,7 +109,7 @@ src_install() {
# install license file
if [[ ! -f ${INTEL_LIC_DIR}/$(basename ${IPP_LICENSE}) ]]; then
insinto ${INTEL_LIC_DIR}
- doins ${IPP_LICENSE}
+ doins ${IPP_LICENSE_LOCAL}
fi
# cp quicker than doins