summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-24 10:24:21 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-24 10:24:21 +0000
commit43b9b4aa79dc297e89816fc2931cb6cd70039aef (patch)
tree4dd4c42b252422f9c9112540d52594f5bdcd2c43 /sci-libs
parentVersion bump wrt #205926. (diff)
downloadgentoo-2-43b9b4aa79dc297e89816fc2931cb6cd70039aef.tar.gz
gentoo-2-43b9b4aa79dc297e89816fc2931cb6cd70039aef.tar.bz2
gentoo-2-43b9b4aa79dc297e89816fc2931cb6cd70039aef.zip
Version bump
(Portage version: 2.1.4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-goto/ChangeLog10
-rw-r--r--sci-libs/blas-goto/blas-goto-1.22.ebuild168
-rw-r--r--sci-libs/blas-goto/files/blas.pc.in2
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.223
4 files changed, 180 insertions, 3 deletions
diff --git a/sci-libs/blas-goto/ChangeLog b/sci-libs/blas-goto/ChangeLog
index 969fbd2a1c93..96b6a3218029 100644
--- a/sci-libs/blas-goto/ChangeLog
+++ b/sci-libs/blas-goto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/blas-goto
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.13 2007/10/11 17:38:06 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.14 2008/01/24 10:24:20 bicatali Exp $
+
+*blas-goto-1.22 (24 Jan 2008)
+
+ 24 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> files/blas.pc.in,
+ +blas-goto-1.22.ebuild:
+ Version bump
11 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org>
blas-goto-1.19.ebuild:
diff --git a/sci-libs/blas-goto/blas-goto-1.22.ebuild b/sci-libs/blas-goto/blas-goto-1.22.ebuild
new file mode 100644
index 000000000000..cf7cc2e90268
--- /dev/null
+++ b/sci-libs/blas-goto/blas-goto-1.22.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.22.ebuild,v 1.1 2008/01/24 10:24:20 bicatali Exp $
+
+inherit eutils fortran flag-o-matic toolchain-funcs
+
+MY_PN="GotoBLAS"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Fast implementations of the Basic Linear Algebra Subroutines"
+HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
+SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
+LICENSE="tacc"
+SLOT="0"
+# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
+# for supported architectures
+KEYWORDS="~x86 ~amd64"
+IUSE="threads doc"
+RESTRICT="mirror"
+RDEPEND="app-admin/eselect-blas
+ dev-util/pkgconfig
+ doc? ( app-doc/blas-docs )"
+
+DEPEND="app-admin/eselect-blas
+ >=sys-devel/binutils-2.17"
+
+S="${WORKDIR}/${MY_PN}"
+FORTRAN="g77 gfortran ifc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Set up C compiler
+ if [[ $(tc-getCC) = *gcc ]]; then
+ C_COMPILER="GNU"
+ elif [[ $(tc-getCC) = icc ]]; then
+ C_COMPILER="INTEL"
+ else
+ die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
+ fi
+
+ # Set up FORTRAN 77 compiler
+ case ${FORTRANC} in
+ g77)
+ F_COMPILER="G77"
+ ;;
+ gfortran)
+ F_COMPILER="GFORTRAN"
+ F_LIB="-lgfortran"
+ ;;
+ ifc|ifort)
+ F_COMPILER="INTEL"
+ ;;
+ *)
+ die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
+ esac
+
+ # Fix shared lib build
+ sed -i \
+ -e "s:\(&& echo OK\):${F_LIB} \1:g" \
+ "${S}"/exports/Makefile \
+ || die "sed for shared libs failed"
+
+ # Set up compilers
+ sed -i \
+ -e "s:^# \(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
+ -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
+ -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
+ -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
+ -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
+ "${S}"/Makefile.rule \
+ || die "sed for setting up compilers failed"
+
+ # Threaded?
+ if use threads; then
+ sed -i \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ "${S}"/Makefile.rule \
+ || die "sed for threads failed"
+ fi
+
+ # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
+ if use amd64; then
+ sed -i \
+ -e "s:^# \(BINARY64 = 1\):\1:g" \
+ "${S}"/Makefile.rule \
+ || die "sed for 64 binary failed"
+ fi
+
+ # Respect CFLAGS/FFLAGS
+ if [[ -z "${FFLAGS}" ]]; then
+ ewarn "FORTRAN FFLAGS undefined, using -O2"
+ export FFLAGS="-O2"
+ fi
+
+ sed -i \
+ -e '/^CFLAGS/s:=:+=:' \
+ -e '/^FFLAGS/s:=:+=:' \
+ "${S}"/Makefile.rule \
+ || die "sed for flags failed"
+}
+
+src_compile() {
+
+ # Make static library
+ emake LDFLAGS="$(raw-ldflags)" || die "emake failed"
+
+ # Make shared library
+ cd exports
+ emake so -j1 || die "emake failed"
+}
+
+src_test() {
+ cd test
+ emake || die "emake test failed"
+ make clean
+}
+
+src_install() {
+ local MAIN_DIR="/usr/$(get_libdir)/blas"
+ local DIR="${MAIN_DIR}/goto"
+
+ # dolib.so doesn't support our alternate locations
+ exeinto ${DIR}
+ doexe libgoto_*.so
+ dosym libgoto_*.so ${DIR}/libgoto.so
+ dosym libgoto_*.so ${DIR}/libgoto.so.0
+ dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
+
+ # dolib.a doesn't support our alternate locations
+ insinto ${DIR}
+ doins libgoto_*.a
+ dosym libgoto_*.a ${DIR}/libgoto.a
+
+ dodoc 01Readme.txt 03History.txt 04FAQ.txt
+
+ cp "${FILESDIR}"/blas.pc.in blas.pc
+ local extlibs=""
+ use threads && extlibs="${extlibs} -lpthread"
+ extlibs="${extlibs}"
+ sed -i \
+ -e "s/@LIBDIR@/$(get_libdir)/" \
+ -e "s/@PV@/${PV}/" \
+ -e "s/@EXTLIBS@/${extlibs}/" \
+ blas.pc || die "sed blas.pc failed"
+ insinto /usr/$(get_libdir)/blas/goto
+ doins blas.pc
+ ESELECT_PROF=goto
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.goto ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=blas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}
diff --git a/sci-libs/blas-goto/files/blas.pc.in b/sci-libs/blas-goto/files/blas.pc.in
index 81940962c48a..e0caa5dc2b3a 100644
--- a/sci-libs/blas-goto/files/blas.pc.in
+++ b/sci-libs/blas-goto/files/blas.pc.in
@@ -1,6 +1,6 @@
prefix=/usr
exec_prefix=${prefix}
-libdir=/usr/@LIBDIR@
+libdir=${prefix}/@LIBDIR@
includedir=${prefix}/include
Name: blas
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.22 b/sci-libs/blas-goto/files/digest-blas-goto-1.22
new file mode 100644
index 000000000000..db5d09011b49
--- /dev/null
+++ b/sci-libs/blas-goto/files/digest-blas-goto-1.22
@@ -0,0 +1,3 @@
+MD5 30bf16eac7311a3018628825782d9506 GotoBLAS-1.22.tar.gz 2055354
+RMD160 2eec2605a10e3e6fff1d3db2be21d774f5c0e804 GotoBLAS-1.22.tar.gz 2055354
+SHA256 a5479c4f2e78d3116536675a83df5d2dc23648f90a69babb646b69d02f695d6c GotoBLAS-1.22.tar.gz 2055354