summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-29 11:15:43 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-29 11:15:43 +0000
commit0a3f1129c91e9fd333c153ec27f6e3ec922510fd (patch)
treec176d9f69f8d8a8dd1a67711a415aa82a4dc3d27 /sci-libs/vtk
parentVersion bump (diff)
downloadgentoo-2-0a3f1129c91e9fd333c153ec27f6e3ec922510fd.tar.gz
gentoo-2-0a3f1129c91e9fd333c153ec27f6e3ec922510fd.tar.bz2
gentoo-2-0a3f1129c91e9fd333c153ec27f6e3ec922510fd.zip
Don't use bundled libtheora, moved USE ogg -> theora
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog8
-rw-r--r--sci-libs/vtk/vtk-5.6.0-r2.ebuild (renamed from sci-libs/vtk/vtk-5.6.0-r1.ebuild)12
2 files changed, 15 insertions, 5 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 320f5b93d8a5..6e1559c5b8d5 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.71 2010/05/29 10:13:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.72 2010/05/29 11:15:43 jlec Exp $
+
+*vtk-5.6.0-r2 (29 May 2010)
+
+ 29 May 2010; Justin Lecher <jlec@gentoo.org> -vtk-5.6.0-r1.ebuild,
+ +vtk-5.6.0-r2.ebuild:
+ Don't use bundled libtheora, moved USE ogg -> theora
29 May 2010; Justin Lecher <jlec@gentoo.org> vtk-5.6.0-r1.ebuild:
Added missing DEPS
diff --git a/sci-libs/vtk/vtk-5.6.0-r1.ebuild b/sci-libs/vtk/vtk-5.6.0-r2.ebuild
index 3a389ca9cca8..a13a36b6ff2f 100644
--- a/sci-libs/vtk/vtk-5.6.0-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r1.ebuild,v 1.3 2010/05/29 10:13:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r2.ebuild,v 1.1 2010/05/29 11:15:43 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -19,7 +19,7 @@ SRC_URI="http://www.${PN}.org/files/release/${SPV}/${P}.tar.gz
LICENSE="BSD LGPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="boost cg doc examples java mpi ogg patented python qt4 tcl tk threads R"
+IUSE="boost cg doc examples java mpi patented python qt4 tcl theora tk threads R"
RDEPEND="
mpi? ( virtual/mpi[cxx,romio] )
cg? ( media-gfx/nvidia-cg-toolkit )
@@ -35,6 +35,7 @@ RDEPEND="
examples? (
x11-libs/qt-core:4[qt3support]
x11-libs/qt-gui:4[qt3support] )
+ theora? ( media-libs/libtheora )
R? ( dev-lang/R )
dev-libs/expat
dev-libs/libxml2
@@ -92,13 +93,13 @@ src_configure() {
-DVTK_DATA_ROOT:PATH="${EPREFIX}"/usr/share/${PN}/data
-DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
-DBUILD_SHARED_LIBS=ON
+ -DVTK_USE_SYSTEM_EXPAT=ON
-DVTK_USE_SYSTEM_FREETYPE=ON
-DVTK_USE_SYSTEM_JPEG=ON
+ -DVTK_USE_SYSTEM_LIBXML2=ON
-DVTK_USE_SYSTEM_PNG=ON
-DVTK_USE_SYSTEM_TIFF=ON
-DVTK_USE_SYSTEM_ZLIB=ON
- -DVTK_USE_SYSTEM_EXPAT=ON
- -DVTK_USE_SYSTEM_LIBXML2=ON
-DBUILD_TESTING=OFF
-DBUILD_EXAMPLES=OFF
-DVTK_USE_HYBRID=ON
@@ -121,6 +122,9 @@ src_configure() {
$(cmake-utils_use threads VTK_USE_PARALLEL)
$(cmake-utils_use R VTK_USE_GNU_R) )
+ use ogg &&
+ mycmakeargs+=(-DVTK_USE_SYSTEM_OGGTHEORA=ON)
+
# mpi needs the parallel framework
if use mpi && use !threads; then
mycmakeargs+=(-DVTK_USE_PARALLEL=ON)